?
Solved

auto disconnect on mapped drives

Posted on 2003-11-03
6
Medium Priority
?
2,377 Views
Last Modified: 2007-12-19
I just setup a new workstation that is serving as a server. This PC is running Windows 2000 Professional. I currently have 2 drives that are mapped to another server so that reports that run in the morning can go from one server to another. The problem that I am having is whenever the computer is sitting idle for say 5 minutes it will disconnect the mapped drives where they will have a red X, but if I double click on them the drive reconnects and all is well. How do I resolve this where they will stay connected when the computer is idle? I've already done the below and made sure the HD was NOT set to turn off after a certain period of time.

http://support.microsoft.com/default.aspxcid=http://support.microsoft.com:80/support/kb/articles/q138/3/65.asp&NoWebContent=1
0
Comment
Question by:BMANDEP
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
6 Comments
 
LVL 41

Accepted Solution

by:
stevenlewis earned 2000 total points
ID: 9675545
see if this helps
It was autodisconnect registry setting. The default is to disconnect after being idle for 15 minutes.

I used the command net config server /autodisconnect:-1 which disables autodisconnect and that stopped the remote users from loosing their Mapped Drive.


It is for w2k server, but may work on workstation (professional)
0
 
LVL 24

Expert Comment

by:shivsa
ID: 9675714
make sure auto disconnect is not enabled in

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Servic es\LanmanServer\Parameters

set this value to 0.(mostly it is set to "f").

the command is

net config server /variable ( in your case this autodisconnect).

also check this link for more useful information.
http://www.uwec.edu/Help/Win00/map-drive.html#Map
0
 
LVL 13

Expert Comment

by:rhinoceros
ID: 9675856

Microsoft official Information
http://support.microsoft.com/default.aspx?scid=kb;en-us;Q297684

I hope it can help.
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 41

Expert Comment

by:stevenlewis
ID: 9675917
which confirms what shivsa and myself posted :-)
0
 

Author Comment

by:BMANDEP
ID: 9677917
shivsa, I did what you said about setting the value to 0, but it still auto-disconnected and per Microsoft you are not supposed to set it at 0.
NOTE: If you set the autodisconnect value to 0 (zero), the autodisconnect feature is not turned off, and the Server service disconnects mapped network drives after only a few seconds of idle time.

stevenlewis, I had already tried what you had mentioned, but still did not work.

Any other suggestions?
0
 
LVL 24

Expert Comment

by:shivsa
ID: 9680032
I think i gave u wrong value to set.
In the Value data box, type ffffffff.
It will increase the timeout value on server side, but wil not turnoff the autodisconnect.
to turnoff i think from client side u have to put value = -1.

For example, to set the Autodisconnect value to 30 minutes, you would run the following command line:
net config server /autodisconnect:30

also r u using samba. if yes u might want to upgrade samba to latest, since there are some bugfixes relate to autodiscoonect are there.
-----------------
if nothing of this works then maybe this will help
--------------

START | RUN | gpedit.msc

Local Policies
Security Options
look down the list for "Microsoft Network server: amount of idle time required before suspending session - default = 15 minutes".
Right click and Properties.
Set this to an obscenely large number of minutes.
99,999
next...
on the same list... find:
"Microsoft Network Server: Disconnect clients when logo hours expire". Right click and Properties.
Set at "disabled"


0

Featured Post

New feature and membership benefit!

New feature! Upgrade and increase expert visibility of your issues with Priority Questions.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I don't know if many of you have made the great mistake of using the Cisco Thin Client model with the management software VXC. If you have then you are probably more then familiar with the incredibly clunky interface, the numerous work arounds, and …
Sometimes a user will call me frantically, explaining that something has gone wrong and they have tried everything (read - they have messed it up more and now need someone to clean up) and it still does no good, can I help them?!  Usually the standa…
This is used to tweak the memory usage for your computer, it is used for servers more so than workstations but just be careful editing registry settings as it may cause irreversible results. I hold no responsibility for anything you do to the regist…
Hi friends,  in this video  I'll show you how new windows 10 user can learn the using of windows 10. Thank you.

777 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question