Solved

Dig Cam -> mount: not a valid block device

Posted on 2003-11-03
13
18,380 Views
Last Modified: 2013-12-15
I have a Nikon Coolpix 4300 which I am unable to connect to my RH9.0 system as a mass storage device via USB.
I've tried various statements in fstab, such as:
dev/sda1               /mnt/usb                vfat    noauto,users 0 0
dev/sda1               /mnt/usb                auto    noauto,users 0 0
dev/sda2               /mnt/usb                auto    noauto,users 0 0

But when I try to mount I get the message:
mount: /dev/sda1 is not a valid block device
 
I don't know what the format should be (vfat, ...), but I'm sure there's more to my problem that just this.
What else can I try?

Also, is there a way, other than restarting, to "re-read" /etc/fstab?

0
Comment
Question by:allelopath
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 8
  • 5
13 Comments
 
LVL 12

Expert Comment

by:paullamhkg
ID: 9675707
What happen when you just mount the Dig Cam? mount -t vfat /dev/sda1 /mnt/usb can this work? Can you access other usb device?
0
 
LVL 1

Author Comment

by:allelopath
ID: 9675963
Mount the camera direclty works.
0
 
LVL 12

Expert Comment

by:paullamhkg
ID: 9676499
so try" /dev/sda1   /mnt/usb    vfat    default   0  0 " in your fstab and restart post your result please
0
Ransomware: The New Cyber Threat & How to Stop It

This infographic explains ransomware, type of malware that blocks access to your files or your systems and holds them hostage until a ransom is paid. It also examines the different types of ransomware and explains what you can do to thwart this sinister online threat.  

 
LVL 1

Author Comment

by:allelopath
ID: 9682915
changed fstab as you suggested, but still get the same error when trying to mount:
mount: /dev/sda1 is not a valid block device
0
 
LVL 12

Expert Comment

by:paullamhkg
ID: 9683788
Do you got the error during the linux startup?
0
 
LVL 1

Author Comment

by:allelopath
ID: 9686715
On startup in linux, lots of text flys by, starting this thing, starting that thing, and so on.
Is this stuff written to a log file such that I don't have to watch everything as it flies by?
0
 
LVL 12

Expert Comment

by:paullamhkg
ID: 9691461
you can check the /var/log/dmesg and the /var/log/messages, to see any error on the startup.
0
 
LVL 1

Author Comment

by:allelopath
ID: 9691767
I searched var/log/messages for "sda" on today's logs, only one line:
Nov  5 08:57:56 localhost mount: mount: /dev/sda1 is not a valid block device

No occurences of "sda" in /var/log/dmesg

0
 
LVL 12

Accepted Solution

by:
paullamhkg earned 125 total points
ID: 9691874
I think everytime you start your linux distro the Dig Cam may not be plug into your linux PC right, so the startup havn't detect the device and skip it, so after you plug in you need to mount the /mnt/usb this should remoun the Cam for you, have you try this? or it give you the same error?
0
 
LVL 12

Expert Comment

by:paullamhkg
ID: 9692413
I think what I going to do is as below

for the /etc/fstab, I will add

/dev/sda1               /mnt/usb                vfat    noauto,users 0 0

so that everytime you linux distro will mount the /dev/sda1 to the mount point /mnt/usb, but will not mount the device (Dig Cam), after that everytime you plug in your Dig Cam, run 'mount /mnt/usb' should mount your Dig Cam even a ordinary user.

0
 
LVL 12

Expert Comment

by:paullamhkg
ID: 9692418
remember everytime when you wanted to unplug your Dig Cam, run 'cd /' than 'umount /mnt/usb' to unmount the Dig Cam before unplug this will be better.
0
 
LVL 1

Author Comment

by:allelopath
ID: 9698492
i think you're right, the camera has to be plugged in and turned on in order for it to work
(without mounting it directly)
kinda lame, but this is a perfect example of why linux for the desktop is not there yet.

i've noticed a strange thing...whenever i turn off the camera (while it is still plugged in the usb)
the floppy drive tries to read...
0
 
LVL 12

Expert Comment

by:paullamhkg
ID: 9698545
<i've noticed a strange thing...whenever i turn off the camera (while it is still plugged in the usb)
the floppy drive tries to read...>

I'm not so sure about this, it may be while you shutdown your Cam the OS try to xWindows try to search, and read every device including the floppy.
0

Featured Post

Free learning courses: Active Directory Deep Dive

Get a firm grasp on your IT environment when you learn Active Directory best practices with Veeam! Watch all, or choose any amount, of this three-part webinar series to improve your skills. From the basics to virtualization and backup, we got you covered.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
LINUX backups with VEEAM 8 160
linux 13 109
php56-php-mcrypt for rhel7 php56 1 111
Looking for a program called HoneyMine. 3 72
Daily system administration tasks often require administrators to connect remote systems. But allowing these remote systems to accept passwords makes these systems vulnerable to the risk of brute-force password guessing attacks. Furthermore there ar…
This is the error message I got (CODE) Error caused by incompatible libmp3lame 3.98-2 with ffmpeg I've googled this error message and found out sometimes it attaches this note "can be treated with downgrade libmp3lame to version 3.97 or 3.98" …
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.

730 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question