Dig Cam -> mount: not a valid block device

I have a Nikon Coolpix 4300 which I am unable to connect to my RH9.0 system as a mass storage device via USB.
I've tried various statements in fstab, such as:
dev/sda1               /mnt/usb                vfat    noauto,users 0 0
dev/sda1               /mnt/usb                auto    noauto,users 0 0
dev/sda2               /mnt/usb                auto    noauto,users 0 0

But when I try to mount I get the message:
mount: /dev/sda1 is not a valid block device
I don't know what the format should be (vfat, ...), but I'm sure there's more to my problem that just this.
What else can I try?

Also, is there a way, other than restarting, to "re-read" /etc/fstab?

Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

What happen when you just mount the Dig Cam? mount -t vfat /dev/sda1 /mnt/usb can this work? Can you access other usb device?
allelopathAuthor Commented:
Mount the camera direclty works.
so try" /dev/sda1   /mnt/usb    vfat    default   0  0 " in your fstab and restart post your result please
10 Tips to Protect Your Business from Ransomware

Did you know that ransomware is the most widespread, destructive malware in the world today? It accounts for 39% of all security breaches, with ransomware gangsters projected to make $11.5B in profits from online extortion by 2019.

allelopathAuthor Commented:
changed fstab as you suggested, but still get the same error when trying to mount:
mount: /dev/sda1 is not a valid block device
Do you got the error during the linux startup?
allelopathAuthor Commented:
On startup in linux, lots of text flys by, starting this thing, starting that thing, and so on.
Is this stuff written to a log file such that I don't have to watch everything as it flies by?
you can check the /var/log/dmesg and the /var/log/messages, to see any error on the startup.
allelopathAuthor Commented:
I searched var/log/messages for "sda" on today's logs, only one line:
Nov  5 08:57:56 localhost mount: mount: /dev/sda1 is not a valid block device

No occurences of "sda" in /var/log/dmesg

I think everytime you start your linux distro the Dig Cam may not be plug into your linux PC right, so the startup havn't detect the device and skip it, so after you plug in you need to mount the /mnt/usb this should remoun the Cam for you, have you try this? or it give you the same error?

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
I think what I going to do is as below

for the /etc/fstab, I will add

/dev/sda1               /mnt/usb                vfat    noauto,users 0 0

so that everytime you linux distro will mount the /dev/sda1 to the mount point /mnt/usb, but will not mount the device (Dig Cam), after that everytime you plug in your Dig Cam, run 'mount /mnt/usb' should mount your Dig Cam even a ordinary user.

remember everytime when you wanted to unplug your Dig Cam, run 'cd /' than 'umount /mnt/usb' to unmount the Dig Cam before unplug this will be better.
allelopathAuthor Commented:
i think you're right, the camera has to be plugged in and turned on in order for it to work
(without mounting it directly)
kinda lame, but this is a perfect example of why linux for the desktop is not there yet.

i've noticed a strange thing...whenever i turn off the camera (while it is still plugged in the usb)
the floppy drive tries to read...
<i've noticed a strange thing...whenever i turn off the camera (while it is still plugged in the usb)
the floppy drive tries to read...>

I'm not so sure about this, it may be while you shutdown your Cam the OS try to xWindows try to search, and read every device including the floppy.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.