Solved

Router not mailing

Posted on 2003-11-04
24
4,317 Views
Last Modified: 2013-11-30
Recently I switched from cable to ADSL.

Under "cable", I had a D-Link DI-614+ router connected to the modem, using PPPoE. It's firmware was upgraded to the latest version (2.20).
All PC's and the router used the correct provider's smtp server. All outgoing mail arrived as expected, including the router's logs.

Now the router is connected to my Alcated Speedlink 530 ethernet modem (1 port). I changed SMTP servers and PC's appear to send mail correctly. The router itsef however fails sending mail (haven't got much info other than a message like "Failed sending mail").

What could be wrong?

As far as I know I have no restrictions in SMTP ports (both the modem and the router have a firewall).
The modem has internal IP address 10.0.0.138 and assigns 10.0.0.150 to the router.
The router uses 192.168.0.1 internally and all PC's have adresses in that range (.150 - .250).

The ADSL connection is by KPN (for any dutch readers), and is appearently using PPTP. My knowledge is very limited on that (none!). I have connected the router to the modem using an "ethernet" connection type (not PPPoE, not PPTP). No problems using mail, MSN, browsing, FTP etc. from a PC. Only SMTP from the router.
0
Comment
Question by:CRAK
  • 12
  • 8
  • 4
24 Comments
 
LVL 35

Accepted Solution

by:
ShineOn earned 250 total points
ID: 9679725
Do you know the address of the mail server?  Can you ping that address?  Have you tried to telnet to port 25 on that address?  Does the d-link router have any firewalling features enabled?
0
 
LVL 13

Author Comment

by:CRAK
ID: 9682180
The server (smtp.zonnet.nl) doesn't respond to pinging: it times out. Sending mail from the same PC to that server still works!

Telnet connection (using Hyper terminal in XP) to the server (port 25) responded "220 postbode02.zonnet.nl ESMTP" (postbode is dutch for the guy that delivers mail to your door). Don't know what this means, didn't know what to do with this connection. Disconnected again.

The routers firewall has following enries:
Allow NetBios, Source *,192.168.0.2-192.168.0.254, Dest *,(same range), protocol IP (0), 135-139
Allow Oracle, Source *.(same range), Dest *,(same range), protocol IP (0), 1521
Deny Default, Source *,*, Dest LAN,*, IP (0),*
Allow Default, LAN,*, Dest *,*, IP (0),*
(in that order; the bottom two are the devices defaults and can not be altered, I added the first two, schedule: always and enabled)

Options for Source/Dest are *, WAN or LAN + IP range.
Options for Protocol are TCP, UDP, ICMP or * + port range
0
 
LVL 35

Expert Comment

by:ShineOn
ID: 9682269
Someone else will have a better answer than I.  I don't know d-link router configuration.  My guess is that you need to change something in your router config.
0
 
LVL 13

Author Comment

by:CRAK
ID: 9682417
So far you're the only one answering. Guess who provived the best options so far?.....

A correction on the router's "WAN" settings:
I'm using "Dynamic IP adres", supplying host name (DI-614+), MAC address, Pri/Sec DNS address (10.0.0.138 resp. 0.0.0.0) and "MTU"(?) = 1500.

PPTP would require IP address, subnet mask, server IP, PPTP account, PPTP password + retype, max idle time, "MTU" and auto reconnect (enable/disable).

I'll raise points to attact a wider audience, but please don't let me down!?
0
 
LVL 35

Expert Comment

by:ShineOn
ID: 9683161
Assuming you have WinXP, I also assume you have gone here for the "quick-install" documentation:

http://support.dlink.com/products/view.asp?productid=DI-614%2B#

0
 
LVL 35

Expert Comment

by:ShineOn
ID: 9683315
When you ping the SMTP server, does the name resolve to an IP address?
0
 
LVL 9

Expert Comment

by:svenkarlsen
ID: 9683359
Are you stil using the same router (D-Link DI-614+ router) ?

--> PC's appear to send mail correctly.
 ?? Only 'appears'  or have you verified (e.g. create a free mail account somewhere out there, and use it for verification)

--> The router itsef however fails sending mail (haven't got much info other than a message like "Failed sending mail").

did you get that msg from the router ?

Basics:
have you tried reverting to using only the cable modem + 1 Win XP box and verifying mail transport is ok at that level?

are you able to browse internet problemfree from all boxes inside ?

have you upgrade modem and router firmware to latest versions ?
0
 
LVL 13

Author Comment

by:CRAK
ID: 9684650
The installation manual was included with the device. Didn't go through it again, since everything else worked....
I don't trust this PPTP thing though. I noticed on several ADSL providers forums that a lot of people have trouble installing a router behind the modem. PPTP is often mentioned, hardly ever supported by the router (I needed the firmware upgrade) and most people don't seem to get it to work in any way.

Ping did resolve the IP address.

"Appears"... probably a language problem. Mail was sent and received correctly.

Part of the log:
Nov/03/2003 10:21:49  SMTP: sending mail fail    
Nov/03/2003 09:55:44  DHCP Request success   10.0.0.150
Nov/03/2003 09:55:44  DHCP Request   10.0.0.150
Nov/03/2003 09:21:49  SMTP: sending mail fail    
Nov/03/2003 08:55:44  DHCP Request success   10.0.0.150

Pc connected directly to modem works fine. Either way no problems detected while surfing etc. Im typing this while online through the router's WiFi connection...
PC's are either XP or 98.

I noticed that there is a newer firmware version, but D-link reccommends to upgrade only in case of "connectivity issues". I don't thinks that's the case.
The modem itself logs in on www though: he's got the account + password; not the router.

(Shineon... thanks for staying around!)
0
 
LVL 9

Expert Comment

by:svenkarlsen
ID: 9685731
Just trying to clarify:

you actually have any problems mailing from the computers in any setup, it's just the router that gives that report ?

what mail are you expecting the router to send ? (firewall/administrative reports ?)

If you are expecting the router to mail you:  have you configured the router with an e-mail address where it should send administrative msg's and the address for an SMTP server ?

0
 
LVL 9

Expert Comment

by:svenkarlsen
ID: 9685735
Sorry, typo:


> you don't actually have any problems mailing from the computers in any setup, it's just the router that gives that report ?
      ----^----
0
 
LVL 13

Author Comment

by:CRAK
ID: 9685958
That's right: I DON'T have an actual problem, expect when the router itself generates an email.
The mail address remains unchanged. I already used it under the cable account. It's the same account where my EE notifications arrive. It's a free account at the ADSL provider.
I DID change the smtp server from my cable providers one to the ADSL providers one.

The router could periodically send mail (containing the entire log) or do so when attacks occur. E.g. I previously (cable) received some mails that the router received some "ping of death"'s and that those packages were ignored.
0
 
LVL 9

Expert Comment

by:svenkarlsen
ID: 9686480
ok, - then perhaps the router is not configured to have a hostname and a domain? Some mailservers will reject mail from an unverifiable sender.
0
What Should I Do With This Threat Intelligence?

Are you wondering if you actually need threat intelligence? The answer is yes. We explain the basics for creating useful threat intelligence.

 
LVL 13

Author Comment

by:CRAK
ID: 9686739
All PC's are internally 192.168.0.x, so is the router.
NAT (router) would translate everything to 10.0.0.150 and pass it on to the modem (10.0.0.138).
From there (after NAT in the modem) all traffic as seen from the provider is "native" to their systems.
0
 
LVL 9

Expert Comment

by:svenkarlsen
ID: 9687397
I don't think we have to consider the IP scheme on this problem, I am fairly sure it's a name-related probem of some sorts.

You can try telnetting your router and ping the smtp by name and see if it resolves, - this will verify dns configuration of router.

If the router has some facility for telnet or similar (from within a telnet session to the router), then you can try doing a manual mail delivery´(open a session to your mailserver on port 25/SMTP and write (don't mind the lack of echo):

helo origin.com
mail from:pbox@origin.com
rcpt to:pbox@target.com
data
test test
.
quit

Replace domain names with valid domain names and pbox at target with valid accounts (from pbox can be anything).

0
 
LVL 13

Author Comment

by:CRAK
ID: 9690202
I don't see how a can feed that to the router, but I tried it on a wireless notebook...
Neat trick! I don't know what happened, but I think I just killed the smtp server. It's now returning a "permanent error" to my mail program (Lotus Notes)....
Don't tell anyone... and don't put the confession online please!?
;-))
0
 
LVL 13

Author Comment

by:CRAK
ID: 9690281
At www.dlink.com > support > DI 614+ > 2 antenna type you'll find a simulation of the router. Perhaps its any help to discover what it can/can't do....
0
 
LVL 9

Expert Comment

by:svenkarlsen
ID: 9691169
Don't worry CRAK: an SMTP server should be able to handle it self, even if you mistype a few words. I see no mallicious (is that how it's spelled?) behaviour in sending a mail 'by hand', - after all: that's how it all started, and we still basically run by the same principles no matter how flashy your GUI gets!

Anyhow, - did you try to ping the SMTP while telnet'ed into the router ?
0
 
LVL 13

Author Comment

by:CRAK
ID: 9692886
Hang on....
"...telnet'ed into the router...": I was connecting to smtp.zonnet.nl. Straight through the router + modem. Should I have connected to the router only (as 192.168.0.1?). Can you please tell what the "helo" instruction does, so I can determine what to fill out there?

No sorry, I telnet'ed, disconnected after a while an pinged separately. Didn't understand I had to do those simultaneously (we should have a spelling checker at EE, don't you think?). Will try again tonight. I'm at work right now.
0
 
LVL 9

Assisted Solution

by:svenkarlsen
svenkarlsen earned 250 total points
ID: 9693584
CRAK,
don't worry, - old stuff is always messy to fiddle with ;-)

So: yes, - I meant that you should try doing it while telnet'ed to the router, simulating that it is the router mailing.

The 'helo' stuff is not always required, - today various practices apply, but it's civil behaviour to use it.

The text you enter should be (exactly, - notice the '.' on a line by itself):

helo origin.com
mail from:pbox@origin.com
rcpt to:pbox@target.com
data
test test
.
quit

helo: 'origin' means whatever a dns-lookup for your outside IP would return. You get this info by (from a cmd-box):
> nslookup
> server [public ns]
> set type=PTR
> [public IP]
..
.. (here comes the reply)
..
> exit

[public ns] = IP of one of the public nameservers you use (no brackets!)
[public IP] = your public IP (no brackets!)

You will probably get an answer of 5-10 lines. What you are looking for is "name = ". The name can be quite a long string.
Many mail-servers do a ns-lookup to verify the caller.
       
You can try doing it without the helo, and use 'test.dummy.com' as [origin.com] in the "mail from:" line. It will not always work, as some mail-servers require either the helo or a valid originator-domain (or both).

 . . . . . . anyhow: lot's of instructions from me here, but no help in it ;-) Remember to test the nslookup from the router (i.e. when you are in a telnet session) or get some IP-status in same situation, to make sure it knows a valid name-server.

0
 
LVL 13

Author Comment

by:CRAK
ID: 9697318
Both with and without a telnet session open, pinging smtp.zonnet.nl returns 62.58.50.46, but all requests timed out.
0
 
LVL 9

Expert Comment

by:svenkarlsen
ID: 9698081
Well, - unfortunately that only tells us that the  router has dns setup ok, - the missing reply from the SMTP may be due to a deactivation of IGMP at their end.

Do you get a ping-reply from the SMTP from other places ?
0
 
LVL 13

Author Comment

by:CRAK
ID: 9699477
I'm at work again. Same result on ping here. Can't connect to the server though since I'm not on one of their IP adresses (I guess). At home I tried an 98 PC over WiFi and an XP one wired. Same result.

I'm still wondering... could the (not chosen) tunneling protocol have anything to do with it? What is it anyway?
0
 
LVL 13

Author Comment

by:CRAK
ID: 9718126
D-link advised me to lower MTU (currently 1500) in steps of 100.
Meanwhile I found another two switches to log some more. I now get these failures when the router attempts to generate e-mail itself:
SMTP: unexpected reply: 451 See http://pobox.com/~djb/docs/smtplf.html

I've sent this info back to D-Link. I suspect the new firmware. Agree?
0
 
LVL 13

Author Comment

by:CRAK
ID: 10833976
I didn't realize thisone was still open....

D-link has released new firmware. I understood that I should download from the UK site, not the US one (I think I did previously). Will try that once I've generated the required energy for it (and some spare time left).

Meanwhile I used a different workaround: my causin has got a mail server of his own. He now accepts mail from my IP address. Clients still connect to smtp.zonnet.nl. The router to my causin's server.

Solved for now (though I'm still not entirely satisfied), but now I need a hand on a different thing.....
What do I do with the 500pt? Not a refund after all the time you've spent....
Are the two of you still around?
0

Featured Post

What Security Threats Are You Missing?

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

We recently endured a series of broadcast storms that caused our ISP to shut us down for brief periods of time. After going through a multitude of tests, we determined that the issue was related to Intel NIC drivers on some new HP desktop computers …
Meet the world's only “Transparent Cloud™” from Superb Internet Corporation. Now, you can experience firsthand a cloud platform that consistently outperforms Amazon Web Services (AWS), IBM’s Softlayer, and Microsoft’s Azure when it comes to CPU and …
Viewers will learn how to properly install and use Secure Shell (SSH) to work on projects or homework remotely. Download Secure Shell: Follow basic installation instructions: Open Secure Shell and use "Quick Connect" to enter credentials includi…
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now