DSL Modem has built-in firewall?

I recently moved and changed DSL services to BellSouth.  The router i recieved was a Westell.  The problem is, I can't allow other users to recieve files from me, or have other users connect to my servers.  In XP, ipconfig shows my IP as 192.168.1.97, which im guessing is a network address.  The only way to get my real ip is to go to a site like "www.whatismyip.com" and check it.  I have a software firewall, Norton Internet Security, but know this is not the problem because it never did this on the last service and the problem still exists with it disabled.  Is there a way to disable the firewall on the modem to allow incoming connections?
andy8pittsAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JFrederick29Commented:
Do you have a router on your network?  or is your DSL plugging directly into your computer?  

If you do not have a router on your network, it sounds like the way your ISP has their network configured.  They are assigning you a private IP address via NAT.  The public IP address you see at www.whatismyip.com is not actually mapped to your computer therefore like you said people can not connect to your computer or servers.  If this is the case, you need to contact your ISP to have them provide you a pubic IP address or have them setup static mappings to your private IP address.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
andy8pittsAuthor Commented:
Thanks for the response JFrederick29!  I do have a router, but it never did this with the old company, so i doubt it is the problem.  I guess the only thing to do is pay $5 more per month for a static ip :(...Thanks for the help!
0
JFrederick29Commented:
Well you could setup static NAT's on your router to map to your internal computers based on specific ports.  Take a look in your router to see if you can map based on ports.
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

andy8pittsAuthor Commented:
How would i know if this is possible to do, and how would i do it?
0
JFrederick29Commented:
What model of router do you have?  Let me know and I can maybe assist...

You could also look in the manual for the router, it should be under the NAT and PAT section.
0
andy8pittsAuthor Commented:
I seem to have misplaced the manual for the router...It's fairly old, a Networth Ethernext Microhub.  The model # is 0D100D52 . Thanks.
0
JFrederick29Commented:
Oh well that is a hub, not a router :)

You would have to buy a DSL router, then you could setup port forwarding.  Linksys is the most popular brand and is relatively cheap.  I would go that route then to buy a second static IP from your ISP.
0
andy8pittsAuthor Commented:
One more question...I need to change the channel for my wireless access point (D-Link DWL-900AP+).  In the manual, it says to connect to it through http://192.168.0.50/ in a web browser.  I try it, and get the "page cannot be found" message.  I cannot connect to this through a wired pc into the hub, nor with a computer wirelessly connected through the Access Point.  Is there a way to view all IP's used by a network to figure out which one it is assigned to?
0
JFrederick29Commented:
I know its tedious but you could ping starting at 192.168.0.1 and work your way up the range.  Are you able to ping 192.168.0.50 or does it time out?
0
andy8pittsAuthor Commented:
Request timed out.

It's timing out on 192.168.0.50...I also tried pinging everything from 192.168.0.1 to 192.168.0.100 with no success...Any suggestions?
0
JFrederick29Commented:
Maybe you could reset your access point to its factory settings.  Of course this will erase any configuration you have done on it if any.  The manual should explain how to do that.  Once you reset the access point, you could try connecting to 192.168.0.50 again.
0
andy8pittsAuthor Commented:
Tried doing a hard reset (hold reset button on back of AP for 30 seconds)...Didn't help....
0
JFrederick29Commented:
Are you trying to access it wirelessly or are you plugging into it?  Try plugging into it and see if that works.  Also, although its a pain, I would ping from 192.168.0.100-254 to complete the range.  Not sure if it is a communication problem though between your computer and the access point.  Hard to say...
0
andy8pittsAuthor Commented:
Tried plugging directly into the port in the back of the AP from my computer.  Nothing...I'll try pinging the higher numbers...Thanks.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Broadband

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.