Editing Tools ? VI ? Pico ? NotedPad?

Posted on 2003-11-04
Medium Priority
Last Modified: 2013-12-13
This is weird, I use Vi and Notedpad(if in windows)
I used to copy the file to my windows machine and edit it using notepad ..and upload to linux box.
I use vi .. to open it .. and it's perfecly fine , except I noticed there is
[converted] [dos] message in the bottom of the screen.

then I try to use PICO to open it , it failed to display it's just display 1 symbol
looks like "y".

I wonder why note pad in myhome is not compatible with Vi and Pico? but Note pad in my school ... is compatible
is there any different type of noted pad?

or is it a vIrus ? ...  

Question by:wilslm
  • 3
  • 2

Expert Comment

ID: 9680267
Windows uses a different convention for newlines (CRNL instead of NL). There are the tools dos2unix and unix2dos to convert between dos/unix format.

Author Comment

ID: 9680443
you mean ^M?
in Pico they will get rid of ^M ...
this is nothing display except a symbol look like "Ym"

for example
test ^M -> this is windows if you try to open it in VI?
right ?



Expert Comment

ID: 9680447
open the file with vi  and then type :

:set ff=unix

save and close the file

the file is now set to a unix file (just like every new file you make)

 so it should work in pico

this is done bij the windows editor notepad or what ever you use and vi detects this
and with this command you convert it back to the original setting

greetz mr_rabit
A proven path to a career in data science

At Springboard, we know how to get you a job in data science. With Springboard’s Data Science Career Track, you’ll master data science  with a curriculum built by industry experts. You’ll work on real projects, and get 1-on-1 mentorship from a data scientist.


Author Comment

ID: 9680527
download the file ... the open it using Vi editor ... then try use Pico ...

you will see what i mean ...


this is not emergency .. but I am just curious .. because 5 file on my project .. become like that ...

thanks dude

Expert Comment

ID: 9680590
It looks like your file is in unicode, not ascii.

Accepted Solution

mtmike earned 1000 total points
ID: 9681726
I don't know of a tool to convert from unicode to ascii, but you can simply delete the extraneous non-ascii characters to get the file contents:

cat search.test | tr -d '\000''\200\377'

You can probably configure your notepad to save in ascii.

Featured Post

Build your data science skills into a career

Are you ready to take your data science career to the next step, or break into data science? With Springboard’s Data Science Career Track, you’ll master data science topics, have personalized career guidance, weekly calls with a data science expert, and a job guarantee.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

I. Introduction There's an interesting discussion going on now in an Experts Exchange Group — Attachments with no extension . This reminded me of questions that come up here at EE along the lines of, "How can I tell the type of file from its cont…
This article will show you step-by-step instructions to build your own NTP CentOS server.  The network diagram shows the best practice to setup the NTP server farm for redundancy.  This article also serves as your NTP server documentation.
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
This tutorial covers a step-by-step guide to install VisualVM launcher in eclipse.

622 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question