Solved

Steaming Windows Media Server

Posted on 2003-11-04
6
1,052 Views
Last Modified: 2008-01-09
I am trying to be able to stream media from my web site.  The current config is 2 servers, one an IIS 6.0 for web site, and the other Windows Media Server.  Everything seems fine.  I can click on the link to the .asx file and everything works as planned as long as I am on my local LAN.  However Windows Media will not connect to server on the internet, the error message for WMP is .0xC00D1198: Cannot connect to the server.
  The .asx file reads mms://web-23/playlist.asx.  I am behind a firewall, and have a cable modem, I am currently forwarding ports to servers for services they run.  I am not sure what port I may have to open, or if this is a DNS type issue, since I do not host my own external DNS presence, would the Streaming server also need a dns record, and how would I point to this server.  Hope someone will be able to make sense of this.  Thanks
0
Comment
Question by:simprick
6 Comments
 
LVL 7

Expert Comment

by:daniel_c
ID: 9682452
0
 
LVL 2

Author Comment

by:simprick
ID: 9683786
Thanks for response, I saw this article, but it does not apply.
0
 
LVL 17

Assisted Solution

by:Tacobell777
Tacobell777 earned 250 total points
ID: 9685638
0
Comprehensive Backup Solutions for Microsoft

Acronis protects the complete Microsoft technology stack: Windows Server, Windows PC, laptop and Surface data; Microsoft business applications; Microsoft Hyper-V; Azure VMs; Microsoft Windows Server 2016; Microsoft Exchange 2016 and SQL Server 2016.

 
LVL 2

Author Comment

by:simprick
ID: 9686536
Saw this article to and have set those settings on the client and my firewall, still get message cannot connect to server.
0
 
LVL 8

Accepted Solution

by:
heskyttberg earned 250 total points
ID: 9693254
Hi!

Have you forwarded all ports from firewall to media server ?
 In: UDP between port 1024-5000 (Only open the necessary number of ports.)
All porst between 1024 and 5000 needs to be forwarded to the mediaserver, unless you force it to use only one port, which is disabled by default.

/Hasse
0
 
LVL 2

Author Comment

by:simprick
ID: 9703784
I have forwarded the correct ports, although I did not forward all I have told the server what ports to use.  I have got it to work on the internet, however I am not able to access it though our corporate firewall,  I know I could stream on port 80, but I already have that port forwarded to the web server.  I am going to say this is done.  I thank you all for your help.

Rick
0

Featured Post

Enterprise Mobility and BYOD For Dummies

Like “For Dummies” books, you can read this in whatever order you choose and learn about mobility and BYOD; and how to put a competitive mobile infrastructure in place. Developed for SMBs and large enterprises alike, you will find helpful use cases, planning, and implementation.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Debug Tools to analyse IIS process: This article focus on taking memory dumps from IIS to determine which code is taking more time and to analyse which calls hangs/causes more CPU usage. To take dumps,download the following. Install1: To st…
A phishing scam that claims a recipient’s credit card details have been “suspended” is the latest trend in spoof emails.
This Micro Tutorial will give you a basic overview how to record your screen with Microsoft Expression Encoder. This program is still free and open for the public to download. This will be demonstrated using Microsoft Expression Encoder 4.
This video shows how to use Hyena, from SystemTools Software, to bulk import 100 user accounts from an external text file. View in 1080p for best video quality.

776 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question