Can not start OracleTNSListener and OracleAgent

hello everyone,  

I have recently installed Oracle9i ( on a Windows 2000 server. Before installing the latest patch, everything was fine and all services were up and running.
After installing the patch to upgrade to Oracle I could not longer start the Oracle9iTNSListener and the Oracle9iAgent. I have not created a dB instance yet as I was about to so and now I can't. would anyone have an idea as to what may be wrong? many thanks!!.

Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

What is the error you are getting when you try to start it up?  Does it just time out?  Have you looked at the log file in the listener directory to see if there are any errors there?
Mark GeerlingsDatabase AdministratorCommented:
Without some more specifics from you, it is difficult to trouble shoot this.  Oracle9.2.0.4 certainly works on Windows2000 - I have that combination.  Have you tried rebooting?  If you try to start the Oracle service from a DOS prompt, what happens?  The syntax is:
net start [service_name]

For the listener, it is:
lsnrctl start

lsnrctl status

lsnrctl stop
MetroNYAuthor Commented:
oh, sorry, ok, here's what happens:
the service just times out
I tried the Net Start and still times out
when I try to run the Oracle commands (any command), I get an error that says some information is missing from dynamic library Oranls9.dll.  I don't know much about this file and what it does. I hope some of this information is useful.

Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

Mark GeerlingsDatabase AdministratorCommented:
I'm not familiar with that Ora*.dll file.  Have you tried starting the listener from a DOS prompt?  Have you rebooted since installing the patch?
MetroNYAuthor Commented:
yes..I rebooted multiple times...and I did try the

lsnrctl start
lsnrctl status

from the DOS prompt...and still nothing...I am beginnig to wonder if the upgrade process went wrong. I think I'll try to reinstall it or something...and the first thing I upgraded was the Universal installer, so it had no reason to complain...I'll try again...

Mark GeerlingsDatabase AdministratorCommented:
You tried:
lsnrctl status

and the response was "nothing"?  I find that hard to believe.  I would expect either a DOS/Windows "bad command or file name" message or some kind of response from the Oracle listener.  Here's what I get from my PC (with the listener not started):
C:\>lsnrctl status

LSNRCTL for 32-bit Windows: Version - Production on 05-NOV-2003 08:28:44

Copyright (c) 1991, 2002, Oracle Corporation.  All rights reserved.

TNS-12541: TNS:no listener
 TNS-12560: TNS:protocol adapter error
  TNS-00511: No listener
   32-bit Windows Error: 2: No such file or directory
TNS-12541: TNS:no listener
 TNS-12560: TNS:protocol adapter error
  TNS-00511: No listener
   32-bit Windows Error: 61: Unknown error


- - -(end of pasted output from "lsnrctl status") - - -

Maybe you are best off doing a complete uninstall and re-install.  There is no automated way to do a thorough uninstall, you have to do at least part of it manually.  I find it fastest to do the complete uninstall manually.

1. Open the "Services" windows and stop any/all Oracle-related services.
2. From Windows Explorer:
  a. delete the Oracle_home directory tree
  b. delete the C:\Program files\Oracle directory tree
3. Run Regedit:
  a. go to Hkey-Local-Machine, Software and remove the Oracle key
  b. go to Hkey-Local-Machine, System, CurrentControlSet, Services and remove the "Oracle..." entries
4. Remove any Oracle-related directories from your search path.  To do this:
right-click "My Computer"
choose Properties, then click the Advanced tab
In the "System Variables" area, scroll to "Path", click "Edit", then remove the two entries:
Save the changes, then reboot and re-install Oracle.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
MetroNYAuthor Commented:
well, the response when I ran the "lsnrctl status" command was a pop up and it said that some information is missing from dynamic library Oranls9.dll.  and now I can not reproduce the error message because the network admin wiped out the server and starterd over.  The server was new and we were trying to install 9i.  I will try the entire install process again and upgrade and I will post any results I obtain. Thank you for your help.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Oracle Database

From novice to tech pro — start learning today.