Solved

2 XP pro based computers with ICS doesn't have "My Network Places" recognization.

Posted on 2003-11-04
41
1,019 Views
Last Modified: 2010-04-11
This is the second time i'm giving this quesation , That's cause of it havn't realy fixed.

Clues :

There is an Internet connection sharing active and works superb , Ping , Games , everthing working but "My Network Places"!.

1 adapter is IBM etherjet and the other one is 3com's adapter.

Almost all services are working , Please right down if you some info bout services that should be enabled/disabled.

Motherboard - Asus P4P800 deluxe , Proccesor - Intel P4 proccesor.

SP1 for XP Pro in both computers


Please help me to get rid of this problem , The bounty is high and the time is short.

Thanks in advance.
0
Comment
Question by:ShadowRack
  • 17
  • 10
  • 4
  • +4
41 Comments
 

Assisted Solution

by:Malc2003
Malc2003 earned 200 total points
ID: 9681636
This sounds like the same problem I have been having for ages also!! see -
http://www.experts-exchange.com/Networking/Q_20785348.html#9665840
I gave up in the end!! I have now bought a router and the problem is solved, I would love to know why it didn't work but no one seemed to know for sure.  I found that I could use either ICS or File+Printer sharing but not both together. Also to switch between the 2 I had to keep using IPCONFIG to renew the NIC's IP address, crazy.

Malc
0
 
LVL 35

Expert Comment

by:ShineOn
ID: 9682097
Have you checked into the firewalling features of WinXP to see if that is blocking the connection between your PC's?
0
 
LVL 35

Expert Comment

by:ShineOn
ID: 9682115
Do you have any file and print sharing enabled?  If not, that could be your issue.  ICS and file and print sharing are 2 different functions.  One allows you to use a computer's internet connection, the other allows you to share files and printers between 2 (or more) different PC's.
0
 
LVL 35

Expert Comment

by:ShineOn
ID: 9682161
Re: Malc2003's link - I'm wondering about the USB part.  It could be that somehow Windows interpreted the USB modem as a NIC and screwed up the provider order and binding order.  The only other explanation would be that Windows now automatically disables file/print sharing when ICS is in use, as a security measure.  If so, they shouldn't do that - it would be adding yet another PITA on top of all the other ones...
0
 

Author Comment

by:ShadowRack
ID: 9682324
1. Thank you for the prompt replys

2. No , I'ts not working either if the firewall is on/off , Altough zonealarm is crazy sometimes.

3. Yes , File and printer sharing is enabled in both computers.
0
 

Expert Comment

by:Malc2003
ID: 9682611
Does My Network places work OK if you disable ICS? You will probably have to renew the NIC IP address or reboot to check.  If it does work with ICS Disabled then this surely points to the same type of conflict as I had.  What type of Internet connection are you using and which ISP?

Malc
0
 
LVL 4

Expert Comment

by:Wiired
ID: 9682875
try disabling simple file sharing
0
 
LVL 41

Assisted Solution

by:stevenlewis
stevenlewis earned 130 total points
ID: 9683697
XP home or Pro
NetBios over tcp enabled?
using dhcp from the router?
0
 
LVL 6

Expert Comment

by:Casca1
ID: 9688609
How are the two systems connected?
Via a hub? How is the ICS machine connected to the internet?
0
 

Author Comment

by:ShadowRack
ID: 9689753
1. Nope it's not working even if disabling ICS.

2.Internet connection is adsl by outer alcatel modem , why do u have to know the isp?

3.Disabling File and printer sharing not fixing it..

4.XP Pro , Enabling netbios over tcp is done , Still didn't help , connection between two NICs are by network cable the 3'rd Nic in the internet computer is connected with network cable to the adsl modem.

Hint : In "My network places" i don't always see even my own computer , It's kinda random..


0
 

Expert Comment

by:Malc2003
ID: 9689877
I think you need to disable ICS, then do IPCONFIG /ALL on both machines and post the results.  You could try mapping a network drive using the IP address of one of the comps.  IE -
net use X: \\IPADDRESS\C$ and see if it will map the hosts C: drive. post the IPCONFIG results first anyhow.
0
 

Author Comment

by:ShadowRack
ID: 9689967
I will do so soon.

Do you know all the services needed/no needed , List of them it will be great.
0
 
LVL 8

Assisted Solution

by:ViRoy
ViRoy earned 20 total points
ID: 9689972


try this and you problems should be resolved.
tcp/ip is a very poor carrier of NETBIOS - NETBIOS is how windows communicates with each other and is necessary for them to show in "my network places"

go into network properties and add the IPX/SPX protocol... i believe it literally says "NWLink IPX/SPX compatible protocol"

once added simply restart both computers and take another look :)
0
 
LVL 6

Expert Comment

by:Casca1
ID: 9690222
Well, I don't need to know how your connected to ISP, just the access device, which you stated. You are running a cable directly between the two machines?
0
 
LVL 35

Expert Comment

by:ShineOn
ID: 9690270
You want to have file & printer sharing enabled.

Have you tried mapping a drive letter to each computer's shared folder?
0
 
LVL 35

Expert Comment

by:ShineOn
ID: 9690299
For what services to disable/enable, go here:  http://www.blackviper.com/WinXP/servicecfg.htm
0
 

Author Comment

by:ShadowRack
ID: 9700839
OMG!!! , I mistakenly gave Casta1 the points instead of Viroy!!! , It was the IPX who helped the netwrok work well with or without ICS...

I probebly rushed to give the accepted answer and didn't notice i weren't giving it yo Viroy... , That bad but it's not only my fault cause the site art built is confusing :(


Well , If there is a way to help this out just post here comment and ill do what it needs..

Again , Sorry.
0
 
LVL 6

Assisted Solution

by:Casca1
Casca1 earned 50 total points
ID: 9701657
I asked them to refund the points and score.
0
 
LVL 8

Expert Comment

by:ViRoy
ID: 9702423

thanx, glad to hear your fixed :)
i appreciate you guys going through the trouble... :)
0
 
LVL 35

Expert Comment

by:ShineOn
ID: 9702532
ShadowRack - don't I get anything for providing the answer to the 2nd half of your question?
0
Enabling OSINT in Activity Based Intelligence

Activity based intelligence (ABI) requires access to all available sources of data. Recorded Future allows analysts to observe structured data on the open, deep, and dark web.

 
LVL 6

Expert Comment

by:Casca1
ID: 9703863
Well, depends on what you wanted. 8-)
NWLink solved, whaich is what he was after. I beat my head against the wall trying to make it work the way it should, but that's just the IT in me.
At least ShadowRack got what he asked for; A solution.
0
 
LVL 35

Expert Comment

by:ShineOn
ID: 9703958
I'm sorry but the IPX solution doesn't help with this part of the question.
"Almost all services are working , Please right down if you some info bout services that should be enabled/disabled.:
0
 

Author Comment

by:ShadowRack
ID: 9706563
ShineOn is right , It wasn't the IPX after all , Coz i deleted it and it's still works :)

Unfortunatlly i did too many thing so i don't remember what helped..

 :(
0
 
LVL 35

Expert Comment

by:ShineOn
ID: 9707165
I guess the best thing to do would be to look at the whole question thread again, and grant points as you feel appropriate.  Splitting points among several Experts that helped you get to your goal is acceptable.

BTW, I didn't say it wasn't the IPX, just that you had a 2-part question, one part of which I definitively answered with my link to blackviper's site.

What worked initially may well have been using NetBIOS over IPX, because as was stated by ViRoy, IP *IS* a poor carrier of NetBIOS, because you have to make sure your network is set up *just right* for it to work all the time, whereas running NetBIOS over IPX works EVERY time, in my experience.
0
 

Author Comment

by:ShadowRack
ID: 9707428
The Black viper's site is a well known 1 that i've already browsed long time ago , It didn't help me tough to answer my question it's only for specific tweaking.

I've tried the netbios over TCP/IP and it didn't work , i dunno how things worked out , But it seems after deleting everything and installing again the components and configuration it worked...  altough i've already done it before posting this thread and it didn't work back then..

0
 
LVL 35

Expert Comment

by:ShineOn
ID: 9707454
Specific tweaking to fix this problem?  That's not likely a fix, in any case.  You were asking about what services to enable/disable.  If blackviper's services docs didn't help you in any way, I would be surprised.  Following the various recommendations and taking into account the prerequisited enumerated on his site will give you a faster, more efficient, and less vulnerable system.
0
 
LVL 35

Assisted Solution

by:ShineOn
ShineOn earned 50 total points
ID: 9707733
I think your "answer" had to do with a combination of NetBIOS transmission, routing and name resolution, along with file & porint sharing.

From what I've seen on this subject, in order to "see" anything in "my network places" under "computers near me" you need a combination of being in the same workgroup, file&print sharing turned on on the computer you hope to see, and a transport method for NetBIOS info that can be readily "seen" by the other computer(s).

That can be done in a "flat" network by enabling NetBEUI, or in a routed network by enabling NetBIOS over IP or NetBIOS over IPX.  Because IPX is broadcast-oriented (that's why it's known as "chatty") you don't have to have a method for the other computer(s) to "discover" computers that have file and print sharing on in your workgroup if you are using NetBIOS over IPX.  If you are using NetBIOS over IP, however, you also have to be in the same IP subnet and be able to resolve the computer name via IP, either through the HOSTS/LMHOSTS files or through DNS.

By "playing around" with the various suggestions here, you apparently stumbled upon the combination that works for you.
0
 
LVL 35

Expert Comment

by:ShineOn
ID: 9707738
Should be "...same IP subnet AND/OR be able to resolve the computer name via IP..._
0
 

Author Comment

by:ShadowRack
ID: 9708323
Dude , I think ur wrong , In my friends house no actions has been made else but the Network wizard , Nothing.

Everything from ICS to My network places is working great...

Well he got USB cable modem but it doesn't change a thing either..

So i don't think somth minor like the netbios over TCP/IP.. it just worked.. , It will go wrong again like it was happening in the past.. , There is no solid fix to this problem i guess..
0
 
LVL 35

Expert Comment

by:ShineOn
ID: 9708507
That's one of the nifty things about IT.  Things don't "just work."  There's always an explanation.

The challenge sometimes is to figure out that explanation.

Something that you did as part of this troubleshooting effort was a "solid fix."  You just have a hard time identifying it.
0
 
LVL 35

Expert Comment

by:ShineOn
ID: 9708526
What happens at your friend's house has nothing to do with what happens at your house, no matter how similar you might hope to make them.  IT and all IT functionality is based on logic, pure and simple.  Sometimes it seems like magic.  Sometimes it seems illogical.  Sometimes it seems like there's no way to tell what is wrong and if you get it working, what you did to fix it.

The plain and simple truth is, there is an explanation for everything in IT.  Even if it's random gamma rays swapping a bit on you in your RAM or CPU.  There's an explanation for EVERYTHING.

There are no "true mysteries" in IT, dude.  Just unaccounted-for cause-and-effect.
0
 
LVL 41

Accepted Solution

by:
stevenlewis earned 130 total points
ID: 9708540
Agree with ShineOn, things don't just happen. However this gives me a clue
"I've tried the netbios over TCP/IP and it didn't work , i dunno how things worked out , But it seems after deleting everything and installing again the components and configuration it worked"
Things do get corrupted, because of poser surges, bad shut downs, disk errors, etc
often times removal and reinstall fixes it
0
 
LVL 35

Expert Comment

by:ShineOn
ID: 9708564
Agree with stevenlewis.  Often a reinstall or reconfigure or hard boot or power reset is the "fix" just because something, somewhere, got corrupted.  If you aren't really paying attention, or are trying several "fixes" at the same time, it is difficult to determine what "fixed" the problem. It may not be a corrupt file, just corrupted memory addresses - the old "slipped a bit" issue.  Regardless, some action you took resolved the issue causing your problem.  If you weren't assiduously tracking the result of each and every thing you tried, then it might seem to you that "it just works."  Something was causing your problem, and something you did resolved the problem.  K???
0
 

Author Comment

by:ShadowRack
ID: 9710303
Dude , I'm sorry but no.
0
 
LVL 41

Expert Comment

by:stevenlewis
ID: 9710329
OK, it was magic LOL
0
 
LVL 35

Expert Comment

by:ShineOn
ID: 9710945
That must be why they call us wizards - hehe.
0
 
LVL 35

Expert Comment

by:ShineOn
ID: 9710951
When users call me with a problem and I walk over to their workstation, the problem magically disappears, just because I was standing there.  I tell them it's my "magnetic" personality...  hehe
0
 

Author Comment

by:ShadowRack
ID: 9717021
Dude , I've been working as technitian for 2 years , Maybe not at XP troubleshooting but anyway i've learned one thing... , Stable and Consistant does not much with Microsoft therfore you can translate the "end" to the prob as "it magically workes" or somth... , I'm not writing alot cause this subject is already making me sick for almost a year and i don't have power to reapeat everything everytime.. , I'm listening to all the advices to try to combine as you said the solve to the problem... , But everytime it gets along it's nothing i've been given by the opions here... at least when it's totaly fine for a period..

0
 

Author Comment

by:ShadowRack
ID: 9717072
To tell the truth most of the stuff here was funny to read as it's my second thread for this problem in this forum , so i tought ill give all the points to Malc2003 who was the the most correct one but.. since it's only less than half correct ill split up the points for everyone who helped..
0
 
LVL 35

Expert Comment

by:ShineOn
ID: 9717588
If I'm still alive, and this site is still here, and any of us remember this, I think after another 20 or so years as a technician you'll be in the chorus along with me and stevenlewis...

Yes, Microsoft products are both a consultant's dream and nightmare rolled into one.  However seemingly illogically constructed, they all still must follow the rules of logic, as must all the hardware components.  I know it sounds weird but sometimes the only way to fix a problem is ignore it, while sometimes the only way to fix what seems. logically, to be simple is to blow it all away and start fresh.
0

Featured Post

Why You Should Analyze Threat Actor TTPs

After years of analyzing threat actor behavior, it’s become clear that at any given time there are specific tactics, techniques, and procedures (TTPs) that are particularly prevalent. By analyzing and understanding these TTPs, you can dramatically enhance your security program.

Join & Write a Comment

This is an article about my experiences with remote access to my clients (so that I may serve them) and eventually to my home office system via Radmin Remote Control. I have been using remote access for over 10 years and have been improving my metho…
Join Greg Farro and Ethan Banks from Packet Pushers (http://packetpushers.net/podcast/podcasts/pq-show-93-smart-network-monitoring-paessler-sponsored/) and Greg Ross from Paessler (https://www.paessler.com/prtg) for a discussion about smart network …
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…

758 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

21 Experts available now in Live!

Get 1:1 Help Now