PHP, Apache, Quicktime or OSX?

Not sure where the problem lies here.

Cast of characters:
OSX Server 10.2.8
PHP 4.3.3
Apache 1.3.28
QuickTime 6.4

The website developed in PHP has been uploaded to the server in the default location suggested by the Admin Guide. When trying to open any QuickTime movie on the site, I'm not able to open it. The code is fine on the page. But even when I do a file listing and click on the MOV file to play on it's own without the interference of the web page it might be on, I get internal server error or misconfiguration error. When I right click the file to download to disk, I get unable to load file. It seems that I should at least be able to download the file. I've checked the permissions on the folder. They're all good. MIME settings, all good. Created a new HTML file with a new MOV, nothing. Internal Server Error  is the specific error message. The most confusing for me, however, is the fact that I can't view the movie from a file listing in the browser. I figure once I get that sorted out, everything else will fall into place.

Anyway, I'm pretty lost on the issue if someone wants to throw any ideas my way, I'd be grateful.


Who is Participating?
ileotechConnect With a Mentor Author Commented:
I got it, thought I don't understand why it works.

At the bottom of the httpd.conf file, I entered

AddType video/quicktime .mov

and it started working.

I had tried it earlier in the day without the dot before mov and it didn't work.

What I don't understand is that in Server Settings>Configure Web Services>MIME Types, mov is listed as a MIME type with video/quicktime as a web server response. A dot before that was not an option. I already tried adding it in and OSX told me to take a hike. In the mime_macosxserver.types file lives the line:

AddType video/quicktime mov

How does adding that line (with the dot before mov) in httpd.conf differ from what's already there?
Apache does not rely on the OS definitions and file type associations.
Defining a file type in OSX is not enough - you have to add it to httpd.conf for Apache.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.