Screensaver message: Could not find any compatible Direct3D devices.

I get this message when I try to run a 3D screensaver. I have upgraded to DirectX 9 with no luck. I emailed Dell and they said to try the repair or restore options of Windows XP. Well, I don't want to do that. I'd like to just fix this specific problem. Anyone have any ideas?
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Update your video card drivers. If you need help finding them, let us know what kind of video card you have.
lrthamesAuthor Commented:
I have already updated the video driver from the Dell website. I just redid it to be sure. Still does not work.
Hmm, try going to Start|Run and type dxdiag

When that comes up go to the display tab.
Under Direct3D Acceleration: does it say enabled or disabled, If disabled try enabling it. Also to the right there should be a button for Test Direct3D. Run it and see what happens.

Depending on what happens you might try using a driver from the chipset of the video card (ie Nvida or ATI).
The 7 Worst Nightmares of a Sysadmin

Fear not! To defend your business’ IT systems we’re going to shine a light on the seven most sinister terrors that haunt sysadmins. That way you can be sure there’s nothing in your stack waiting to go bump in the night.

lrthamesAuthor Commented:
OK, when I run dxdiag, it says on the Display tab:

DirectDraw Acceleration:  Not available
Direct3D Acceleration: Not available
AGP Texture Acceleration: Not available

The box to test Direct3D is grayed out.
In the notes it says, Direct3D funtionality is not available. You should verify that the driver is a final version from the hardware manufacturer.

I don't know what you mean by "using a driver from the chipset of the video card (ie Nvida or ATI)."

I have a 64 MB DDR NVIDIA GeForce4 MX 420 with TV/out video adapter.

Opps, I meant from the manufacturer of the video card chipset, so since it's Nvidia based follow Crash's links.

i think you need to follow the issue of installing Direct X 9b, this has to be done, why cant you do it, do you get an wrror?

lrthamesAuthor Commented:
Still does not work after install of driver from NVIDIA website. I get the same messages as above when i run DXDIAG.
You might have to see if Dell has an updated motherboard chipset or agp driver.
lrthamesAuthor Commented:
I don't see an update for the motherboard or the agp driver (whatever that is). Do you think the repair option from the Windows XP cd wil work?
A Windows XP repair might work, it's worth a try anyway.
Do you know what chipset your motherboard is? Like VIA, Nvidia, Intel, SIS etc.
It being a Dell it's most likely an Intel chipset.
You can get Intel's INF Update Utility from:

If that doesn't work then I'd try the Windows repair.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
This old question needs to be finalized -- accept an answer, split points, or get a refund.  For information on your options, please click here-> http:/help/closing.jsp#1 
Post your closing recommendations!  No comment means you don't care.
lrthamesAuthor Commented:
I haven't yet tried Windows Repair and that is why I did not close the question. I haven't had the time or inclination to deal with this. If I ever get around to trying "Repair", I'll post the answer here. Thanks so much for everyone's help. This website is fabulous!
Thanks for the points!
Some third party software packinges disable graphic acceleration.  

Be sure that you have the graphics accelertaion setting in the "Full" position. Go to [Start]|[Settings]|[Control Panel]|[Display]|[Settings]|[Advanced]|[Troubleshoot].

I had the same issue and this corrected the problem.
lrthamesAuthor Commented:
kpdenny -
I tried your fix and it worked! I can't believe it was that simple. Thank you so much. How can I give you some points???
Thanks again, Lynn
Heh, I never even thought of checking that for some reason. Good idea kdpenny, go to and post a comment and I'll give the points to you.

And glad it's all worked out for you now Lynn!
lrthamesAuthor Commented:
kenneniah -
Keep half the points for yourself. You stuck with me through a lot of troubleshooting.

It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows XP

From novice to tech pro — start learning today.