• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2970
  • Last Modified:

The Microsoft Jet database engine could not find the object 'Databases'. Make sure the object exists and that you spell its name and the path name correctly.

how can I edit the file? I subscribed, because the system said: pay for solution, and I did, but I don't see the solution anywhere.

Again, I'm trying to open an access file, and I get this error message:

The Microsoft Jet database engine could not find the object 'Databases'.  Make sure the object exists and that you spell its name and the path name correctly.
1 Solution
Sounds like you are linking the access file to another access mdb (backend). Try opening a table, if you cant, you need to locate the access backend and relink the tables to it. Make sure you use the network path if it is not locally stored.

If you do not even get to the databasewindow, what i assume from your desription
this error message may indicate some serious problem with the internal system tables.

what you can try:

make a empty new database

try to import the objects of the damaged database into this new database
in the first menu ("file") the third entry("external data") first entry ("import")

Regards, Franz
Maybe you should show us exactly how you are calling your database.  
Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

dkaplan435Author Commented:
Problem solved. I tried all the above suggestions, none of them worked. I purchased a program called AccessRecovery 2.2 and was able to save the file.
jadedataMS Access Systems CreatorCommented:
No comment has been added lately, so it's time to clean up this TA.
I will leave the following recommendation for this question in the Cleanup topic area:

PAQ with points refunded

Please leave any comments here within the next seven days.

EE Cleanup Volunteer
PAQed, with points refunded (500)

EE Moderator
Just a note on this kind of problem: "Beware of the non-alphabetical characters"

It seems that if there is a dot within the filename (NOT related to the extension of the file) like 'part1.part2.extension', Access refuses to digest it and you would  get the above error message. This kind of problem is very typical when you move a file from a unix environment, where any character is admissible within a name, into a windows workspace, where the rules are not very consistent.

An easy work-around is to substitute the dot ('.') with an underscore ('_') and to import the file using the new filename.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: MCSA MCSE Windows Server 2012

This course teaches how to install and configure Windows Server 2012 R2.  It is the first step on your path to becoming a Microsoft Certified Solutions Expert (MCSE).

Tackle projects and never again get stuck behind a technical roadblock.
Join Now