Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Computer can not recieve packets

Posted on 2003-11-05
18
Medium Priority
?
593 Views
Last Modified: 2013-12-07
A couple of days ago, I formatted my drive and installed XP. I installed 4 in 1 drivers, followed by my network drivers (onboard LAN from an ECS K7VTA3). I realized I installed the wrong set of 4 in 1 drivers, so I installed different ones. This caused conflicts, so I used system restore to roll back. All of a sudden my network worked fine.

A day later, I came back to my computer, and discovered I couldn't get on again. I check the connection status, and suddenly, I wasn't receiving packets anymore.

Information:
Connected through a Linksys Cable router, across 2 hubs. The connection of the person sharing the hub with me works fine

In Device Manager, it shows that I have not installed drivers for a network controller. It doesn't seem happy with any of the drivers I own. However, I'm 99% sure my connection worked without this anyway.

Proccessor: Athlon XP 2100

I have tried uninstalling and reinstalling drivers numerous times

I've swapped between the onboard lan and a Hawking USB to RJ 45 connector. One of the LEDs is on, the LED labelled 10/100 is not. The documentation does not say if it should be on, but I'm guessing it should

System worked fine before reformat

Tried reformatting a second time, did not work.

Thank you for an answer.
0
Comment
Question by:regfairfield
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 4
  • 3
  • +3
18 Comments
 
LVL 1

Expert Comment

by:mrochac
ID: 9690224
Few things to try, try a loop back ping, ping 127.0.0.1, see if you get a response, if so your nic is ok. Can you ping anything, gateway another computer? is your computer resolving names, try a nslookup? winipcfg what the configuration you get?

Resus.
0
 
LVL 35

Expert Comment

by:ShineOn
ID: 9690390
Check your NIC card properties.  Make sure powersave feature is NOT enabled.  You don't want your NIC to be turned off by powersave.
0
 
LVL 1

Expert Comment

by:Scott_V
ID: 9690749
This is where you can get the latest driver for your NIC.  I'd suggest you start by installing (force installing if necessary) this driver...

http://www.ecsusa.com/downloads/driver/lan/8139502.zip

You can use this link if you feel unconfortable linking directly to a file.

http://www.ecsusa.com/downloads/drivers_lan.html

Once you have the latest driver, I would then make sure if you right click on "My network places" and goto Properties that your "Local Area Connection" shows up.  If you right click on this LAC and go properties, make sure that its "bound" to the correct NIC and the correct drivers (Internet Protocol (TCP/IP); Client for Microsoft Networks) at a minimum.

Then go to the properties of the TCP/IP and make sure (assuming your router uses DHCP) that its set to "Automatically obtain" everything.

Once all this is done, click OK a few times until all the windows go away.  Then click on Start->Run and type in "cmd".  Hit enter, and type (in the dos box) "ipconfig /all"

make sure you have an IP Address (that does NOT start with 169.x.x.x) and a gateway that looks similar to the IP address...

If you do have an IP that starts with 169.x.x.x that means DHCP was not found and the NIC never got an IP, so it used an "Autoconfig" one.  This is bad and means you'll have to hard assign an IP.

If you didn't get anything displayed when you typed "ipconfig /all" that could mean that windows still thinks you don't have a NIC installed, or its not bound to TCP/IP properly.  If thats the case, you could try removing all drivers from the "Local Area Connection" Properties box, restart, and hope for the best...

Anyways, assuming that typing "ipconfig /all" got you something like IP Address = 192.168.x.x or 10.x.x.x you may be good to go.

Try typing "ping www.homestarrunner.com" and see if you get a response.

If so, you should now beable to surf the web (IP/gateway/and DNS are running)

If not, tell me what worked and what didn't...

-Scott


-Scott
0
Get free NFR key for Veeam Availability Suite 9.5

Veeam is happy to provide a free NFR license (1 year, 2 sockets) to all certified IT Pros. The license allows for the non-production use of Veeam Availability Suite v9.5 in your home lab, without any feature limitations. It works for both VMware and Hyper-V environments

 

Author Comment

by:regfairfield
ID: 9690884
Thank you all for your help.

I am already running the latest drivers for my NIC, and it is displaying the correct drivers and showing TCP/IP properites.

I cannot obtain an IP address, nor can I ping my router, or any of the computers on the network, the only ping I can perform is a loopback ping.

Manually placing an IP address does not work either.

I have already installed and reinstalled drivers several times.

Powersave was on, but it did not fix anything.

Thank you all, but futher suggestions are needed/
0
 
LVL 1

Expert Comment

by:ezlife
ID: 9690922
I'm assuming when your network won't connect that you try to do a release/renew of your network IP?   you can do it through ms-dos , type,  ipconfig release/renew, if you have then try this.


uninstall your nic card from device manager. Shut the computer off.

Can you reset the hub infront of you?  By reset I mean whatever directions you have to follow,(usually power down by button and hold reset for x amount of seconds, or unplug power for x amount of seconds and turn back on). Do this while your computer is off. If you can't don't worry, it's not necessary for this test, just helps.

Turn on your computer and check to see if you're online. ( dumb I know but it's possible).  By now windows should have prompted to install new hardware, install it and point it to the driver for the nic card. If for some reason windows does not ask to install new hardware, put in your installation cd, or go to control panel, click on add new hardware, then manually point it to the driver ( driver on cd , in folder or whatever).
0
 
LVL 1

Expert Comment

by:ezlife
ID: 9691013
I'm sorry, I meant reset the router in front of you. The 10/100 means a computer is connectected. There might be a light for 10 and 100, more then likely the 10 won't be lit. If the other light is labeled, dsl, cable, internet, or act. That is your internet connection and the light should be lit, although if this were the case, you should still be able to ping your router.
0
 

Author Comment

by:regfairfield
ID: 9691176
Thanks, but that didn't work, the 10/100 light still is not on.
0
 

Author Comment

by:regfairfield
ID: 9691561
I figure I might as well try to solve the network controller issue in devine manager. Is there anywhere I can find a generic network controller driver for Windows XP?
0
 
LVL 1

Expert Comment

by:Scott_V
ID: 9692342
If what you're describing to me is what I think it is, you probably see your NIC card in device manager (with the correct description) but it has some sort of symbol on it (usually a yellow exclimation mark)

If this is the case, when you click Start then goto run, type "cmd" and then run ipconfig it'll probably come back with absolutely nothing...  This means windows does not have your NIC installed properly and/or is not binding it to TCP/IP at all...

If you have a network controller issue in device Manager like that, it usually means your NIC driver is either not installed properly, or you accidentially forced the wrong drivers on it.  Heres what I'd do...

Force feed the drivers I sent you in the link to the card by choosing "Display a list of the known drivers for this device so that I can choose a specific driver" and use the "Have Disk..." option.  This is assuming you only have the intergrated NIC installed and active, and that the motherboard you listed is the one you have...  

-or-

You can re-reinstall windows XP

-or-

You can disable the onboard LAN all together and get a $20 Linksys (or equiv.) LAN card with a driver CD.  This may be a good solution to convince youself that the drivers are/are not the issue...  If this seperate card doesn't work either, it could be another issue entirely...

All this aside, please run the "ipconfig /all" and copy/paste its output to a reply.  This in itself is useful to the troubeshooting process...

-Scott
0
 

Author Comment

by:regfairfield
ID: 9695719
The card itself does show up in device manager, however, there is another thing labeled "Network Controller", which won't let me force feed it. Ipconfigs work fine on my machine.

I have also tried connecting through a Hawking USB Network adapter, which also does not work.

Windows IP Configuration

Host Name...(compter name)
Primary DNS Suffix.....(none)
Node Type............broadcast
IP Routing Enabled..........No
VINS Proxy Enabled........No


Ethernet Adapter Local Area Connection 3:

Connection specific DNS suffix......(none)
Description:...........Hawking UF100 USB 10/100 Network Adapter
Physical Address.....00-E0-98-AC-6A-F9
Dhcp Enabled........Yes
Autoconfig Enabled.......Yes
IP Addrexss 0.0.0.0
Subnet:    0.0.0.0
Default Gateway.......(none)
DHCP Sever.......255.255.255.255

Thank you for your help.
0
 
LVL 35

Expert Comment

by:ShineOn
ID: 9695793
Have you deleted the NIC from device manager, and rebooted to let Windows discover it again?  Does it discover the NIC on bootup or not?

If it doesn't discover it and go through the wizard to add the driver, then the onboard NIC may have bit the dust.
0
 
LVL 1

Expert Comment

by:Scott_V
ID: 9695889
Looks to me that the hawking USB adaptor is installed okay, but not getting an IP address...  Try doing an "Ipconfig /release" then "Ipconfig /renew" while using only the hawking USB lan...  (You could right click on the MyNetworkPlaces->Properties then right click on "Ethernet Adapter LAC 3" anc choose "Repair" too....

Nothing will work until you get an IP Address that is not 0.0.0.0 or 169.x.x.x...

-Scott
0
 

Author Comment

by:regfairfield
ID: 9696085
Ipconfig /release gives me a 169.x address

Ipconfig /renew doesn't work, it says it can not connect with the DHCP server.
0
 
LVL 35

Expert Comment

by:ShineOn
ID: 9696134
Do you get lights on your switch/hub port using the USB adapter?
0
 

Author Comment

by:regfairfield
ID: 9696210
There is only one light on, the one labelled link/act. The one labeled 10/100 is off.
0
 
LVL 1

Accepted Solution

by:
Scott_V earned 500 total points
ID: 9696672
Okay, the no-address thing means one of two things.  Regfair and ShineOn were on the right track with one of these two things which may be physical network problems.  If you do not have a link light, or there are problems with your network cable and/or network ports (on the switch or the LAN card) this problem could show up...

The second thing could be that the DHCP on the router is not enabled, and therefore you will not beable to get an IP address this way.

Do you have another computer that connects to this LAN?  If you do, try hard-assigning an ip address of the same form, and make the DNS/Gateway/Subnet Mask the same as that machine's.  If this works, try pinging some machine on your network (or try pinging your router)

Just in case you didn't know, you can get the information off your other PC by using "ipconfig /all" just as before.

-Scott
0
 

Author Comment

by:regfairfield
ID: 9696896
I feel horrible for this, but the problem was the cable. I tried had tested it several times before hand, and it came up good, I also figured that it couldn't be it anyway, since the problem came up after a reformat. Apparently, I was wrong.

I replaced the cable at Scott's suggestion, so he gets the points. Thank you all for your help, and I'm very sorry.
0
 

Expert Comment

by:pgeneste
ID: 12245142
Microsoft Knowledge Base Article - 811259 How to determine and recover from Winsock2 corruption.
This will fix 99% of the issues talked about here!!
Also review
Microsoft Knowledge Base Article - 317518 How to reset "Internet Protocol (TCP/IP)
Hope this help you out
0

Featured Post

On Demand Webinar: Networking for the Cloud Era

Did you know SD-WANs can improve network connectivity? Check out this webinar to learn how an SD-WAN simplified, one-click tool can help you migrate and manage data in the cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Arrow Electronics was searching for a KVM  (Keyboard/Video/Mouse) switch that could display on one single monitor the current status of all units being tested on the rack.
During and after that shift to cloud, one area that still poses a struggle for many organizations is what to do with their department file shares.
Internet Business Fax to Email Made Easy - With  eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, f…
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…

722 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question