Solved

How do you get your jumpstart server to load VTS to its clients?

Posted on 2003-11-05
30
450 Views
Last Modified: 2013-12-23
Hey everyone,
   I have a jumpstart server loading Solaris 8 on to a bunch of clients.  What I am looking to do is have the jumpstart server load VTS on the client machines.  This way once the client gets the o/s loaded I can simply just run VTS on the client.  I want the jumpstart server to load the VTS package on the client machines.  Thank you everyone for your help in advance.  
0
Comment
Question by:kassidy2010
  • 15
  • 14
30 Comments
 
LVL 34

Expert Comment

by:PsiCop
ID: 9690262
You would prolly find an answer quicker in the Solaris TA. http://oldlook.experts-exchange.com/Operating_Systems/Solaris/
0
 
LVL 24

Expert Comment

by:shivsa
ID: 9691212
0
 
LVL 24

Expert Comment

by:shivsa
ID: 9691222
u can add SUNWvts package to jumpstart-dir/*.profile file
like

package SUNWgzip add
package SUNWless add
package SUNWman add
package SUNWbash add

then whenever a client is installed, after this SUNWvts will also be installed.
0
 
LVL 24

Expert Comment

by:shivsa
ID: 9691308
read some tips and tricks from here.
http://www.manucomp.com/tips/solaris_tips_jumpstart.php
0
 

Author Comment

by:kassidy2010
ID: 9694187
Thanks everyone.  I will be checking these out today.  I will try shivsa's solution and also search for other solutions.  I will let everyone know how it comes out.   Thanks for everyone's responses.  If anyone else has any more ideas please feel free to keep on posting!  :)
0
 

Author Comment

by:kassidy2010
ID: 9695767
I created a file named vts.profile  When I ran a jumpstart install it did not work. I created a directory in my jumpstart directory called VTS.   Here is the contents of the file:

package /VTS/SUNWvts add
package /VTS/SUNWvtsmn add
package /VTS/SUNWvtsol add
package /VTS/SUNWvtsx add


That is all I put in the file.  Am I missing anything at all??

The files are in /jumpstart/VTS

Thanks again for everyones help!
0
 
LVL 24

Expert Comment

by:shivsa
ID: 9696105
u need not to create another profile file, u can add this pkgadd SUNWvts packages to existing profile under /jumpstart/Profiles/profile.

also check for the permission on dirctories and packages, it should be atleast read/exe.
0
 
LVL 24

Expert Comment

by:shivsa
ID: 9696232
if this does not work then i would suggest
putting these pkgadd entried into the finish file.


pkgadd  -d ${PKGS} SUNWvts

where PKGS is package directory.
0
 

Author Comment

by:kassidy2010
ID: 9696362
Shivsa,
  I have not tried the last thing you wrote about adding to a finish file.  I have no finish file so I will have to create one.  I also do not have a /jumpstart/Profiles/profile.  Should I create this??  


Thanks!
0
 
LVL 24

Expert Comment

by:shivsa
ID: 9696467
yes, u can create both of these files.
they are used by jumpstart, i think u might be having these files with jumpstart, copy the standard ones and then chanhe it accordingly.

something like these...
# cat /jumpstart/Finish/finish
#!/sbin/sh
echo 'Finish script ......\n\n\n'

# cat /jumpstart/Profiles/profile

install_type  initial_install
.......
0
 
LVL 24

Expert Comment

by:shivsa
ID: 9696544
on solaris 9, the profile file comes with the name of any_machine, i think on sol 8 they use the same name.
u can put this file under /jumpstart directoty.

cp -r jumpstart_sample/* /jumpstart
cd /jumpstart
ls
rules check any_machine
.... and some more files.

#cat /jumpstart/any_machine
           install_type          initial_install
           system_type          standalone
           partitioning          default
           package               SUNWvts add

0
 

Author Comment

by:kassidy2010
ID: 9696668
Shivsa,
  Thank you so much!  I found were the profile was.  The person who set up the jumpstart server had it in a weird place, now I found everything.  It was named something odd.  I am in the middle of testing again and I will let you know!  Thank you so much!
0
 

Author Comment

by:kassidy2010
ID: 9697051
Where would the packages get installed.  I can not find them in the system. I did a find and could not find them and also checked specific directory.  Is this known not to work sometimes??  Maybe I will try the finish script tomorrow?  Not sure what else to do or where else to look.  Thanks for all the in put Shivsa, just to let you know, you have been doing a great job so far :)  Let me know what else I can do or where they maybe or what I am doing wrong....so frustrating :/

0
 
LVL 24

Expert Comment

by:shivsa
ID: 9697109
u can see if the packages get installed with
pkginfo | grep SUNWvts.

the logs files generally kept on /var/sadm/pkg directory.
hope u get this work this time.
0
 

Author Comment

by:kassidy2010
ID: 9703324
I can't figure out what I am doing wrong.  Do I have restart any services??  I added the lines to the profile.  I then ran a check.  I checked pkginfo and the /var/sadm/pkg directory.  Still nothing.  I must be missing something.  You have gotten this to work this way correct?  I am not sure what else to try or if I should just do a finish script?  Thanks fore everything!
0
Enabling OSINT in Activity Based Intelligence

Activity based intelligence (ABI) requires access to all available sources of data. Recorded Future allows analysts to observe structured data on the open, deep, and dark web.

 
LVL 24

Expert Comment

by:shivsa
ID: 9703594
could u try adding finish script.

there is one more way called post installation, this is user once u run your normal install and after that u want to install any required patches and some package like VTS.
0
 

Author Comment

by:kassidy2010
ID: 9703708
Ok, I will write a finish script and see how that works.  After I write the finish script what do I do next so the jumpstart server knows to install it.  Do I have to add anything to my rules file or anything like that?  I will let you know either wya how that goes!  Thanks, you have been an amazing help!
0
 

Author Comment

by:kassidy2010
ID: 9716110
After I write the finish script is there anything i have to do.  Add it to the rules files anything??  Or maybe a check file to run??  Please advise.  I feel pretty close.
0
 
LVL 24

Expert Comment

by:shivsa
ID: 9716178
u need not to do anything, if u are done with finish script, just run a check file to run. it will create  runles.ok and then u can start installing, if u face some problem then post the messages.

0
 
LVL 24

Expert Comment

by:shivsa
ID: 9716193
Add rule in rules file
Adding entries in the rules file, enables the clients to choose the correct profile for the installation. If no profile exists, the client will enter interactive installation mode.

The rules file consists of lines with five fields each;

  keyword value begin profile finish

0
 
LVL 24

Expert Comment

by:shivsa
ID: 9716220
also for reference check this link.
http://www.manucomp.com/tips/solaris_tips_jumpstart.php
0
 

Author Comment

by:kassidy2010
ID: 9717820
Shivsa,
  Ok, I am so frustrated right now :(  I just have no clue what I am doing wrong.  I will past some files here for you to look at.  First here is the finish script

jserv# more VTSinstall.finish
#!/bin/sh
#
#
#       Install VTS 11/07/2003  RL
#
#
echo "Installing Sun VTS from Jumpstart Server......."
mount -f nfs 10.0.0.1:/jumpstart /a/mnt
cd /a/mnt
pkgadd -d ${var/sadm/pkg/VTS} SUN*
cd /a
umount /a/mnt

Here is the rules.ok file:
jserv# more rules.ok
any -   -   any_machine VTSinstall.finish
# version=2 checksum=3563

and here is the any_machine profile:
jserv# more any_machine
install_type    initial_install
system_type     standalone
cluster         SUNWCuser
package         SUNWaudmo add
package         SUNWman add
package         SUNWvts add
package         SUNWvtsmn add
package         SUNWvtsol add
package         SUNWvtsx add
partitioning    explicit
usedisk         c0t0d0
locale          en_US
filesys         c0t0d0s1 1024 swap
filesys         c0t0d0s0 free /
0
 

Author Comment

by:kassidy2010
ID: 9722452
Still not sure what I am doing wrong???  Does any of this help?
0
 
LVL 24

Expert Comment

by:shivsa
ID: 9735262
sorry i did not check this post, thought it is resolved.
anyway
1. delete vts related things from any_machine file.

2. This is what i am using right now.

--------
finish.sh
------

#!/bin/sh -x

BASE=/a
MNT=/a/mnt
ADMIN_FILE=/a/tmp/admin
mkdir ${MNT} 2>&1 >log

echo "Installing Sun VTS from Jumpstart Server......."
mount -f nfs 10.0.0.1:/jumpstart ${MNT} 2>/dev/null

cat >${ADMIN_FILE} <<DONT_ASK
mail=root
instance=overwrite
partial=nocheck
runlevel=nocheck
idepend=nocheck
rdepend=nocheck
space=ask
setuid=nocheck
conflict=nocheck
action=nocheck
basedir=default
DONT_ASK

/usr/sbin/pkgadd -a ${ADMIN_FILE} -d ${MNT} -R ${BASE} SUNWvts 2>/dev/null
/usr/sbin/pkgadd -a ${ADMIN_FILE} -d ${MNT} -R ${BASE} SUNWvtsmn 2>/dev/null
/usr/sbin/pkgadd -a ${ADMIN_FILE} -d ${MNT} -R ${BASE} SUNWvtsol 2>/dev/null
/usr/sbin/pkgadd -a ${ADMIN_FILE} -d ${MNT} -R ${BASE} SUNWvtstk 2>/dev/null
/usr/sbin/pkgadd -a ${ADMIN_FILE} -d ${MNT} -R ${BASE} SUNWvtstx 2>/dev/null
/usr/sbin/pkgadd -a ${ADMIN_FILE} -d ${MNT} -R ${BASE} SUNWvtsx 2>/dev/null
umount ${MNT}  2>/dev/null
rmdir ${MNT} 2>/dev/null

echo "Finish install script completed."
---------

3. after creating these files, run check again.
and do the installation.
0
 

Author Comment

by:kassidy2010
ID: 9742621
I tried this and get a core dump.  I am not sure what files I am suppose to create.  All I did was put this code in finish.sh.  Do I have to create an admin file and if so what does it contain?  Anything else??

0
 
LVL 24

Expert Comment

by:shivsa
ID: 9742946
no admin file will be created by this file.
did u change the name of finish.sh file to  VTSinstall.finish. because that the file name u are using in rules files.
once u do those changes, try to run check script and then do the installation.

what kind of core dump u had. system paniced or script dumped the core.
if script dumped the core, could u send me the errors.
also if script dump the core
do pstack core and send me the output.
may be your vts binaries are not correct.
0
 

Author Comment

by:kassidy2010
ID: 9764959
What directory do the packages have to be in??
0
 
LVL 24

Accepted Solution

by:
shivsa earned 200 total points
ID: 9765376
in finish script u are mounting 10.0.0.1:/jumpstart ${MNT}( where MNT is /a/mnt)
so u should have all the packages on server 10.0.0.1:/jumpstart directory or if u have selected some other directory then mount that directory here.
i see u have all your vts files in /jumpstart/VTS, may me u should mount like this
10.0.0.1:/jumpstart/VTS ${MNT}( or whatever is your correct path) but make sure once u mount the directory u should see all the packages there.

0
 

Author Comment

by:kassidy2010
ID: 9771036
Thanks for all of your help.  YOu did a great job!!!
0
 

Author Comment

by:kassidy2010
ID: 9771088
Hi Shivsa,
  I have a quick question.  Is there a way to answer the questions that the VTS install asks inside the script?
0

Featured Post

6 Surprising Benefits of Threat Intelligence

All sorts of threat intelligence is available on the web. Intelligence you can learn from, and use to anticipate and prepare for future attacks.

Join & Write a Comment

Meet the world's only “Transparent Cloud™” from Superb Internet Corporation. Now, you can experience firsthand a cloud platform that consistently outperforms Amazon Web Services (AWS), IBM’s Softlayer, and Microsoft’s Azure when it comes to CPU and …
When it comes to security, there are always trade-offs between security and convenience/ease of administration. This article examines some of the main pros and cons of using key authentication vs password authentication for hosting an SFTP server.
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now