TMemo and cxMemo, line limit?

Hi Experts, I have no idea whats causing this. I have tried both a TMemo component and cxMemo component with the same results. I have the following code:

memCustDetails: TMemo;
.
.
.

memCustDetails.Lines[0] := frmCustomerLookup.FName + ' ' + frmCustomerLookup.Surname;
memCustDetails.Lines[1] := frmCustomerLookup.Address;
memCustDetails.Lines[2] := 'test';
memCustDetails.Lines[3] := 'test2';

After successfully entering the first two lines, the memo never shows the 3rd line or line[2]. 'test' is never displayed. It would appear that any line after the second or line[1] is never displayed. Is there a limit on the number of lines?

Thanks in advance

Ian
beaveiAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ThoseBugCommented:
the problem is when you use lines[x] only.. may be in the line [2] or [3] don't have any valid char...the consequence is this line not exits...you can use this..

memo1.Lines.Insert(0,'test');
memo1.Lines.Insert(1,'test');
memo1.Lines.Insert(2,'test');
memo1.Lines.Insert(3,'test');

Regards.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
swift99Commented:
Tmemo has a line limit that is fairly small (or possibly a buffer size limit).

TRichText (or is it TRichMemo?) has a much higher limit.
0
kretzschmarCommented:
it is TRichEdit, swift99

TMemo-limit default -> 32KB, max 64KB
TRichedit-limit default -> 64KB max 2GB

(XP, win2000 have a bit higher default limits)

but the problem is worked out by ThoseBug already

meikl ;-)
0
beaveiAuthor Commented:
Thanks ThoseBug it works a treat. Very strange how the 'memo.lines[x] := value' doesn't go past 2 though...

Thanks again
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Delphi

From novice to tech pro — start learning today.