Celebrate National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Override diabled Workstation only

Posted on 2003-11-06
14
Medium Priority
?
1,200 Views
Last Modified: 2012-06-27
Hi !

Is there any way that i can login to Workstation only even if it´s disabeld in the client setup?

ServerOS        : Netware 5.1
Client              : Client 4.83 / 4.9
WorkstationOS : Windows XP / 2000
0
Comment
Question by:Thops
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 4
  • 4
14 Comments
 
LVL 35

Expert Comment

by:ShineOn
ID: 9695833
Do you mean that "workstation only" has been disabled, or that the "display workstation only checkbox" feature has been disabled?

Try unplugging the network cable and rebooting.  If the Novell client can't find a network, it usually will allow login locally.
0
 
LVL 1

Author Comment

by:Thops
ID: 9695951
I mean that the checkbox is unchecked.

We have some workstations that i want to secure from local logon, the reason is that i don´t want the students to be able to go on the Internet without Netware login.
The workstations have wireless networking and sometimes it don´t connect to the network and i want to be able to start the workstation and correct the problem.

When this happends i am "unplugged" but i can not start workstation only as you suggest.
0
 
LVL 35

Expert Comment

by:ShineOn
ID: 9696035
Do you have the "workstation only" checkbox in the NetWare login dialog, only it is not checked?  Or do you have it set up so that the "workstation only" checkbox does not appear on the NetWar login dialog?

Do you have BorderManager running as your firewall?  If so, you can prevent unauthorized, unauthenticated Internet access through BorderManager features.
0
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
LVL 35

Accepted Solution

by:
ShineOn earned 300 total points
ID: 9696066
Try this TID:
http://support.novell.com/cgi-bin/search/searchtid.cgi?/10086294.htm

It's for Client 4.9.  Don't know that these features would work for the 4.83 client.
0
 
LVL 10

Expert Comment

by:DSPoole
ID: 9696332
it's for Client 4.90 only - new features.

You can remove the Workstation Only checkbox, but if the user fails to authenticate to NetWare the workstation will prompt to log into Windows.  If you are using ZENworks with a Dynamic Local User policy in the User Policy Package, you can make the policy Volatile - ie:  it will delete the user accounts when the user logs out.  Thus, there will be no local user account to log into if Windows prompts for a local login.

that and the BM thingy ShineOn suggested.
0
 
LVL 1

Author Comment

by:Thops
ID: 9696532
Wow... now i´m confused :-)

1. The only thing i have done, or want to do, is to leave the checkbox in client setup/ advanced login (i think) unchecked.
2. I don't have BorderManager
3. I have ZenWorks installed but havent been successful in figuring it out, i have tried Dynamic local users for other reasons but couldn´t get the policyfiles right. Can i stop "Workstation only" users from accessing the Internet with that?

---> ShineOn
I found this where you pointed me :
//Quote//
It may be that the administrator does not want the "Workstation Only" checkbox displayed, but does want the user to be able to login to the workstation only in the event that the network is not available. This is made possible by setting the "Workstation Only Fallback" flag.  If it is set, and the Network authentication fails, and the "Workstation Only" flag is clear, Login will still ask you if you want to login "Workstation Only". To enable this functionality, set this registry flag:

     HKLM\Software\Novell\Login\
     DWORD: Workstation Only Fallback (default 0)
     0=Don't allow Workstation Only login in case of network authentication failure.
     1=Allow Workstation Only login in case of network authentication failure.

// End Quote//

It seems to do the trick, i will try it at work tomorrow ( it´s nine in the evening here i sweden)

I´ll be back, thanks for now!
0
 
LVL 35

Expert Comment

by:ShineOn
ID: 9696599
> 3. I have ZenWorks installed but havent been successful in figuring it out, i have tried Dynamic local users for other reasons but
> couldn´t get the policyfiles right. Can i stop "Workstation only" users from accessing the Internet with that?

Do you mean with a policy?  I wouldn't.  I'd recommend volatile Dynamic Local User like DSPoole suggested - and don't let any students know your local admin signon or password.

0
 
LVL 1

Author Comment

by:Thops
ID: 9696746
Well, i´ll se if i can get the volatile Dynamic Local User set up to work. I don´t remember what went wrong the last time. I think it was something with the mandatory profile for the dynamic user. I remember having problems with creating and setting that up.
0
 
LVL 35

Expert Comment

by:ShineOn
ID: 9696795
We can help with that, too.  It properly should be a new question, though.
0
 
LVL 10

Expert Comment

by:DSPoole
ID: 9696815
You can use the Workstation Policy Package (specifically the NT Client Configuration) to remove the Workstation Only check box from the Windows machine...
0
 
LVL 10

Expert Comment

by:DSPoole
ID: 9696825
orrrrrr... if you are brave, you can do it manually:

right-click My Network Places - Properties
right-click on you Local Area Connection - Properties
select the Novell Client for Windows - Properties
select the Advanced Login tab
in the Show on Login section, uncheck the Workstation Only box there -

press the OK buttons and reboot - the Workstation Only button is now gone.
0
 
LVL 1

Author Comment

by:Thops
ID: 9699126
That was not nice.....

It´s not the actual removal of the button that is the problem, i´m not THAT stupid ! :-(
0
 
LVL 10

Expert Comment

by:DSPoole
ID: 9702927
???

0
 
LVL 35

Expert Comment

by:ShineOn
ID: 9702972
Thops - I'm sure that DSPoole was not attempting to be rude or facetious in his recommendations.  Sometimes the written word can be misinterpreted, because we depend so much on facial expression and body language as part of communication.  Please don't be offended.
0

Featured Post

Important Lessons on Recovering from Petya

In their most recent webinar, Skyport Systems explores ways to isolate and protect critical databases to keep the core of your company safe from harm.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Instead of error trapping or hard-coding for non-updateable fields when using QODBC, let VBA automatically disable them when forms open. This way, users can view but not change the data. Part 1 explained how to use schema tables to do this. Part 2 h…
The core idea of this article is to make you acquainted with the best way in which you can export Exchange mailbox to PST format.
Do you want to know how to make a graph with Microsoft Access? First, create a query with the data for the chart. Then make a blank form and add a chart control. This video also shows how to change what data is displayed on the graph as well as form…
We’ve all felt that sense of false security before—locking down external access to a database or component and feeling like we’ve done all we need to do to secure company data. But that feeling is fleeting. Attacks these days can happen in many w…

730 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question