Red Hat 9.0 sleeping, can't connect using ssh


I hope u people can help as this is very annoying.
I am at uni and have set up a Red Hat 9.0 server at home.
The problem is that i can't connect to it after a day when it has been rebooted.

I am have connected to it before so it works but it just sleeps is there anything i can do.

It is supposed to be file server and a http server, and to back up uni work.

Thanks Toby
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Is Power Managment enbaled in the system BIOS? You don't any sort of power management functions enabled on a server.

Once the system gets in this state does it have external network connectivity? I.E., from the console can you access an Internet site? Also at that point does it have the same IP that it did right after a boot?
temporoAuthor Commented:
i don't know about the bois settings i don't think that any of the features are enabled.

i don't know i and at uni so can not connect to it to use it
It always has the same IP cause it is a server.
I guess I should have been more clear about the IP. I was actually interested in knowing if the Internet IP, be it on the Linux machine or on a gateway router, was changing. When you get home see if you have Internet access from the console.
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

I have the same feeling of jlevie said, the internet IP you got it from your ISP? or do you have the internet IP? because if you have internet IP setup and it's fixed, even the linux sleep, you still can remote access.

Also, you said "The problem is that i can't connect to it after a day when it has been rebooted." will it be the ssh service havn't start after reboot? have you also check that? you can restart the ssh service by /etc/rc.d/init.d/sshd restart, or you can check from /var/log/messages or /var/log/dmesg to see the service start up or not.
Listening mainly...

Toby, when you get back home, in what state is the server? Blank screen/wound down disks etc?
Perhaps a few words on the network topology would be good too...

-- Glenn
temporoAuthor Commented:
right to set things straight,

The IP is a router which i have allowed traffic though on only the ports that i need eg 22 21 and 80
This IP is a static IP

When the computer is rebooted i can connect, but after about a day or 24 hours i can not connect again. therefore i guess either the process prioities have to change eg ssh -10 or something like that.

The server is in a working state. I can only get to it via ssh as i am at uni 250 miles away from the server. i know that it is working as i can ask my mum or brother to reboot it. As you do from the login screen.

The server is located in a network and has a direct link to the router. there are three other computers on the network and they use the sever as a file server.
(Not trying to be insulting, but just need this clearly confirmed)
When your mum/brother "touch" the machine... Does it "wake up", or is the reboot needed?

When they do it next time, could you ask them to check the memory statistics ("cat /proc/meminfo" or "free" or "top")?
Also check that sshd is running (if nothing else by running "ps auxww | grep sshd | grep -v grep")...

The above should perhaps be performed with you talking them through it over the phone:-).

-- Glenn
temporoAuthor Commented:
The reboot is needed

i can ask my mum to reboot now if she is home. i know that on a reboot sshd should work as it is in the startup menu or what ever it is called i can't remember.

When sat at the consol you can use the machine as if a normal pc but i still can not connect to it untill rebooted
When the machine gets in this state do you loose access over both ssh and port 80 (I assume you have a web server running on the system if port 80 is open)?

Since you say that sitting at the console the machine works normally does that mean the one can access Internet sites from the console?

There's nothing in an RH 9 system that I know of that will disable sshd after 24 hours of uptime. So I think we are looking for some sort of network problem or something else wierd with the machine.
temporoAuthor Commented:
Well, finally I found out the solution of the problem.
It is the compaq sleep modus. It not only shuts down the monitor and
harddisks but also the network card.
Unchecking sleep modus solved the problem.

i found the above on google groups and ther server is a compaq so it this my problem then
temporoAuthor Commented:
i have turned off the webserver at the moment, i did this when i asked my mum to reboot it as it was a security risk as i can not see the logs if i can not login or connect.

i don't know if it is 24 hours it is a lenght of time as i connected one day and then the next day i did the same thing but the connection would not connect using Putty.
Ah, so then it _was_ power management.
The only form of "power management" one perhaps could accept on a server would perhaps be enabling DPMS for X (turn off screen).
Points to Jim, I'd say:-).

-- Glenn
temporoAuthor Commented:
i don't know if it is my problem but i guess it is. is there any way i can fix it here or do i have to ask my mum to fix it.

i have not changed any of the bios from standard.
Yep, if you have the standard Compaq BIOS settings it is probably the power management feature (enabled by default) that is the cause. That can only be changed from the BIOS set up and that must be done from the console.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
temporoAuthor Commented:
ok thanks very much i will have to spend some time talking on the phone to a family member to sort it out..

It's not that hard to do though, on most Compaqs... If it's an older computer it might have the Setup/VP partition stuff which is a bit less simple, but if it is a newer machine, it's a fairly standard menudriven type of thing.
Just <F10> at the Compaq bootup screen, perhaps set language,then use arrowkeys to go to "Power Management" menu, choose the something appropriate (I did this on an EN SFF P800 not 2 hours back... can't for the life of me remember the exact choice:-), deactivate it, <F10> to get back to the menu, Arrows to the system menu, choose save&exit ... and you should be fine.

Good luck

-- Glenn
temporoAuthor Commented:
cheers mate i should be able to direct them ok over the phone.

it is old but we will see what happens, if another question comes up in the bios type section saying that the bios is messed up it is most probably me. hehe
Thanks again.
does the http server work when it is sleeping?
i think i might have the same prob...
temporoAuthor Commented:
sorry i can't remember and i cant test it now as i have turned it off, for security resons.

i hope to fix it with the bios settings. i need to change the power settings or something like that.

-- Temporo
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Distributions

From novice to tech pro — start learning today.