Solved

XP Pro will not recognize USB mass storage devices

Posted on 2003-11-06
68
1,074,377 Views
Last Modified: 2013-12-09

I have a home built system and just replaced my motherboard. I did a clean install of Windows XP Pro (with SP1). I am now having a problem with USB devices which should be recognized as removable storage devices, specifically my Sony DSC-P50 camera, a USB flash memory card and SANDISK 6-in-1 reader. It is an ASUS P4C800-E Deluxe motherboard with USB 2.0 ports. The three devices worked prior to the clean install and work fine in my laptop. I know that my USB ports are working because my PALM Tungsten T3, Epson Scanner and APC UPS are working OK.

When I plug in the camera, flash or SANDISK, XP recognizes the device with the correct description of what it is. XP goes through the new hardware sequence, but fails. If I click on the USB device icon, it shows a tree with the device, disk drive below that, and then unknown device type below that. There are no special device drivers for these devices and they should all be supported by XP’s built in drivers. The whole system also freezes up at that point. It comes back when I pull out the USB cable to the device.

Other times when I plug in a device, it shows as "Generic device I:", but there is no device I: showing in My Computer.

The ASUS P4C800E-Deluxe has BIOS settings related to USB mass storage devices, but they seem to be for permanent devices that need to be present at boot. They don't seem to be for removable devices, like my SANDISK 6-in-1 card reader, Sony camera, or USB flash card. The BIOS USB screen shows what devices are active and will show the external USB hub and 1, 2 or 3 disks, depending on what is plugged in. The devices fail whether plugged into the hub or directly into the motherboard.

I noticed another interesting thing. If I run the Management Console/Disk Management utility while plugging in the devices, they show up with letters for 30 seconds or so before they disappear. Even while showing in Disk Management, however, they do not appear in Explorer. After 30 seconds they disappear and the new hardware utility reported a failure installing a new device.

This started 5 days ago. Last night, the devices would actually work for a few minutes before they reverted to the symptoms mentioned above.

In the Microsoft Community newsgroups there are many descriptions of similar problems, all related to XP not working with USB mass storage devices. None of the posts, though, has a solution.

I have the feeling I will end up doing a repair install of XP, but after only 5 days, that shouldn’t be necessary.

Any ideas?

Thanks,
Stan
0
Comment
Question by:rosest
68 Comments
 
LVL 14

Expert Comment

by:kronostm
ID: 9700753
There's a known issue with USB storage devices and mapped netwk drives .
Do you happen to have any mapped netwk drive?
0
 
LVL 14

Expert Comment

by:kronostm
ID: 9700787
is the USB root HUB driver properly installed?
0
 
LVL 17

Expert Comment

by:xema
ID: 9701172
Did you installed the chipset drivers that came on the MoBo CD?
0
 

Author Comment

by:rosest
ID: 9701977
kronostm: Thanks for the comments. I don't have mapped drives, but I should comment on the process I went through to builde the system.

When I first set up the system on Saturday, I had three physical hard drives, each with two partitions (my original 2 IDE drives and my new S-ATA drive). They mapped as C-F, D-G, E-H. I also had CD and DVD drives, I and J. After I copied my data off of the old E-H to the new C-F, I removed the original 2nd IDE drive and had C-E and D-F. The CD drives stayed at I and J so I then changed their assignments to G and H. The camera or SANDISK, whichever I plug in, tried to map to I:. I then moved the CD/DVD drives to Y and Z to get them out of the way. Could all these changes be related?

Another thing I should mention. As I have hunted around the web looking for information on this problem, I came across a note this morning that says that my Sony camera is supported by native WinXP drivers and I should not install the Sony-provided Win2000 drivers. I should have mentioned that, not realizing this, I did install the Sony Win 2000 drivers. Could that be the cause of this problem? If so, how do I remove whatever incorrect files or changes have been made? There is no reference to the camera in Control Panel Add/Remove software.

As for the USB root HUB, that must be working. There are no errors showing in device manager, and non-storage devices are working, like my Palm and scanner.

xema: I installed everything from the MB installation disk. I have also installed all updates from the Windows Update site, one of which addresses a USB 2.0 issue.
0
 
LVL 14

Expert Comment

by:kronostm
ID: 9702135
On the Sony camera's setup menu you'll find something like "USB connect" with two options "P2P" and "Normal" where P2p is peer to peer.
If you set the camera to p2p it will be detected by windows as a camera not as an external storage device.
Windows XP has drivers for this camera and should work ok, you won't encounter the "external drive mounting error" , but it's a workaround.

My guess is that Windows messed up the devices handling system while you worked with so many drive letters and then removed some.

If I were you I'd remap some drive letters, maybe remove some drives...leave only the boot drive and try mounting the external drives.
Maybe stupid windoze will revert to normal from that deep sh*t it entered.

sfc /scannow never hurts, but that restores only corrupted files not settings.

Anyway ... a repair from the boot CD (I recomend doing that with only the boot drive hooked) should fix the problem.

Indeed, different known issues came up on a google search but none to look exactly like yours. Again, my bet is on that too_many_drive_letters_when_installing and moving drives and drive letters.

I'll be gone till monday , very curious how it will end up.

(`'·.¸(`'·.¸ ~ ¸.·'´)¸.·'´)
«´.¸¸KRONOS¸¸.·`»
(¸.·'´(¸.·'´ ~ `'·.¸)`'·.¸)
0
 

Author Comment

by:rosest
ID: 9702256
Kronostm: Thanks, I'll try a sfc /scannow see if that does anything, and then the repair. Will let you know afterwards.  Have a good weekend.

Stan Rose
0
 
LVL 4

Expert Comment

by:freshair
ID: 9705328
generally when a USB device is plugged into your USB port, the OS looks for two things: first the USB port (determine hardware type), and then it searches for the right driver for the device. it is possible that your system doesn't contain the driver for your USB HDD so the device got detected incorrectly. in this case you would need to find a system driver for your device from the manufacturer. also, even if the instruction on the device package says plug-n-play, do a reboot after you plugged it in. pug-n-play isn't particularly reliable most of the time.
0
 
LVL 5

Expert Comment

by:muhalok
ID: 9706454
I know about another issue with USB devices. Many times you have to install drivers first, then plug the device. If you did it otherwise, Windows won't find the driver for the device even if its there - it just won't match between them. So, what you need to do is the following:
0. Unplug the devices
1. Uninstall the USB drivers (many driver installation utilities have "Uninstall" option)
2. Reboot (for safety)
3. Install the USB drivers for those devices
4. Plug the device in.

If this is the course of action - problem will be solved.


Another thing which is probable: USB 2.0 issue - probably your devices can't work on USB 2.0 ports?
0
 

Author Comment

by:rosest
ID: 9708236
These devices all used to work and all are supported by native WinXP drivers. I believe the problem is due to installing with the extra IDE drive and then removing it. It is getting confused by what it thinks are conflicting drive assignments. Also, I should have connected the first device, got it working then leave it connected and connect the second device. Get them both working then connect the third. They must have developed overlapping assignments because I connected them at different times. I have to find a way to unwind that confusion. Doing an SFC /SCANNOW and even a repair install didn't help because it preserved the original settings. I may have to do another clean install.

Stan
0
 
LVL 14

Expert Comment

by:kronostm
ID: 9712719
Stan ... you are right .... that's what I said ...windoze messed them up. Probably a clean reinstall is your bet now.
Have you tried the workaround with the sony camera ? Just out of curiosity...
0
 

Author Comment

by:rosest
ID: 9714702
I did try changing the camera setting to what Sony calls PTP. Sure enough, in that mode it looks like a Twain device and I was able to pull off my pictures. Not quite as convenient as simply copying them, but it does work; thanks for that tip.

I have another thread running now as an MS incident report. The MS tech asked for some log files and status setting so I'll see if that makes any progress. I am betting, however, that the clean install is in my future (again)! I will let you know what comes from that.

BTW, he (the MS tech) said that simply doing a hardware manager uninstall would eliminate the Win 2000 driver. I did that, but I have a feeling the files are still there and were picked up again when I reattached my camera. I wish I could get rid of those residual files to see if it helps.

Stan
0
 
LVL 14

Accepted Solution

by:
kronostm earned 500 total points
ID: 9715037
OK stan .. I helped you as much as I could .... now waiting to see how it ends
0
 
LVL 5

Expert Comment

by:muhalok
ID: 9717994
In order to remove the residual files do the following:
1. Open installed components in Device Manager, go to "Driver" and there click on "Driver details"
2. Write down the files names and their paths.
3. Uninstall the device in Device Manager.
4. Go and delete those files.

You're done.
0
 

Author Comment

by:rosest
ID: 9718022
Do I need to get rid of any .inf files, as well?

Thanks,
Stan
0
 
LVL 5

Expert Comment

by:muhalok
ID: 9718593
You may also look for the names of those files in \WINDOWS\INF dir to delete those and in registry and remove those keys.
0
 
LVL 14

Expert Comment

by:kronostm
ID: 9720371
listening .....
0
 

Author Comment

by:rosest
ID: 9721945
I checked the driver as muhalok suggested and , unfortunately, they are not the Sony-supplied drivers but are the WinXP distribution drivers. So, today being a holiday for me, it's time for a clean install.

I am going to start by doing a second installation to another partition just to verify that everything works fine , then I'll wipe out my prime install.

Will let you know much later.

Stan
0
 

Author Comment

by:rosest
ID: 9721946
I checked the driver as muhalok suggested and , unfortunately, they are not the Sony-supplied drivers but are the WinXP distribution drivers. So, today being a holiday for me, it's time for a clean install.

I am going to start by doing a second installation to another partition just to verify that everything works fine , then I'll wipe out my prime install.

Will let you know much later.

Stan
0
 

Author Comment

by:rosest
ID: 9727506
OK, I did it - a clean install. Everything is working fine now - the Sony camera, Sandisk reader (with 4 drives) and my flash card. Letting everything go to the default letters, the drives ended up assigned to:

C,D,E,F  Harddrives
G,H        CD and DVD
I            Camera
J,K,L,O   Sandisk
Q           Flash card

I was surprised to see that the Sandisk skipped over M,N and the Flash card skipped P. I bet that the earlier problem and these assignments are related in some subtle way.

I plugged them in one after another (camera-Sandisk-Flash), each time leaving the preceeding ones plugged in and powered on. That made sure they didn't accidentally try to pick the same letter.

Thanks to everyone for their help. I'll give out partial credit!

Stan
0
 

Author Comment

by:rosest
ID: 9747440
Although it is too late for me, I just received this information from MS support. They said it is OK to post:


Dear Stan,

Thank you for your reply. According to the information, I recommend you follow these steps to resolve this issue:

Step 1: Remove Hidden Devices

1. Click Start. Click Run. Type cmd and press OK.
2. Type "set DEVMGR_SHOW_DETAILS=1" (without quotation marks) and press Enter.
3. Type "set DEVMGR_SHOW_NONPRESENT_DEVICES=1" (without quotation marks) and Press Enter.
4. Type "start devmgmt.msc" (without quotation marks) and click press Enter.
5. Click View. Click Show hidden devices.
6. Click "+" to expand Imaging devices, Unknown devices and USB devices.
7. Are there any digital camera devices and unknown devices (including grayed out devices)? If so, please right click it and click Uninstall.

Step 2: Remove all oem*.inf files

=========================

1. Click start and click run then under the run line type in the command "cmd" (without the quotation marks)

2. In the command line, type in the following (without the quotes) and press enter after each command:

          "cd \windows\inf"
          "ren infcache.1 *.old"
          "ren oem*.inf *.old"
          "del C:\windows\setupapi.log"
          "exit"

Step 3: Removing all entries under HKEY_LOCAL_MACHINE/Enum/USB that start with VID

==================================================================

Removing the VID entries from the registry will cause them to be redetected at restart.

CAUTION: If you have a USB keyboard or mouse, do not remove the VID entry for these devices, otherwise, Windows may not restart correctly.

1. Click Start and click Run. Type regedit and click OK. The Registry Editor window will open.

2. Go to HKEY_LOCAL_MACHINE\System\CurrentControlSet\Enum\USB.

3. Highlight and delete all the VID_.... entries.

Permissions may be set allowing the deletion of the VID_ entries by following the steps below:

a)      Right-click the key to be deleted, and then click Permissions. The VID_... Permissions window will open.
b)      With Everyone highlighted in the Group or User name section, select Full Control in the Permissions section.
c)      Click Apply, and then click OK.

4. Turn off the computer.

Step 4: Reconnect the digital camera to the computer system:

=============================

1.      With the computer system turned off, reconnect the Sony DSC-P50 camera to the USB port.
2.      Restart the computer.
3.      After the Windows operating system has finished restarting, plug the digital camera into the electrical outlet.
4.      A New Hardware Detected window should open and reload the drivers.

If the camera still cannot work, I recommend you plug the camera to another Windows XP computer (Desktop) to test whether this camera works. I suspect it is an incompatibility issue.

Thank you for your time. I look forward to your reply.

Best Regards,

Microsoft Windows Support Professional
0
 
LVL 14

Expert Comment

by:kronostm
ID: 9747845
and .... does any of the above work?
0
 

Author Comment

by:rosest
ID: 9748775
As I mentioned, I had already done the clean install and that had fixed my problem. I posted it for anyone else with a similar problem.

Stan
0
 
LVL 14

Expert Comment

by:kronostm
ID: 9753311
OH, sorry ...I was out of track ... too many Qs I'm partitipating in  :-|
0
 

Expert Comment

by:nrparsons
ID: 9991813
Solution Title: XP Pro will not recognize USB mass storage devices
Author: rosest
Date: 11/06/2003 01:05PM PST

Our problem is almost identical to the one described above.  Same Mobo, OS (Home), and problem except it's with a permanently installed 6 in 1 Card Reader attached to the MOBO pin connections.  We tried all the suggestions given to Stan and no luck.  In building this system, it was a clean XP Home install that found the card reader as an unknown mass storage device.  No drivers are supplied for XP.

On a different machine running Windows XP Home, a different 6 in 1 card reader that came with XP drivers was installed.  It will boot and find the 6 in 1 reader once in a while and add all the drives.  Most of the time when it boots, it doesn't find it at all.

Nancy & Janet

0
 

Author Comment

by:rosest
ID: 9992013
Even today, I find that it occasionally fails to display the drives in the Explorer pane. One time I discovered that even though Explorer didn't show the drives, I typed the drive letter into the address bar and it then showed it (ie, H:\ ). I was actually quite surprised when it did that.

Stan
0
 

Expert Comment

by:viaduct
ID: 10175916
OK. I've got this too... ...first with an external IDE USB box, and today with my new Minolta dimage XT. My work around will be to use a handy win98se machine connected to the same network... but it's not a brilliant solution.

I was thinking of doing the Microsoft thing, but I am nervous about losing other stuff that actually does work at the moment.
0
 

Author Comment

by:rosest
ID: 10176342
Did you try the trick I discovered on 12/23? That is, even if it does not appear in the Explorer folder tree (or My Computer window), manually type a reference to it in an Explorer address window and see if it appears.

Stan
0
 

Expert Comment

by:viaduct
ID: 10199419
I Tried your trick - no luck.
I tried the Microsoft method you posted - no luck.
Looks like it's a clean install then... what a bore!
0
 

Author Comment

by:rosest
ID: 10200803
My condolences!

Stan
0
 

Expert Comment

by:viaduct
ID: 10200926
Done it!
Oh joy!
Disk now works, and so does camera!
Thanks for the help,
Tim.
0
 

Expert Comment

by:sonuku
ID: 10365075
*shakes fist at the sky*

i had basically the same problem, but with a usb 2.0 external hdd

i tried:
- messing with the bios
- updating the bios
- yelling at windows
- having a ciggerette
- the registry fix
- searching google for close to 7 hours

looks like i could of fixed it 3 times over if i just formatted... see how it goes eh ^-^

-signed: an annoyed consumer-whore
0
 

Expert Comment

by:mike_rock_911
ID: 10486560
I have had similar same problems for a while with a 20GB Arcdisk.  Works perfectly with my WIN-98 laptop but baulks when I try to use it with my WIN-XP machine.  I tried all the solutions above as well.

Through a process of elimination, I got to one of those eureka moments - just disable the USB 2.0 host controller (termed enhanced host controller) in the device manager let everything default to USB 1.1 henceforth.  You get the standard warning message when you subsequently plug in a 2.0 device but ignore it, I figure half-baked performance beats NO performance anyday (actually, my hard disk works satisfactorily under 1.1).

It is clear the current version of the USB 2.0 (enhanced host controller) driver is flaky.  I'll probably re-enable it when a new service pack is released.
0
 

Expert Comment

by:LecturerAlan
ID: 10506470
Hi all

I have a very similiar issue occuring with my Windows xp pro, just recently I brought a mp3 player for my daughter, did nt work at all, tried all the normal fixes, tricks you name it  I did it,
so then just to make life interesting I went and brought a second hard drive 80 gb to match the other 80 gb, Hd installed ok, but Xp will insist on looking for new drivers every time I boot up,
so up to date...I lecture at a local fe college and have a new 256mb jumpdrive to carry files AROUND YOU KNOW THAT SORT OF THING SO HERE I AM THINKING THIS IS GOING TO BE REALLY COOL NO MORE DISK BURNING....WRONNNGG... USB DEVICE NOT RECOGNISED WILL NOT INSTALL WILL NOT DO ANYTHING......ok I feel better now.... deep breath.. so I start thinking it must be because I am using usb 1.1 and although I have heard usb is backwards compitable this must be causing some sort of conflict in some deep dark area of windows...simple Ill go and buy a usb 2 pci card, plug it in, install the drivers and all will be well....WRONG WRONG WRONG.
I am a 3d modeller and animator in my spare time and a mac designer lecture in my college time
as much as a hate to say this I will be going 64 mac next time purely for the reliability factor

if somebody somewhere sympathises with this drawn out moan at microsofts flaky hardware support please advise what to do

Alan Figg
0
 

Expert Comment

by:sonuku
ID: 10510633
ok, i went out and bought a PCI USB 2.0 card for like $15, its got three ports, and everything works now...

my guess is its something to do with intel's usb 2.0 chipset being... well... **** ^-^

do yourself a favour, go to your local computer store, and just get a usb 2.0 card, its soooooooooooo much easier than screwing around with everything... it took me nearly 2 days of searching google for a fix, messing with xp installs, trying to install drivers in a certain way... its just a pain in the ass.

$15, and all your problems are fixed.

--

on another note, if you are using a mac, they suck, and 2 times out of 5, they dont spam enough power through the usb, and it wont mount the external hdd... so pick your external case with care, and make sure they say "mac compatible" >_< cause, the little "extra power" dongle, thats PS/2... well... can't go anywhere on a mac... they dont have one ^-^
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 

Expert Comment

by:sonuku
ID: 10510660
p.s
make sure you get the VIA chipset usb pci cards (directed towards alan).

PLUS! in my spamming around windows, i noticed a quick fix for the ASUS P4P800, i went into "hadware devices" and disabled the onboard USB 2.0 controller.
that forced it to become 1.1, even tho all my ports on the mobo are 2.0... and it worked then... just slowly... but it was a temporary work around, until i got the pci card.

thx all

-sonuku
0
 

Expert Comment

by:LecturerAlan
ID: 10511999
sonuku

thanks a bunch, funny thing is the 4 port usb device is made by Via ?
I am getting to the stage where I am thinking clean install will fix what do you think ? is there a quicker way of doing a clean install without having to go through the hours of down loads

Alan
0
 

Author Comment

by:rosest
ID: 10514779
Regarding the Asus P4P800, this is my motherboard and, after the clean install on 11/11, is working fine. I have since added a few other USB 2 devices and they are working without problems, too. In particular, I have an HP PhotoPrinter 7960. In addition to being a regular USB printer, it has flash card slots for several different formats and they all work fine.

Stan
0
 

Expert Comment

by:BazzaW
ID: 10521212
XP Pro again I think - my related problem is with a WD 80Gb USB2 HDD for backups.  Am on my second drive now after workarounds with the WDD techs failed and I could no longer access the first drive.  On my work PC (Compaq + XP Pro, single HDD + Sony USB 1 card reader) all went OK and had no problems recognizing the drive(s) or writing to it.  

But at home (Epox 8 RDA + 2 HDD x 3 partitions + USB1 scanner & multicard reader), the external USB2 HDD is nothing but trouble.  Initially it installed fine, then while writing threw an I/O error.  On reboot (external HDD still connected) all the USB drives were gone and no sign of the Mass Storage Device.  Then XP suddenly crashed (as it did previously) and now takes nearly 10 minutes to get past the initial Bios screen.  Once into Windows it seems OK, if a little slow, and Device Mgr shows a problem with the Mass Storage Device.  Have tried disabling and uninstalling both that and the USB2 root hub - no improvement.  XP cannot find the Mass Storage Drivers on install CD to replace, so I'm stuck at present as WD HDD has no drivers.  Only option may be to try drivers from my new Sony F828, not so far installed.

Dont wanna blow this drive away, but its looking increasingly likely judging from comments above.
Any bright ideas out there ?
Ta - Bazza
0
 

Expert Comment

by:sonuku
ID: 10523906
hmm, try a differnt drive "case"

sometimes the hdd will require more power than the usb can put out (5amp)... other than that, i dont know... also, usb sometimes ****s out when there is "line noise" in the cable, soi if you are using a extension cable, that might be 1 cause.

the only solution i've got so far is the PCI card... but it differs from person to person... depending on the hdd case u use, and the hdd u use...

basically, if nothing you've tried here works, best bet is to curl up in a ball, and cry ;_;

solutions mentioned so far:
1. reinstall windows (FORMAT C: (*&@#(*& Wewe we w e w wwe we wew)
2. install drivers in a certain order
3. mess with the bios
4. get a pci card usb 2.0
5. disable usb 2.0 and force it into 1.1
6. try a differnt usb 2.0 case

if nothnig works.. well... i'd send your motherboard back, and complain about its general ****ness ;_;

-much luv and respect for ppl with **** usb 2.0 "bits"

-sonuku
0
 

Expert Comment

by:BazzaW
ID: 10530243
Ta Sonuku - first up the WD external HDD is powered from mains, not via USB, so that shouldnt be a problem.  Checked the Bios and buggar all I can improve there.  Am already on my 2nd external HDD case - as mentioned it seems to work fine on my work PC/XP Pro, but theres something weird about the home setup/XP Pro.  Up til now all my USB devices (multicard reader & scanner) have run fine - no conflicts/problems.  But the external HDD stuffs up majorly, even with the others disconnected.  This just in from the WD techs - havent tried it yet (looks prety basic) but posted it in case it may help others: -
>>>>>>
In Windows Explorer, right-click your hard-disk, and then click Properties.
Click the Hardware tab.
Click the hard disk, and then click Properties.
Click the Policies tab.
Click to clear the Enable write caching on the disk check box, and then click OK two times.
Press CTRL-ALT-DEL to bring up a task list.

You can end task on one program at a time, trying to stop the device in between.

Do not end task on Systray or Explorer. This will cause Windows to crash.

To check for indexing in Windows 2000 and XP only, access My Computer and right-click on the drive letter assigned to the drive. Select Properties. You should see the Allow Indexing option under the General tab. If this is checked, uncheck it.

Please test the drive(s) from within windows, with our Data Lifeguard Diagnostics for Windows (Windlg10.exe)
Please disconnect the USB cable, then disconnect power to the drive from the wall, then reconnect power, then reconnect data cable (all done while Windows is running. This usually solves the problem.)

Never leave an external drive connected while a machine boots. Only connect when windows has loaded and always disconnect usinfg safley remove hardware before Windows shuts down.

Please type 822603 in the search the knoweldge base field at the link below, install the update.

http://support.microsoft.com/

If not, look in Disk Management (start, run, diskmgmt.msc, is the drive there? But not in My Computer? If so what does it show as in Disk management...E.G. healthy/ on-line/ NTFS or FAT 32/ what capacity etc; then look in Device Manager, locate the drive - under Disk Drives/ Other Devices or USB controllers. It there is a code from microsoft and a question mark or exclamation mark, if so reinstall the driver or uninstall the device and then reinstall it using add new hardware.
<<<<<<<<<

.... Personally I think the problem is XP ... at present I'm locked out with the damn Mass Storage Device - it is faulty in DevMgr and I cant disable it or uninstall/reinstall it  - it refuses to do anything, and that I suspect is what is causing the long boot delay.  Have loaded the Sony USB 2 driver but that made no difference.  If no joy from the above, next move will be a USB card I think, then in desperation a complete wipe out and OS reinstall - LINUX is looking better every day - wont take much of an excuse now to say good riddence to Bill Gates.
Chow
Bazza
0
 

Expert Comment

by:LecturerAlan
ID: 10530338
Hi all

I ve just completed a complete  install xp  updates and all, and low and behold all works usb2 pci card, jumpdrive, mp3 player.... harddrive no longer  being installed on every start up but.... every cloud doth hath a silver lining....one of my drive partitions is reporting a bad sector .......boo ####ing hoo

 My advice to this exchange is:

 when you install a new device..expect your pc to crash, need a complete rebuild,
 and what ever other common failures we have to put up with. Order a new sp1 disk this will speed up the install process, if on installation of new product the xp powered machine does not crash. then your bloody lucky this time round because you know full well it will get you next time.
In closing,
Should we really feel this way about a "professional os" I dont think so.

Alan
0
 

Expert Comment

by:BazzaW
ID: 10534146
SMILE
Aha - some small success......have managed to get my external HDD back up and working without major heartache.  Basically disabled write caching on my internal HDD's as in post above, and then disabled USB2 as per Sonuku suggestion, also disabled faulty Mass Storage Device.  Plugged Ext HDD in and lo and behold it was recognized again - made sure write caching was also off for it as well.  After disconnecting drive and rebooting I then ENABLED both USB2 and the MSD again and uninstalled the latter.  Then I plugged the Ext HDD back in and up jumped a working MSD in Device Mgr/USB.  So far I have copied several gigs of files with no problems.  Note write caching is still OFF on both my internal HDD's & the exteranl HDD - might slow things a bit, but X fingers, no more problems.  
Damn M#####soft.

Bazza  
0
 

Expert Comment

by:BazzaW
ID: 10866712
Seems this thread may have dried up?  
Anyhow - I finally have solved the XP/USB2 problem with my system.  In my case the trick was to install SP1 BEFORE loading the motherboard drivers (I have an early copy of XP Pro minus SP1).  I lucked on the solution after (finally) checking FAQs on the EPOX web site, and their support confirmed it.  So had to uninstall the drivers, reinstall SP1 then the Epox drivers, reinstate USB2 in the Bios and now everything seems to be behaving itself.  
Long live USB 2
Bazza
0
 

Expert Comment

by:eddieyan
ID: 10978074
Hi All,

I am facing almost the same problem as well. Bought a new USB2.0 Notebook HDD External Casing. It's USB powered and I'm running windows 2000 sp4. During initial installation, I can't get it to work. There is an exclamation mark besides the USB Mass Storage in Device Manager.

After reading some threads here, I got some idea. Just reinstall back my VIA 4 in 1 driver(via_438.exe) and after restart, there is no more exclamation mark! So I just go to Disk Management to partition the HDD. It work like charm now :) Hope this help!

Eddie
0
 

Expert Comment

by:itc_sburnett
ID: 11152863
I have been having a similar problem.  I plug in ANY diogital camera, Windows XP detects it as a mass storage device, but NOTHING shows up in Explorer.  I look into the Device manager, and all is fine...camera detected & drivers installed properly. The Generic volume is there nuder Storage volumes.

It turns out....that I had drive letters A thru F asigned to local resources.  My first NETWORK drive started at G. As luck would have it, the G Mapped drive no longer existed, but was still viewed as "Accounting on server-name"..When I clicked on it, Violia!  there was my PC Camera. WinDOZE took the G mapping as it wasnt used, and didnt BOTHER to let me know :-)  ( Idid repeatedly press refresh..tothe point, my F5 key needs replacing!)

SO, I guess the moral of the story is, MAKE SURE you have a Drive letter avaialble before the list of network mappings.

Steve
0
 

Expert Comment

by:brittjerry
ID: 11563203
Guys,

Just to re-inforce what Steve said above, I had similar problems with XP Pro and a USB POentax camera. Couldn't see it in Explorer though it was all installed correctly. So disconnected my first network drive (J:) after my last local drive mapping (I:). Lo and behold Windows leapt into life detecting the camera straightaway and assigning letter J: to it. Thanks for all your input it really helped me.

Jeremy
0
 

Expert Comment

by:gcruik
ID: 11581093
Samd problem with WD 120 HDD usb drive. recognized, but won't read (or write)
I looked at the USB ports in the device manager and freaqued out.  there are a mess of them Do I delete all of them?  Or will it really ****up the machine so it won't work?
I feel life is too short for some of this.

Will call IBM tomorrow and bug then  this machine is a recent purchase X40 thinkpad.

Gordon
0
 

Expert Comment

by:Austin_TX
ID: 11712353
This fixed the issue "The specified service does not exist as an installed service" error for USB storage devices

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E 967-E325-11CE-BFC1-08002BE10318} key in the registry, where I discovered a zero-length binary "LowerFilters" value (which should be string or multi-string).

It should not exist with zero-length let alone be binary.

Delete this value and then reboot.
0
 

Expert Comment

by:flowerbot
ID: 12268702
First of all, thanks for this post, I couldn't find anything anywhere else that even came close to the solution for my problem, however what's been posted thus far didn't work for me and I eventually found a solution from a hint I found here (drive letters), so I thought I'd post it for anyone who might come across this page in future, since this site usually provides the best answers to my problems ....

This was my problem - USB mass storage drive was recognised by XP, drivers installed automatically, however I couldn't see the drive in the File Explorer.  I REALLY DIDN'T want to reload Windows so I looked around laterally and found that I had to register the drive and format it (I had assumed that this would have already been done by the supplier - it wasn't).  This might be bleeding obvious to most of you, but it wasn't to me so here's what I ended up having to do:

Go to Control Panel/Computer Management/Storage/Disk Management.
I saw my drive but it didn't have a partition or drive letter, so did a quick format, nominated a partition and gave it a drive letter.

Since then everything's been working perfectly.

I hope this helps.
0
 

Expert Comment

by:BazzaW
ID: 12269485
A related problem I have encountered which may be of interest to some of you (my WD USB2 external HDD is working just fine now)  .... I recently installed a Sony DRU 700A DVD RW and accompanying Nero 6.3.1.23 (lite).  O/S = XP Pro SP1.  I left my BTC CD RW'er as slave on channel 2, Sony DVD as Master.  DVD's wrote fine and I could copy CD's from CD>DVD writer, but the damn thing would NOT write a data CD - no way.  After some to-ing & fro-ing with Nero tech support we solved the problem.  NVIDIA drivers needed updating (I have an EPOX RD8A MBd with GEForce 2 MX graphics card) - apparently old drivers were causing a SCSI/IDE command abort problem when writing to CD.  I also updated to latest NERO ver 6.3.1.25.  The full explanation from NERO is reproduced below in case it helps someone - Situation A was my problem.

Hope this helps
Bazza


SOLUTION EX NERO

affected systems
Operating System: Windows 2000 SP3 and Windows XP SP1
Configuration:
A. Mainboard: nForce2 Chipset - see mainboard list below
CD-Recorder: attached to one of the IDE-ports
B. Mainboard: i845G, 845GE, 845PE
CD-Recorder: attached to the USB 2.0 port
C.Windows XP SP1 with a preinstalled USB 2.0 driver from the OEM


SYMPTOM

A customer get the following error as soon as he try to burn (under Windows 2000/ XP):

SCSI/IDE Command aborted

and sometimes they get a crash/freeze too.

You will find the following in the logfile of Nero:

Status: 0x02 (0x03, SCSI_ABORTED)
HA-Status 0x10 (0x0A, SCSI_HASTAT_REQUEST_SENSE_FAILED)
TA-Status 0x00 (0x00, OK)
Sense Key: 0x05 (KEY_ILLEGAL_REQUEST)
Sense Code: 0x26
Sense Qual: 0x02
CDB Data: 0x2A 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x1F 0x00 0x00 0x00
Sense Data: 0xF0 0x00 0x05 0x00 0x00 0x00 0x00 0x00
0x00 0x00 0x00 0x00 0x26 0x02

CAUSE
Situation A:
A bug in the installation routine of the chipset drivers causes the error within the updating
of the IDE/ATAPI controller device drivers, because it does not install the correct
IDE Controller Drivers.
1. nForce2 IDE Controller
2. nForce 2 IDE MCP2 IDE Controller
A list of several mainboards which uses the nForce2 chipset:
Abit NF7, Abit NF7-S, ASUS A7N8X, Biostar M7NCG, Chaintech 7NJL1, Chaintech Zenith Series CT-7NJS, Epox EP-8RDA, EP-8RDA+, EP-8RGA+, Leadtek WinFast K7NCR18D, MSI K7N2-L / K7N2G, ..

Situation B:
It seems to be that the USB drivers of Microsoft have problems with the Southbridge ICH4 - B0 Stepping.

Situation C:
If you have a computer that supports USB 2.0, and if you have a preinstalled USB 2.0 driver from the OEM, you continue to use the earlier preinstalled drivers for USB 2.0 even after you install SP1.


RESOLUTION
Situation A:
It seems nVidia could resolve this issue now. Please download the latest nForce2 driver version (2.45 or newer).
In case the problem is still there:
1. Please download the latest drivers from nVidia for nForce2. Extract the executable using e.g. Winzip. There is now an IDE \ WinXP folder.
In this folder are the following inf files:
a. nvidesm.inf for NVIDIA® nForce(TM) IDE Controller
b. nvhdc.inf for NVIDIA NForce MCP2 IDE Controller
It depends on your mainboard which inf file is to select. If you see nvidesm as adapter in the Choose Recorder dialog within Nero then select nvhdc.inf
2. Now click Start -> Settings -> Control Panel -> System
3. Now open the property sheet Hardware
4. Click Device Manager
5. Double-click IDE ATA/ATAPI Controller and then double-click the appropriate controller.
6. Now click the property sheet Driver and then click on Update Driver...
7. Now select the file nvidesm.inf resp. nvhdc.inf
8. After finishing you need to reboot for changes to take effect.

In case this does not have the wished effect please repeat it by using the other inf file.

Situation B:
For Windows 2000 SP3 a working patch is now available. More information: <http://support.microsoft.com?kbid=810090>
This patch does not solve the problems under Windows XP SP1. The development of a new driver is near to the end and will hopefully soon be available.
As long as the new drivers are not available is it the best way to avoid the usage of the burnmethod DAO. By using TAO or DAO/96 the problem will not occur.

Situation C:
Information on how to upgrade to the USB 2.0 drivers included in WIndows XP SP1 will you find at the following page: <http://support.microsoft.com/?kbid=329632>

If you have any further questions do not hesitate to contact us again.
0
 
LVL 3

Expert Comment

by:Fermion
ID: 12342568
An OUTSTANDING thread!
Good reading.
0
 
LVL 1

Expert Comment

by:ellis-
ID: 12456255
In you're bios... the usaly is a tab were you can turn on and off USB mass storage. I had this problem once.
0
 

Expert Comment

by:Umapathyxp
ID: 12512774
Try Windows XP serivce pack 2 or 1. Service Pack 1 solves variety of USB problems
0
 
LVL 2

Expert Comment

by:garak1357
ID: 12519923
Install Linux.  :)
0
 

Expert Comment

by:nwpc
ID: 12755134
I have had this happen  and have always solved the problem by removing all USB drivers from Device Manager, rebooting and letting them reinstall.
0
 

Expert Comment

by:kamelle
ID: 12874276
Hallo experts,

my boss gave me an external hardrive, formated, with datafiles. My XP SP1 recognized the device pluged in an USB-slot.
In  the Disk-Administration of mmc.exe appears the device as disk2; the size is visible. The disk is marked as not initialized and not mapped. The initalisation ends with the "unknown error 80004005" read in the event protocol.
What does this error mean?

0
 

Expert Comment

by:GeoffSchultz
ID: 12913601
I've been following this thread in an attempt to solve a similiar problem.  I have a USB based universal media adapter that I've been trying to get running.  When I plug it in the system detects the hardware, but can't find a device driver for it.  I end up with a non-functional "?USB Storage Device" under Other Devices.

I followed parts of this thread that applied to me, but nothing helped.  Then I saw NWPC's post which stated that "....have always solved the problem by removing all USB drivers from Device Manager, rebooting and letting them reinstall" so I thought that I'd give that a shot.  When I rebooted it found the controllers but can't find the drivers for the USB controllers!  WHAT?  How can this be?  XP found the drivers when I installed it.  I'm wondering if there's a generic problem which is keeping the system from finding any drivers.  Any ideas?

-- Geoff
0
 

Author Comment

by:rosest
ID: 12913884
Are you running XP and if so, have you installed SP2? SP2 contains various updated drivers and knows a few more devices than the original XP or XP/SP1. Just another idea.

I have had no problems with SP2 on several systems.

Stan
0
 

Expert Comment

by:GeoffSchultz
ID: 12916914
I'm running SP2.  Also note that when I insert a PCMCIA USB 1 card, that the system can no longer find the USBHUB driver for it.

In my windows\inf directory I find

usb.[inf,pnf]
usbport.[inf,pnf]
usbprint.[inf,pnf]
usbstor.[inf,pnf]
usbvideo.inf

In my windows\system32\drivers I find the following .SYS files

usb8023
usb8023x
usbcamd
usbcamd2
usbd
usbehci
usbhub
usbintel
usbohci
usbport
usbprint
usbstor
usbvideo

-- Geoff

0
 

Expert Comment

by:Goaty
ID: 13033433
Hi,

I had a similar problem with an easy solution.
I had been using a USB Pen Drive (USB Disk Pro) in Windows XP (SP2) for a while and it worked fine.
One day I connected a friend's JUMPDRIVE up to my PC to copy some files of it, again it worked fine. However when I plugged my Pen Drive back in XP recognised it, but I could not see the drive in Windows Explorer.
Reading the comments above I checked Disk Management in Control Panel\Administrative Tools\Computer Management to see what was happening.
I could see my USB Pen Drive, but it had been allocated a Drive Letter G: which was the same as the Drive letter allocated to a Network Drive.
I right-clicked on the USB Pen Drive, changed the drive letter and the drive reappeared in Windows Explorer.

Steve
0
 

Expert Comment

by:frog
ID: 13170451
All the above sounds sooooo familiar.

I found that success depended on which port the devices were plugged into.

I know that can't be because they aren't "ports", it's a bus so all the sockets are basically in parallel. But stability kept on being related to the actual socket, so when it was stable I just left everything permanently plugged in. A printer, a link cable to another PC, an external HDD.
For me it is much more stable than having one cable and plugging each device into it as required.

Perhaps the idea of having dedicated sockets might help some of you.

The problem now is the 4th port, I have 2 flash drives that share it.
One connects most of the time, the other one causes the PC to reboot most times but will eventually connect. (Win XP + SP2)

I'm wondering if anyone knows of a PCI bus card that provides 4 USB ports that are actual dedicated ports so that each will only connect to one particular device.
ie much like com1, com2, etc. or even better like LPT1 and com1 - totally separate ports with no chance of interaction.




0
 

Expert Comment

by:hunterdnance
ID: 13634470
Had this problem many times, very simple solution:

1. Go into Device Manager and expand the "Universal Serial Bus Controllers" group.
2. Uninstall every device listed under this group (right click on device, left click uninstall)
3. Be sure all USB devices are unplugged!! *THIS IS KEY*
4. Restart Computer
5. Upon restart the computer will recognize all the devices and install them.
6. Plug in a device and see if it works.

Hope this helps!
0
 

Expert Comment

by:AliGator
ID: 13966786
Re: Comment from hunterdnance
Date: 03/26/2005 12:54AM GMT
 
"Had this problem many times, very simple solution:"

Just installed new mobo. No XP USB 2.0 driver supplied with board for 4x USB ports. Told to rely on SP1 driver. Had to do an XP repair/install from original pre-SP1 CD to get Windows to load, then did a Windows Update, which installed full SP2. USB ports would not work. Followed README instructions on Support CD supplied with mobo. to uninstall all USB devices from Device Manager (as recommended by hunterdnance above), then right-click and select "scan for hardware changes". USB ports were re-installed with USB 2.0 drivers from SP2. USB 2.0 scanner and USB 2.0 PVR work, SD Card Readerdoes not work. Card Reader is listed in Disk Management as "mass storage device", in Windows explorer and in Device Manager. All reported as working normally until I try to open a picture on an SD card, then I get the error message "The drive is not ready for use ... ". Seems to be a mass storage device problem.
The SD Card Reader works perfectly from an expansion USB hub plugged into my laptop, which is networked to my Photoshop desktop, but this is an untidy work-around. I fear the only alternative is a clean install of XP and SP2, but I have had enough of those to do me for as long as I can get away with it!

Isn't this thread a remarkable comment on Microsoft and Windows XP?
0
 

Expert Comment

by:freddiebrown999
ID: 14393698
I am using all 4 USB ports on my Gigabyte Mobo, and have added a 4 port USB hub for more flexibility. I recently added a 10 GB 2.5" HDD in an external USB enclosure, and found that Windows XP (SP1) would not recognise it. I checked the Device Manage snap in and the USB was shown as Unknown Device....  Despit this device being successfully discovered and accessed on anoher computer (my laptop), without any problems.

Following this thread carefully, I finally tried connecting the external power supply that was supplied with the 4 port hub,- and bingo! the device was discovered. Obviously the HDD tipped the power requirement over the limit that the mobo was able to provide, a scenario that wasn't immediately evident as other less power hungry devices (Sandisk multi card reader, cameras etc) had not had problems being identified.

Hope this helps - available power is an issue the more USB devices that are installed to a system.
0
 
LVL 3

Expert Comment

by:akarre
ID: 14561126
check USB chip set software make sure 2.0 XP SP1 only comes with lower ver.
Cable also has to be 2.0.
But it's most likely the firmware or Software/drivers for you Sony Cam System Id Try there First of tech support if the problem is common they will tell you a solution or that they know and are working on it.  (with an apoligy of course.) Had a Cam same problem was not Sony though. printer, mouse, key, scandisk all worked But no camara. you best bet get a more compatable camara, Or wait it out the will eventually release software to fix.  
0
 

Expert Comment

by:chasers
ID: 14689709
This may sound a little odd, but after trawling the interweb for days trying to fix a fault where nothing was being recognised correctly on any of my 6 main usb ports, I realised that nearly everyone that has this problem is either a self-build or have replaced thier motherboard.  In my case, I had not bothered to correctly use conductive support pillars on one of my mount holes.  The +5v supply for USB is present in most motherboards EVEN IF TURNED OFF but the lead plugged in and live.  To see if your issue is similar to mine, unplug the lead from the power supply for a couple of minutes after uninstalling all USB devices as described above.  Plug in, turn on and try to see if your device is now recognised.  I know it sound odd but try it, worked for me!  I can only think that my poor earthing was leading something odd to happen where ground was floating or something.
0
 

Expert Comment

by:visualfilesis
ID: 21478685
QUOTE "GeoffSchultz:I've been following this thread in an attempt to solve a similiar problem.  I have a USB based universal media adapter that I've been trying to get running.  When I plug it in the system detects the hardware, but can't find a device driver for it.  I end up with a non-functional "?USB Storage Device" under Other Devices.

I followed parts of this thread that applied to me, but nothing helped.  Then I saw NWPC's post which stated that "....have always solved the problem by removing all USB drivers from Device Manager, rebooting and letting them reinstall" so I thought that I'd give that a shot.  When I rebooted it found the controllers but can't find the drivers for the USB controllers!  WHAT?  How can this be?  XP found the drivers when I installed it.  I'm wondering if there's a generic problem which is keeping the system from finding any drivers.  Any ideas?

-- Geoff"

I'm having the same issue as Geoff, windows does not seem to be able to find any new drivers for any USB devices. Even if I change the port that my keyboard is in, it cannot find drivers for it!
It must have worked at some point as the keyboard has drivers whilst in it's usual socket, so there must be some setting or file which has changed that is stopping it from finding new drivers.
I know this is an old topic, so did anyone find a fix for this?
I'm running windows XP Home, SP2
0
 

Expert Comment

by:visualfilesis
ID: 21478692
0

Featured Post

Do You Know the 4 Main Threat Actor Types?

Do you know the main threat actor types? Most attackers fall into one of four categories, each with their own favored tactics, techniques, and procedures.

Join & Write a Comment

Is it worth it to buy an Echo? In a word, yes! For me it was definitely worth it. I use mine on a daily basis. Prologue & Privacy At first, I was very skeptical about the Amazon Echo. In general, I don't like voice assistants. I don't li…
In this article you will get to know about pros and cons of storage drives HDD, SSD and SSHD.
It is a freely distributed piece of software for such tasks as photo retouching, image composition and image authoring. It works on many operating systems, in many languages.
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, Just open a new email message.  In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now