Exchange 2000 won't deliver mail (SMTP - Unable to bind to the destination server in DNS)

Okay, Here is the lowdown...

Exch 2000 isn't letting any emails out... we can get emails in and we can send locally. I can look in the SMTP queue and see all of them just sitting there, with the error Unable to bind to the destination server in DNS. I have tried using a few different DNS servers, with no luck.

The network set up -- Three Servers (Exchange, File Server, SQL Server) sitting behind an ISA Server. I can telnet to port 25 on external servers, so i know that i can get out.

HELP!!!!

Not sure what to do...
comersionAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JasonBighamCommented:
****
quote
****

Open the Exchange Systsem Manager
(Start->Programs->Exchange->System Manager)

Select Servers->(your server name)->SMTP
in the tree

Right click on Default SMTP Virtual Server, select properties
Select the Delivery tab, then Advanced
then "Configure external DNS servers:   CONFIGURE"
And make sure it has the right DNS server(s).

0
BembiCEOCommented:
What JasonBigham described presupposes, that you use DNS name resolution for the delivery and not a smarthost. If you use a smarthost, it may be also an authentication problem, as most of the providers will reject anonymous relay. But your desciption points me also to DNS.

I would rather setup a clean DNS Server instead of configuring DNS servers within the virtual SMTP Server, as it is easier to check. So, setup a DNS Server and add forwarders, which point to DNS servers of your ISP. If your DNS works fine, you should be able to resolve all external names from any client using nslookup. If not, external DNS name resolution is blocked.

Also note, that telnetting port 25 through ISA depends on the machine, from where you do it. If your EXCH and ISA resides on the same machine, you must add a packet filter, which allows outgoing traffic on port 25. If ISA and EXCH are different machines, you may ne a server publishing rule. The same procedure may affect DNS. If the source of the DNS request is on the same machine (either EXCH or DNS forwarder), you need a packet filter which allows outgoing DNS traffic.

All traffic on the ISA itself needs packet filters, all traffic from clients are handled by the way, the clients are connected to ISA. If you use Secure NAT clients (no additional software, no web client, no firewall client), the site and content rules and the protocol rules in combination with protocol definitions determines, what the client is allowed to to. So it it important, on which machine which services resides on - and from this machine, you have to check these services, if they pass ISA.

See for details:
http://support.microsoft.com/default.aspx?scid=kb;en-us;287646&Product=exch2k
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

VahikCommented:
Do not configure dns enteries in ur smtp server all it does confuse ur exchnage.
I have said this 100 times so here it goes one more time just make sure all ur clients
and servers(including ur exchange DC GC and DNS server itself)point to ur internal DNS server
and in ur dns server make sure to put ur isp's DNS server in ur forwarders tab.After all this
u must also make sure ur internal DNS servers are not root dns servers in that case nothing and i mean nothing will get out.To know if ur dns server has become a root server just go to ur
dns\server and make sure u dont see any entery for this ".".if u do just delete it and restart ur
dns server.Also i am sure u know how to configure ur DNS servers behind an isa server if u dont just go to isaserver.org and u will see tons of material on that subject.Good luck.
0
comersionAuthor Commented:
you are correct -- I am using DNS and not smarthost.

My Exch and ISA are not on the same machine, but both have DNS server installed.

If i take the dns settings out of the SMTP Virtual Server, then i get the error: The remote server did not respond to a connection attempt.

I believe that i have all of the Mail Server Filters/packets/publishing rules set correctly in ISA, so it is probably a DNS problem? How do i confirm / fix this?

Looks like it's gonna be a late night for me...
0
David WilhoitSenior Consultant, ExchangeCommented:
set DNS entries on your IP configuration, not the VS. EXchange points to your internal DNS, and all other requests are forwarded to the external DNS. If your Exchange server is only looking at external DNS, or the forwarder IP addresses you have configured on the DNS properties do not respond, then this can happen. Try this: change a forwarder IP on the DNS server to 4.2.2.2. REstart the DNS Server service, and the DNS client, and the DNS client on Exchange. See if mail starts to flow.

D
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
comersionAuthor Commented:
Thanks everyone!!!
0
ShaqstersCommented:
Hi All,

I have exactly the same problemI was running MS proxy server and exchange 2000 server with IIS.Suddenly one day my cleints cannot access internet through proxy server.I restarted the IIS and all was OK.After 2 hours my exchange stopped sending any outgoing emails.Incomming is fine and so is the local delivery.In the queue I can see all my mails pending which, after a while says status is retry>if we look at the properties it says unable to bind the destination server to DNS.I reinstalled IIS and then reinstalled exchanges 2000.Still the same problem.im using a smart host!

3 sleepless nights now and any help will be appreciated!!!
0
Crutch36Commented:
Hi,

as posted above the problem is with DNS. in the DNS look in the properites and forwarders. Try a different dns address like freedom 2 surf 192.106.56.6 or 194.106.33.42. it sounds as if your current dns stopped responding hence the lack of internet access and email. (either delete old forwarder or push new ones up in dns properties)

i had exactly the same problem with exchange 2k3 sbs, changed my forwarder bang flowing emails
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.