Solved

Exchange 2000 won't deliver mail (SMTP - Unable to bind to the destination server in DNS)

Posted on 2003-11-06
9
33,908 Views
Last Modified: 2012-08-14
Okay, Here is the lowdown...

Exch 2000 isn't letting any emails out... we can get emails in and we can send locally. I can look in the SMTP queue and see all of them just sitting there, with the error Unable to bind to the destination server in DNS. I have tried using a few different DNS servers, with no luck.

The network set up -- Three Servers (Exchange, File Server, SQL Server) sitting behind an ISA Server. I can telnet to port 25 on external servers, so i know that i can get out.

HELP!!!!

Not sure what to do...
0
Comment
Question by:comersion
9 Comments
 
LVL 8

Assisted Solution

by:JasonBigham
JasonBigham earned 50 total points
ID: 9697709
****
quote
****

Open the Exchange Systsem Manager
(Start->Programs->Exchange->System Manager)

Select Servers->(your server name)->SMTP
in the tree

Right click on Default SMTP Virtual Server, select properties
Select the Delivery tab, then Advanced
then "Configure external DNS servers:   CONFIGURE"
And make sure it has the right DNS server(s).

0
 
LVL 8

Expert Comment

by:JasonBigham
ID: 9697717
0
 
LVL 35

Assisted Solution

by:Bembi
Bembi earned 50 total points
ID: 9697832
What JasonBigham described presupposes, that you use DNS name resolution for the delivery and not a smarthost. If you use a smarthost, it may be also an authentication problem, as most of the providers will reject anonymous relay. But your desciption points me also to DNS.

I would rather setup a clean DNS Server instead of configuring DNS servers within the virtual SMTP Server, as it is easier to check. So, setup a DNS Server and add forwarders, which point to DNS servers of your ISP. If your DNS works fine, you should be able to resolve all external names from any client using nslookup. If not, external DNS name resolution is blocked.

Also note, that telnetting port 25 through ISA depends on the machine, from where you do it. If your EXCH and ISA resides on the same machine, you must add a packet filter, which allows outgoing traffic on port 25. If ISA and EXCH are different machines, you may ne a server publishing rule. The same procedure may affect DNS. If the source of the DNS request is on the same machine (either EXCH or DNS forwarder), you need a packet filter which allows outgoing DNS traffic.

All traffic on the ISA itself needs packet filters, all traffic from clients are handled by the way, the clients are connected to ISA. If you use Secure NAT clients (no additional software, no web client, no firewall client), the site and content rules and the protocol rules in combination with protocol definitions determines, what the client is allowed to to. So it it important, on which machine which services resides on - and from this machine, you have to check these services, if they pass ISA.

See for details:
http://support.microsoft.com/default.aspx?scid=kb;en-us;287646&Product=exch2k
0
 
LVL 26

Assisted Solution

by:Vahik
Vahik earned 50 total points
ID: 9697877
Do not configure dns enteries in ur smtp server all it does confuse ur exchnage.
I have said this 100 times so here it goes one more time just make sure all ur clients
and servers(including ur exchange DC GC and DNS server itself)point to ur internal DNS server
and in ur dns server make sure to put ur isp's DNS server in ur forwarders tab.After all this
u must also make sure ur internal DNS servers are not root dns servers in that case nothing and i mean nothing will get out.To know if ur dns server has become a root server just go to ur
dns\server and make sure u dont see any entery for this ".".if u do just delete it and restart ur
dns server.Also i am sure u know how to configure ur DNS servers behind an isa server if u dont just go to isaserver.org and u will see tons of material on that subject.Good luck.
0
What Security Threats Are You Missing?

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

 

Author Comment

by:comersion
ID: 9698079
you are correct -- I am using DNS and not smarthost.

My Exch and ISA are not on the same machine, but both have DNS server installed.

If i take the dns settings out of the SMTP Virtual Server, then i get the error: The remote server did not respond to a connection attempt.

I believe that i have all of the Mail Server Filters/packets/publishing rules set correctly in ISA, so it is probably a DNS problem? How do i confirm / fix this?

Looks like it's gonna be a late night for me...
0
 
LVL 24

Accepted Solution

by:
David Wilhoit earned 100 total points
ID: 9698493
set DNS entries on your IP configuration, not the VS. EXchange points to your internal DNS, and all other requests are forwarded to the external DNS. If your Exchange server is only looking at external DNS, or the forwarder IP addresses you have configured on the DNS properties do not respond, then this can happen. Try this: change a forwarder IP on the DNS server to 4.2.2.2. REstart the DNS Server service, and the DNS client, and the DNS client on Exchange. See if mail starts to flow.

D
0
 

Author Comment

by:comersion
ID: 9698598
Thanks everyone!!!
0
 

Expert Comment

by:Shaqsters
ID: 11135815
Hi All,

I have exactly the same problemI was running MS proxy server and exchange 2000 server with IIS.Suddenly one day my cleints cannot access internet through proxy server.I restarted the IIS and all was OK.After 2 hours my exchange stopped sending any outgoing emails.Incomming is fine and so is the local delivery.In the queue I can see all my mails pending which, after a while says status is retry>if we look at the properties it says unable to bind the destination server to DNS.I reinstalled IIS and then reinstalled exchanges 2000.Still the same problem.im using a smart host!

3 sleepless nights now and any help will be appreciated!!!
0
 

Expert Comment

by:Crutch36
ID: 11956829
Hi,

as posted above the problem is with DNS. in the DNS look in the properites and forwarders. Try a different dns address like freedom 2 surf 192.106.56.6 or 194.106.33.42. it sounds as if your current dns stopped responding hence the lack of internet access and email. (either delete old forwarder or push new ones up in dns properties)

i had exactly the same problem with exchange 2k3 sbs, changed my forwarder bang flowing emails
0

Featured Post

Free book by J.Peter Bruzzese, Microsoft MVP

Are you using Office 365? Trying to set up email signatures but you’re struggling with transport rules and connectors? Let renowned Microsoft MVP J.Peter Bruzzese show you how in this exclusive e-book on Office 365 email signatures. Better yet, it’s free!

Join & Write a Comment

Local Continuous Replication is a cost effective and quick way of backing up Exchange server data. The following article describes the steps required to configure Local Continuous Replication. Also, the article tells you how to restore from a backup…
Following basic email etiquette rules will help you write a professional email and achieve a good, lasting impression with your contacts.
In this video we show how to create a Resource Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: Navigate to the Recipients >> Resources tab.: "Recipients" is our default selection …
In this video we show how to create a mailbox database in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Servers >> Data…

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

14 Experts available now in Live!

Get 1:1 Help Now