Solved

TCP/UDP Ports opening on Cisco 1721

Posted on 2003-11-06
5
2,143 Views
Last Modified: 2012-06-27
Hi,
I am by far a cisco expert, and i apologise in advance for my crappy IOS config. Here is the situation:
I am configuring my 1721 with a WIC 1T (serial) connected to a PPP connection, then NATted out to the rest of the network through the Fast Ethernet Interface. Here is my config file:

Current configuration : 2225 bytes
!
version 12.3
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname TheRouter
!
no logging console
enable secret 5 xxxxxxxxxxxxxxxxx
enable password 7 xxxxxxxxxxxxxxxxxxxxxxx
!
ip subnet-zero
!
!
no ip domain lookup
!
!
!
!
!
interface FastEthernet0
 description connected to EthernetLAN
 ip address 192.168.8.3 255.255.255.0
 ip nat inside
 speed auto
 full-duplex
!
interface Serial0
 description connected to Internet
 ip address 61.88.xxx.xxx 255.255.255.252
 ip access-group 106 in
 ip nat outside
 encapsulation ppp
 no fair-queue
!
router rip
 version 2
 passive-interface Serial0
 network 192.168.8.0
 no auto-summary
!
ip nat pool Cisco1721-natpool-0 61.88.172.106 61.88.xxx.xxx netmask 255.255.255.252
ip nat inside source list 1 pool Cisco1721-natpool-0 overload
ip nat inside source list 10 interface Serial0 overload
ip nat inside source static tcp 192.168.8.1 25 61.88.xxx.xxx 25 extendable
ip nat inside source static tcp 192.168.8.1 110 61.88.xxx.xxx 110 extendable
ip nat inside source static tcp 192.168.8.1 53 61.88.xxx.xxx 53 extendable
ip classless
ip route 0.0.0.0 0.0.0.0 61.88.xxx.xxx
no ip http server
!
access-list 1 permit 192.168.8.0 0.0.0.255
access-list 106 permit tcp any any eq ftp-data
access-list 106 permit tcp any any eq ftp
access-list 106 permit tcp any any eq telnet
access-list 106 permit ip any any
access-list 106 permit tcp any any eq smtp
access-list 106 permit icmp any any echo
access-list 106 permit icmp any any echo-reply
access-list 106 permit tcp any any eq www
access-list 106 permit tcp any any eq pop3
access-list 106 permit tcp any any eq domain
access-list 106 permit udp any any eq domain
access-list 106 permit udp any any eq nameserver
access-list 106 permit tcp any any eq 4899
access-list 106 permit tcp any any eq 6600
dialer-list 1 protocol ip permit
no cdp run
snmp-server community public RO
snmp-server location xxxxxxxxxxxxxxxxx
snmp-server contact xxxxxxxxxxxxxxxxxx
snmp-server enable traps tty
!
line con 0
 exec-timeout 0 0
 password 7 xxxxxxxxxxxxxxxxxxxxxxxx
 login
line aux 0
line vty 0 4
 password 7 xxxxxxxxxxxxxxxxxxxxxxxxxxx
 login
!
no scheduler allocate
!
end

(4899 and 6600 are for a remote management software)

The problem is mainly two things:

One:
i am unable to type 'no ip nat pool Cisco1721-natpool-0' to get rid of that nat pool. apparently its "in use", I have tried getting rid of the references to nat on the interfaces (no ip nat inside, outside etc..), but still nothing. This doesnt REALLY worry me, having the line 'ip nat inside source list 10 interface Serial0 overload' doesnt affect it does it?

Two:

Although I have enabled all the different ports in access list 106, and applied it to s 0, a port scanning program (NetScanTool v5.1) detected only the Telnet port was open. I can telnet to it fine. Any reason for this? should i maybe use the port numbers instead of the key words? apparently 4899 and 6600 are still closed, so i dont know if that would work either.  grrr

Thanks in Advance and i apologise again for being such a stupid newbie to cisco routers  :)


-Trav
0
Comment
Question by:Travstar
5 Comments
 
LVL 13

Accepted Solution

by:
td_miles earned 44 total points
ID: 9699539
1. The reason you get this error message is because NAT is in use from this pool. See this link, for how to solve the problem:
http://www.cisco.com/en/US/tech/tk648/tk361/technologies_tech_note09186a0080094422.shtml

2. You haven't created a static NAT for the ports 4899 & 6600, so even though you are allowing the traffic to enter the outside interface of the router, without a NAT, there is nothing to respond on these ports (the router won't because it isn't running any service on these ports). You would need to add lines similar to the other ones you have for ports 25, 110 & 53 to forwardthis traffic to a specific internal host.


Hi to a fellow Australian  :)
(well, judging by the IP 61.88.x.x you are in AU)
0
 
LVL 5

Assisted Solution

by:epylko
epylko earned 43 total points
ID: 9699896
What are you trying to accomplish with access-list 106? Your line that says "permit ip any any" lets all your IP traffic through and pretty much makes the rest of your access list useless.

-Eric
0
 
LVL 17

Assisted Solution

by:mikecr
mikecr earned 43 total points
ID: 9702738
To remove your NAT pool, go to your serial interface and do "no ip nat outside" and then do "clear ip nat translations *" from the administrative prompt. Once you have done this, go into global config mode and remove your NAT pool.

Epylko is correct also that your permit ip any any statement makes the rest of your access list useless at that point. Try using another port scanner such as Superscan4 to test your ports. You need to adjust that line in your access list first.
0

Featured Post

Find Ransomware Secrets With All-Source Analysis

Ransomware has become a major concern for organizations; its prevalence has grown due to past successes achieved by threat actors. While each ransomware variant is different, we’ve seen some common tactics and trends used among the authors of the malware.

Join & Write a Comment

Suggested Solutions

In this tutorial I will show you with short command examples how to obtain a packet footprint of all traffic flowing thru your Juniper device running ScreenOS. I do not know the exact firmware requirement, but I think the fprofile command is availab…
Quality of Service (QoS) options are nearly endless when it comes to networks today. This article is merely one example of how it can be handled in a hub-n-spoke design using a 3-tier configuration.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now