TCP/UDP Ports opening on Cisco 1721

Hi,
I am by far a cisco expert, and i apologise in advance for my crappy IOS config. Here is the situation:
I am configuring my 1721 with a WIC 1T (serial) connected to a PPP connection, then NATted out to the rest of the network through the Fast Ethernet Interface. Here is my config file:

Current configuration : 2225 bytes
!
version 12.3
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname TheRouter
!
no logging console
enable secret 5 xxxxxxxxxxxxxxxxx
enable password 7 xxxxxxxxxxxxxxxxxxxxxxx
!
ip subnet-zero
!
!
no ip domain lookup
!
!
!
!
!
interface FastEthernet0
 description connected to EthernetLAN
 ip address 192.168.8.3 255.255.255.0
 ip nat inside
 speed auto
 full-duplex
!
interface Serial0
 description connected to Internet
 ip address 61.88.xxx.xxx 255.255.255.252
 ip access-group 106 in
 ip nat outside
 encapsulation ppp
 no fair-queue
!
router rip
 version 2
 passive-interface Serial0
 network 192.168.8.0
 no auto-summary
!
ip nat pool Cisco1721-natpool-0 61.88.172.106 61.88.xxx.xxx netmask 255.255.255.252
ip nat inside source list 1 pool Cisco1721-natpool-0 overload
ip nat inside source list 10 interface Serial0 overload
ip nat inside source static tcp 192.168.8.1 25 61.88.xxx.xxx 25 extendable
ip nat inside source static tcp 192.168.8.1 110 61.88.xxx.xxx 110 extendable
ip nat inside source static tcp 192.168.8.1 53 61.88.xxx.xxx 53 extendable
ip classless
ip route 0.0.0.0 0.0.0.0 61.88.xxx.xxx
no ip http server
!
access-list 1 permit 192.168.8.0 0.0.0.255
access-list 106 permit tcp any any eq ftp-data
access-list 106 permit tcp any any eq ftp
access-list 106 permit tcp any any eq telnet
access-list 106 permit ip any any
access-list 106 permit tcp any any eq smtp
access-list 106 permit icmp any any echo
access-list 106 permit icmp any any echo-reply
access-list 106 permit tcp any any eq www
access-list 106 permit tcp any any eq pop3
access-list 106 permit tcp any any eq domain
access-list 106 permit udp any any eq domain
access-list 106 permit udp any any eq nameserver
access-list 106 permit tcp any any eq 4899
access-list 106 permit tcp any any eq 6600
dialer-list 1 protocol ip permit
no cdp run
snmp-server community public RO
snmp-server location xxxxxxxxxxxxxxxxx
snmp-server contact xxxxxxxxxxxxxxxxxx
snmp-server enable traps tty
!
line con 0
 exec-timeout 0 0
 password 7 xxxxxxxxxxxxxxxxxxxxxxxx
 login
line aux 0
line vty 0 4
 password 7 xxxxxxxxxxxxxxxxxxxxxxxxxxx
 login
!
no scheduler allocate
!
end

(4899 and 6600 are for a remote management software)

The problem is mainly two things:

One:
i am unable to type 'no ip nat pool Cisco1721-natpool-0' to get rid of that nat pool. apparently its "in use", I have tried getting rid of the references to nat on the interfaces (no ip nat inside, outside etc..), but still nothing. This doesnt REALLY worry me, having the line 'ip nat inside source list 10 interface Serial0 overload' doesnt affect it does it?

Two:

Although I have enabled all the different ports in access list 106, and applied it to s 0, a port scanning program (NetScanTool v5.1) detected only the Telnet port was open. I can telnet to it fine. Any reason for this? should i maybe use the port numbers instead of the key words? apparently 4899 and 6600 are still closed, so i dont know if that would work either.  grrr

Thanks in Advance and i apologise again for being such a stupid newbie to cisco routers  :)


-Trav
TravstarAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

td_milesCommented:
1. The reason you get this error message is because NAT is in use from this pool. See this link, for how to solve the problem:
http://www.cisco.com/en/US/tech/tk648/tk361/technologies_tech_note09186a0080094422.shtml

2. You haven't created a static NAT for the ports 4899 & 6600, so even though you are allowing the traffic to enter the outside interface of the router, without a NAT, there is nothing to respond on these ports (the router won't because it isn't running any service on these ports). You would need to add lines similar to the other ones you have for ports 25, 110 & 53 to forwardthis traffic to a specific internal host.


Hi to a fellow Australian  :)
(well, judging by the IP 61.88.x.x you are in AU)
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
epylkoCommented:
What are you trying to accomplish with access-list 106? Your line that says "permit ip any any" lets all your IP traffic through and pretty much makes the rest of your access list useless.

-Eric
0
mikecrCommented:
To remove your NAT pool, go to your serial interface and do "no ip nat outside" and then do "clear ip nat translations *" from the administrative prompt. Once you have done this, go into global config mode and remove your NAT pool.

Epylko is correct also that your permit ip any any statement makes the rest of your access list useless at that point. Try using another port scanner such as Superscan4 to test your ports. You need to adjust that line in your access list first.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.