Cannot access internet via alphabetic URLs

Using WIndows XP, and brodband.

Recently, I have been unable to access the internet via URLs. I can access pages by entering the IP address. When I attempt to ping to a URL, it fails, but I can ping to an IP address.

My ISP said that it is necessary to edit the registry, but that for insurance purposes they could not tell me what to do. I rang Microsft, who directed me to www.winguides.com/registry/. I have downloaded this but I'm still not sure what I need to edit.
jmwilsonmaghullAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

mapledrumsCommented:
Open up a command prompt & type "ipconfig /all" & post your results here. You should have some DNS servers' IP addresses under your DNS settings. If you're using DHCP to receive such settings automatically & you're not able to do so, try "ipconfig /release" followed by "ipconfig /all" to see if you obtain the DNS servers' IPs. If you need to configure the DNS setting manually (your ISP should be able to provide the IPs for you), you'll have to do so under "Control Panel", "Network Connections", right click on your NIC, select "Properties", double-click on "Internet Protocol (TCP/IP)", selet "Use the following DNS server addresses", type in your primary & secondary DNS servers.

Then click "OK" till you're back in "Control Panel" & do a test to see if your PC resolves hostnames.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
PsiCopCommented:
Your DNS is not functioning.

Somewhere in your WinXP IP configuration settings, you have DNS servers defined. mapledrums told you were to look. Either the servers you have listed are not functioning DNS servers, or your DNS requests are being blocked between your machine and the servers.

The fact that you can pinf by IP address means basic IP connectivity is work. You've eliminated your NIC, cables, IP stack, router, etc. as the culprit. The breakdown is in name resolution, the process of translating the alphanumeric host name into an IP address.
0
snerkelCommented:
Check your DNS settings, should be something like this

http://www.tech24.arce.co.uk/VPNsetup/IP.html
0
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

jmwilsonmaghullAuthor Commented:
Thanks for help so far. Obviously I'm gaining information on a PC other than my own, so there is a delay in responding.
0
jmwilsonmaghullAuthor Commented:
Thanks to Snerkel. Everything now working as required.
0
mapledrumsCommented:
Hi jmwilsonmaghull,

Both PsiCop & I mentioned that your DNS settings weren't correct, but our answers weren't accepted or assisted. Although I didn't provide "pictures" for you to go through, but I did provide step by step instructions which would have amounted to the same thing. Care to enlighten us here ?
0
mapledrumsCommented:
It's EE policy to accept the first answer that solves your problem. Besides, since someone DID solve your problem, you still gave him/her a B grade. I don't think you're being fair here.
0
jmwilsonmaghullAuthor Commented:
Sorry. New to board. Not aware of etiquette.

What actually made the difference was my checking the box for Obtain DNS server automatically. What was previously checked was the Use the following DMS server addresses, which then included the correctly given DNS address. Checking the other box appeared to make all the difference.
0
PsiCopCommented:
I think that mapledrums is correct on both counts - at least one other Expert contributed to the Answer, and the Question was Answered completely.

If you'd like to change your Answer selection, or split points, or change the grade, then at this point you need to post a (free) Question in the Community Support forum. This forum is monitored by the EE Moderators, who can make these changes for you. Explain what changes you'd like made, and include a link to this Question.
0
mapledrumsCommented:
Thanks to all for the followup.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking

From novice to tech pro — start learning today.