Solved

Migration problem

Posted on 2003-11-07
14
329 Views
Last Modified: 2010-03-04
I migrated an application from one server (that uses Netscape web server) to another server that uses apache web server. The entire application is written in Perl.

The application is asking username and password while entering into the application. But the application needs to display the user name. It was working fine in the old server (Netscape web server) but not here. The application (in apache) is NOT displaying the user name. The "$ENV[REMOTE_USER]" is not returning the expected user name. Where might be the problem?

Is it due to Netscape/apache server difference or should i configure anything in the apache's conf files?

Please help me in this regard. Any other pointers would be helpful.

0
Comment
Question by:rnavanee
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 5
  • 2
14 Comments
 
LVL 5

Expert Comment

by:g0rath
ID: 9703150
It exists the the var name may have changed. All env vars are prepended with HTTP_

So $ENV[HTTP_REMOTE_USER] that should work
0
 

Author Comment

by:rnavanee
ID: 9712264
No, the "$ENV[HTTP_REMOTE_USER]" is not working. Any other ideas ...??


0
 
LVL 38

Expert Comment

by:yuzh
ID: 9712632
How did you setup the user authentication ?

When a user login, authentication is ckeck again some kind of database, or just
use a flat text file defined in  .htaccess file ?

0
Get 15 Days FREE Full-Featured Trial

Benefit from a mission critical IT monitoring with Monitis Premium or get it FREE for your entry level monitoring needs.
-Over 200,000 users
-More than 300,000 websites monitored
-Used in 197 countries
-Recommended by 98% of users

 

Author Comment

by:rnavanee
ID: 9712680
It uses .htaccess file only. User authentication is working fine. But i need the name of the user who logged in. As i said the application is not working due to change in the server (NS sever to the apache server). Please give me some more info regarding the Perl/apache configuration to be done.
0
 
LVL 38

Expert Comment

by:yuzh
ID: 9712691
Check you Appache configuration file httpd.conf to see how the access control is definded
for appache, use .htaccess? or just one file control the whole site (access.conf)

do a searrch on "AccessConfig" to find out
0
 
LVL 38

Expert Comment

by:yuzh
ID: 9712752
If you are not asked for authentication and REMOTE_USER is shown as undefined, then Apache is not recognizing the .htaccess file. Check that you have `AllowOverride AuthConfig' set for the cgi-bin directory.

0
 

Author Comment

by:rnavanee
ID: 9712754
I looked into the "httpd.conf" file.

It contains ...
#ResourceConfig conf/srm.conf
#AccessConfig conf/access.conf
....

"AccessConfig" is commented in that file.
0
 

Author Comment

by:rnavanee
ID: 9712938
The application asks for authentication and i am allowed to enter the application only if the correct username/password is given. So there is no problem with that. However the user name is not getting recognized.

I am pasting the lines from httpd.conf fine:
.....
    ScriptAlias /cgi-bin/ "/web/cgi-bin/"

    <Directory "/web/cgi-bin/">
        AllowOverride AuthConfig
        Options None
        Order allow,deny
        Allow from all
    </Directory>
....


Please let me know if there is any problem with the configuration shown here.
0
 
LVL 38

Accepted Solution

by:
yuzh earned 125 total points
ID: 9713178
Modify your cgi-bin Directory (just commet them out) and make it looks like
the followings:

<Directory "/web/cgi-bin/">
     Options FollowSymlinks
 </Directory>

PS: don't change the other  </Directory> settings, and then restart Appache to see what happen.
 
0
 

Author Comment

by:rnavanee
ID: 9713751
Is it mandatory to restart the apache server to make  the new changesto take effect ?

0
 
LVL 5

Assisted Solution

by:g0rath
g0rath earned 125 total points
ID: 9714809
The new changes only propogate to new childern. If you do not restart, then process 1 may be running old version, and it's time to spawn a new child, then proccess 2 is running new version.

Depending on what your doing this may not be bad.

But since a client can either hit proccess 1 or 2 for every web page hit, it's always recommended to restart the server. But that can mean downtime, and that is already accounted for. Send the HUP signal to the server, and it'll reread the conf files for all current processes.
0
 
LVL 38

Expert Comment

by:yuzh
ID: 9727863
How's it going?
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Hi, in this article I'm going to teach you how to run your own site, and how to let people in (without IP). I'll talk about and explain each step... :) By the way, everything in this Tutorial is completely free and legal. This article is for …
If you are a web developer, you would be aware of the <iframe> tag in HTML. The <iframe> stands for inline frame and is used to embed another document within the current HTML document. The embedded document could be even another website.
This video Micro Tutorial shows how to password-protect PDF files with free software. Many software products can do this, such as Adobe Acrobat (but not Adobe Reader), Nuance PaperPort, and Nuance Power PDF, but they are not free products. This vide…
NetCrunch network monitor is a highly extensive platform for network monitoring and alert generation. In this video you'll see a live demo of NetCrunch with most notable features explained in a walk-through manner. You'll also get to know the philos…

688 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question