Cant see server in Lan

Hello experts,
I've got a home network set up - 3 windows mechines and 1 linux web server.
the linux server has several domains hosted on it.
I can only access this linux box from a WAN, since if i enter my external IP within the LAN, i reach my router's web interface.
If i'm on the WAN and I enter my IP, i reach my linux server.
If i'm within the LAN and i enter the internal IP of the server, i reach its main page (obviously).

Here comes the question:
how do i reach the different domains from within the LAN, if i can only access the server using name based domains from a WAN?

say my domains are : example.com  domain.com  expert.com
and my internal ip of the server is 10.0.0.9

how do i access .... example.com within the LAN?

from a WAN it works great... but accessing it from the LAN is the problem here...

Thanks !
11odsAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

lrmooreCommented:
Try creating a local hosts file on a workstation with the IP address of the Linux server:

example:
10.0.0.9 <tab> www.example.com
10.0.0.9 <tab> www.expert.com
10.0.0.9 <tab> www.test.com

0
vtobusmanCommented:
 go into the web config of your routers web interface....  their should be an option to turn on and off remote admin... turn it off..

  or you can setup an internal DNS server and set your client computers to use that dns server ...  on the internal dns server set the domains to go the internal address
ie domain 1 = 10.0.0.9

 if you decide on an internal dns server an easy ont to use i found to be one called Simple DNS available for download at http://jhsoft.com

 Good Luck
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
cubanjoeCommented:
You need to specify a new DNS name on your DNS server .  Eg: http://webbox will take you to you internal IP.  I was messing with this yesterday with one of my servers, and it solved our problem.

If your just on a switch, and have no central server, then you need to download a DNS server like vtobusman suggested.  
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

Brazuca_CalifaCommented:
Your Apache more likely is configured with virtual domains right? Where expert.com points to one web site etc..
So your computer needs to be reaching the server using this names.
Try your local host file on Win2k located at
c:\winnt\system32\drivers\etc
hosts

0
koquitoCommented:
Are those domains only intended for web use?
You can differentiate the domains by IPs.
USe ifconfig in your LInux box to add more than one IP to the NIC, then using Apache (or any web server) you can assign the right IP to the appropiate site(domain).
0
iaindCommented:
If your domains are registered on an external DNS server then when you type the domains names in they get resolved to the external ip addresses.  Most routers don't like this and you can't have trafic that goes out, to come back in.

You have two options.

Add the servers to the hosts file on all your internal pc's/servers.
Or run your own internal DNS server and mirror the external information but with the internal IP addresses.  Your linux server will already have BIND installed on it mostlikly.

Have a look at http://www.linux.org/docs/ldp/howto/DNS-HOWTO.html and http://www.siliconvalleyccie.com/linux-hn/dns-static.htm
0
wyliecoyoteukCommented:
If your router supports it, you could possibly use port forwarding.
Or you could set up a reverse proxy on the linux server.
0
11odsAuthor Commented:
sorry for the delay

thank you for your input and ideas everyone,

i will close this question by the end of the week once i get a chance to try this!
sorry again

11ods
0
asurada2003Commented:
hi,

If u are using linux,
u have to install samba so that u other windows platform can connect to it.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.