Solved

Network ok, ping ok, but no http or network browsing

Posted on 2003-11-07
21
22,199 Views
Last Modified: 2013-11-13
Well this one has me pretty much stumped.
I have a Compaq 3000 Presario laptop with XP Pro installed
    Built in NIC, and WLAN
Everything appears to be functioning correctly as far as the network is concerned
    My DHCP is assigning me IP and DNS
    I can ping addresses @my fire wall @ local ISP @ cisco.com
   So my DNS resolution is also working
When I open a browser window I was getting redirected to a search page, but the search page would not come up the address would simply rotate between two addresses very rapidly and no page would display
    I took care of this as it was a piece of spy ware that needed a manual un install
Now I do not get any page "page can not be displayed"
and network request say that "no network provider accepted the given path"
It is pretty important that I not do a system restore as there is a lot of user installed "stuff" that would be a pain to redo.
Thanks for any help
0
Comment
Question by:stubbsmc2
  • 7
  • 5
  • 3
  • +4
21 Comments
 
LVL 49

Expert Comment

by:sunray_2003
ID: 9702758
0
 
LVL 44

Expert Comment

by:CrazyOne
ID: 9702759
Your Winsock may be corrupted
http://members.shaw.ca/techcd/WinsockXPFix.exe

Another Expert shekerra found out what the WinSockXPFix does:

1- Netsh ip int reset resetlog.txt....2.)

2- replaces these Registry keys:
 HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Winsock..
 HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Winsock2

3- backup old host file and replaces host file

So in essence it detects the OS and releases the IP then resets TCP stack using Netsh. Next it deletes the two registry keys above and Imports the correct keys into the registry. Then it backs up your current hosts file and replaces it with a fresh one and then reboots.
0
 
LVL 49

Expert Comment

by:sunray_2003
ID: 9702762
0
 
LVL 97

Expert Comment

by:war1
ID: 9702770
Greetings, stubbsmc2!

Your network connection may be corrupted by the removal of the spyware. Here is a script to reset your winsock and TCP/IP stack.

http://members.shaw.ca/techcd/WinsockXPFix.exe

Best wishes, war1
0
 

Author Comment

by:stubbsmc2
ID: 9703030
Good suggestions.  I am trying one of the actuall spyware removal tools.  I removed "IgetNet" manually.  I had to of course download and burn the software to a CD since I cannot browse on the Laptop.  But if this does not work I will try the Winsock repair.
Thanks I will update in about 20 min
0
 

Author Comment

by:stubbsmc2
ID: 9703344
OK here is the update.  (and yes I know it took me more then 20 min, I got distracted)  I ran Spy Bot and it found a lot of different spyware and removed it.  I then tried again to browse and got nothing. No error messages either, simply page cannot be displayed.  
I then downloaded the Winsock fix tool and applied this.  the first attempt failed.  The second attempt completed.  but on reboot I still cannot browse.  the home page comes up "page cannot be found" and when I try to switch pages it simply says that windows cannot open the seach page.
I can now browse the local network
I can also use http in safe mode.
am I missing a step in the repair? or is this something else?
0
 
LVL 16

Expert Comment

by:joinaunion
ID: 9703423
go into your internet options click on advanced tab then scroll down to where it says http 1.1 settings and make sure both are checked then retry browsing
0
 
LVL 21

Expert Comment

by:gemarti
ID: 9703424
Try to flush your DNS

START | RUN | IPCONFIG /FLUSHDNS



0
 
LVL 21

Expert Comment

by:gemarti
ID: 9703534
Troubleshooting Browsing Error Messages in Microsoft Internet Explorer
http://support.microsoft.com/default.aspx?scid=/support/IE/ie5/topics/browse/iebrowseemts.asp
0
 
LVL 21

Expert Comment

by:gemarti
ID: 9703574
Here is another method for repairing winsock and rebuilding your TCP/IP Stack:

01. Use Regedit.exe to navigate to:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Winsock.

02. Export the Winsock key to a Winsock.reg file, to save it.
03. Delete the Winsock key.
04. Navigate to:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Winsock2.

05. Export the Winsock2 key to a Winsock2.reg file, to save it.
06. Delete the Winsock2 key.
07. Exit Regedit.exe.
08. Control Panel / Network and Dial-up Connections.
09. Right-click Local Area Connection and press Properties.
10. Select Internet Protocol (TCP/IP) and press Uninstall.
11. After uninstalling TCP/IP, shutdown and restart your computer.
12. If TCP/IP is NOT automatically re-installed, use Control Panel / Network and Dial-up Connections.
13. Right-click Local Area Connection and press Properties.
14. Press Install.
15. Press Protocol / Add.
16. Select Internet Protocol (TCP/IP) under Network Protocol, possibly under Microsoft, and press OK.
17. After the TCP/IP install, power off and power on your external modem, or shutdown and restart your computer.
0
What Is Threat Intelligence?

Threat intelligence is often discussed, but rarely understood. Starting with a precise definition, along with clear business goals, is essential.

 

Author Comment

by:stubbsmc2
ID: 9703790
Well, he plot thickens.  Windows seems to think that I am not connected to the internet.  I have ran the wizard multiple times and still windows says that I am off line.  I can try to manually rebuild my Winsock but I am not sure if that will help.
0
 
LVL 44

Expert Comment

by:CrazyOne
ID: 9703899
Maybe your modem has taken a nose dive. See if you can updated the drivers or delete them through Device manager and reboot so as to refres the driver.
0
 

Author Comment

by:stubbsmc2
ID: 9703959
CrazyOne, that could be the case but it works great in safe mode.
I think I have a protocol problem still somewhere.
0
 
LVL 44

Expert Comment

by:CrazyOne
ID: 9704038
Then you still have something that is blocking
Check for spyware again but use a different program than you did before.

And double check for viruses

Online Scanners

 Norton Web Services  
Go to this page and click on Scan for Viruses
http://security.symantec.com/ssc/vc_about.asp?j=1&langid=us&venid=sym&plfid=22&pkj=REODSKVYRMHCGVRVRMN

It needs to download a few file so as to activate the scan so you may see a message like this.

"The Scan for Viruses uses an ActiveX program to scan your computer. The download is approximately 1.5MB and can take about 10 minutes over a 28.8 modem.

The scan can take more than 20 minutes depending on the speed of your computer and the number of files that you have. Please do not browse away from this page unless you intend to abort the scan.
 
Downloading Scan for Viruses controls. Please wait...
 
During the download, you might see one or more messages asking if it is OK to download and run these programs. Click Yes when these messages appear.
 
Note: Scan for Viruses does not scan compressed files"
======================
 Trend Micro HouseCall        
www.housecall.antivirus.com
"Trend Micro's free online virus scanner
In order to better serve our customers, we ask HouseCall users to register before scanning their computer.  By registering, you will receive virus alerts from our team of Virus Doctors. You will be able to unsubscribe when you receive your first email. You can also scan without registering"
http://housecall.antivirus.com/housecall/start_corp.asp
======================

PC Pitstop Virus Scan
Our free Web-based virus scan uses Panda Software's award-winning technology and virus list. We're checking against the "wildlist," the roughly 200 viruses that are most prevalent in the world in a given month
http://www.pcpitstop.com/antivirus/default.asp
0
 
LVL 44

Expert Comment

by:CrazyOne
ID: 9704046
Oops never mind you can't get online unless you can in safe mode.
0
 

Author Comment

by:stubbsmc2
ID: 9704131
Good catch, I was just about to say, how should I do this.
But I have Norton Antivirus on the machine, and get this, it updates and downloads the newest deffinition files just fine.  I have ran a scan and all seems fine.
I will try another piece of spyware.
0
 
LVL 44

Accepted Solution

by:
CrazyOne earned 500 total points
ID: 9704161
Also try this

Sart > Run msconfig
Click on the tab marked "Startup"
Click on the Disable All button.

If the problem no longer persists then one of the items in the starup is the culprit you just need to track it down.
0
 
LVL 16

Expert Comment

by:joinaunion
ID: 9704671
right click my network places icon then click properties then right click your connection click propertis make sure client for microsoft network is installed then click ok at the bottom then try again
0
 

Author Comment

by:stubbsmc2
ID: 9704738
OK, I think I will have to give CrazyOne the points.  It did have to do with MS config.  But it was because the network was not loading.  Selective startup was enabled.  the user was not sure if they had done this.  But I set it to a normal startup and all seems fine.  Of course I got the chance to clean all the other junk off thier laptop.
Thanks everyone for the assist.
Mattman
Stubbsmc
0
 

Author Comment

by:stubbsmc2
ID: 9704744
PS this one was urgent because the user was a doctor!  He is pretty patient but I really wanted to get it done today for him. thanks again.
MCS
0
 

Expert Comment

by:Lawrence905
ID: 25639527
I had a similar issue running a 64bit vista system, did all the above mentioned, I found that there is a security update sometime after sp2 that was causing the issue, I uninstalled all the security updates on the last date a update was successful and ureka. I could browse again.
0

Featured Post

IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

This article is meant to give a basic understanding of how to use R Sweave as a way to merge LaTeX and R code seamlessly into one presentable document.
Today, still in the boom of Apple, PC's and products, nearly 50% of the computer users use Windows as graphical operating systems. If you are among those users who love windows, but are grappling to keep the system's hard drive optimized, then you s…
The goal of the video will be to teach the user the concept of local variables and scope. An example of a locally defined variable will be given as well as an explanation of what scope is in C++. The local variable and concept of scope will be relat…
The viewer will learn how to pass data into a function in C++. This is one step further in using functions. Instead of only printing text onto the console, the function will be able to perform calculations with argumentents given by the user.

758 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

24 Experts available now in Live!

Get 1:1 Help Now