Formatting harddrive.. impossible?

My computer is an old AST Bravo MS-5166. Today I did something stupid. I went crazy with Fdisk and ruined my memory, and now Red Hat 6.2 won't boot up properly. Basically it tries to boot up and then halts on the line "Kernel panic: VFS: Unable to mount root fs on 03:05". What I was trying to do was format my computer so I could reinstall Linux and start over fresh. Now I can't format at all, as I have no prompt to work with. The computer executes all of this and doesn't do anything with the boot disk when I turn the computer on with it in. My BIOS don't have any options to allow formatting. What can I possibly do to be able to use my computer again?
Tabris42Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

anupnellipCommented:
hii ,
  Do u have the RedHat installation CD . U should have as u where going to format your hard disk . So use this cd and boot your box from the CDROM . the Linux installation screen will come up and u can u can delete your old partition and install a fresh operating system . I hope u dont have any data on the disk ?? I am give u this advice because u presume that this is what u wanted to do . It would be a good Idea if u can install the latest Linux ver in order to avoid driver problems .

Regards

Anup
Tabris42Author Commented:
Booting from the CD is not an option available to me.
svenkarlsenCommented:
Hi Tabris42,

In your BIOS setup, look for some setting that control the boot-up sequence, - probably it has been set to something like: "C:;A:". Change that to "A:;C:).


Kind regards,
Sven

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Tabris42Author Commented:
Close, my BIOS options have a selection for "Boot Device: Try Floppy First" (as opposed to "Try Hard Drive First"), and still it is doing nothing. Is it even possible to create a Linux boot disk in Windows?
svenkarlsenCommented:
Yes, - if you have a windows machine, insert the CD-ROM and open a DOS-box:

C:\> d:
D:\> cd \dosutils
D:\dosutils> rawrite
Enter disk image source file name: ..\images\boot.img
Enter target diskette drive: a:
Please insert a formatted diskette into drive A: and
press --ENTER-- : [Enter]
D:\dosutils>

(Assuming your CD-drive is d:)

Look at:
http://www.redhat.com/docs/manuals/linux/RHL-7.1-Manual/install-guide/s1-steps-install-cdrom.html#S2-STEPS-MAKE-DISKS


for further info
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Distributions

From novice to tech pro — start learning today.