modem dirver and smp kernel

hello experts
I have rh9.0. I have been trying to install my modem driver but each time it says that it doesn't support smp kernel. I have a 2.4.20.xx smp kernel. I tried reconfiguring the kernel but it didn't work. What can I do so that I am able to install the modem driver.
please help.
LVL 1
darpangoelAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jlevieCommented:
I assume that the modem driver you have is for one of the winmodems. If that's the case you'd have to be able to get a driver built for an SMP kernel in order to get it to work on a multi-processor system. From what I've seen of winmodem drivers the vendors don't release the source so you can't built it yourself and are at the mercy of the vendor w/respect to an SMP driver. Personally, I'd just get a good "real modem" and hook it up to a serial port and skip all the winmodem silliness.
0
darpangoelAuthor Commented:
For that i'll have to download the dirver. is it possible for me to change the kernel config or just recompile the kernel so that i am no more using the smp kernel and install the driver. will it work?
0
jlevieCommented:
On a normal RedHat system both the uni-processor and SMP kernel are installed if the installer detects multi-processor hardware and Grub will be configured to default to the SMP kernel. To run the non-SMP kernel you simply need to select the other kernel on the Grub boot screen.
0
darpangoelAuthor Commented:
yeah thats the problem. actuall i don't have a smp machine but what happened was that when i first loaded linux grub didn't load properly so i installed a new kernel using the cd so that i could reinstall the boot loader (grub). so grub now doesn't give me the non smp option.
i want to rectify this problem whiout using the cd.
thanx
0
jlevieCommented:
That's easily enough fixed. First you want to check /boot and /lib/modules to make sure that you have the files associated with an uni-processor kernel on the system. They should be there if your "fix" only installed the SMP kernel. Then you need to edit /boot/grub/grub.conf and add a stanza for the unit-processor kernel. Right now your grub.conf might contain a boot stanza something like:

title Red Hat Linux (2.4.20-20.7-SMP)
        root (hd0,0)
        kernel /vmlinuz-2.4.20-20.7-SMP ro root=/dev/sda2
        initrd /initrd-2.4.20-20.7-SMP.img

Adding a boot stanza like:

title Red Hat Linux (2.4.20-20.7)
        root (hd0,0)
        kernel /vmlinuz-2.4.20-20.7 ro root=/dev/sda2
        initrd /initrd-2.4.20-20.7.img

Before the SMP stanza will make the default boot be to the uni-processor kernel.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.