Solved

Bringing up interface eth0:                                Failed

Posted on 2003-11-08
5
1,723 Views
Last Modified: 2013-12-06
first:
while starting Linux Redhat 8.0 .. i got..
Bringing up interface eth0:                                Failed

i want to know why.. and how to solve it.
second:
   X Server does not work .. after starting and before login.. monitor is flickering and then give me blue screen talking about problem in Vedio(VGA) Card even he already detect it as S3Trio64 (Generic) - i don't know what is need of this "Generic"..
i tried command redhat-config-xfree86 but gives me "can't star x server , try again with fresh configuration" and after continue after long time it tells me "No screen..."
and how to re-configure the VGA card if i need to do that manually.
0
Comment
Question by:wemy
5 Comments
 
LVL 5

Expert Comment

by:brabard
ID: 9709472
About the first question - this mean you have config file that sais to bring up eth0 on boot , but something is wrong with your card - what exactly happens we can discuss after getting more information about you hardware configuration and modules .
For about tha second question - it is possible your xfree config file to have wrong settings about the card and monitor , including the basic ones - vertical and horisontal refreshig .
The core command you can try is #xf86config and to build a new file by few easy steps .
0
 
LVL 1

Expert Comment

by:PurpleTiger
ID: 9714671
We will need a bit more information to help you with your first question.

1) What make/model/chipset is your network card
2) If you issue the command "lsmod" as root[without quotes], what is the output?
3) If you log in from the console, and as root issue the command "ifconfig" [without quotes] What is the output?
4) Has this card previously worked under a different version of linux? If so, what version?

If you can answer these questions then it should help us to diagnose your problems further.
0
 
LVL 1

Expert Comment

by:ajenkins
ID: 9717388
Switch to text mode.  It's Ctrl-Alt-F7 or Ctrl-Alt-F4 I always forget which.  You can look through /var/log/messages that might give some clues, or try something like /sbin/ifconfig eth0
If you haven't set up networking, eth0 isn't "brought up" by default.  And something like ifconfig eth0 192.168.0.7 netmask 255.255.255.0 would do it.  

I think the X configuration is your main problem from the sounds of it.  You can try some different resolutions by holding Control and Alt and then pressing the + or - keys on the numeric keypad.  If you can find one that works, you can get in and fix X that way.  Otherwise, maybe rename your X configuration file (to XF86Config-4.stuffed for example), and run XF86Config to set it all up again.  
That's where you can re-configure your video card (as well as monitor, etc).  Be careful when specifying the vertical refresh rate of your monitor too, else you might damage it!
0
 

Accepted Solution

by:
dandanio earned 50 total points
ID: 9722565
Hey!
First, as root, do: ifconfig -a - if there is a eth0 then it's fine.
Then try: ping 127.0.0.1 - see if it responds.
then: if there is eth0 present do: ifconfig eth0 up
and: ifconfig eth0 192.168.0.1
then: ping 192.168.0.1
If eth0 is not present do: cat /proc/pci and look for your network card. If it's there - it means it's physically installed. Then do lsmod - it should list the modules you have in your kernel. If you know which module works with your card do: modprobe MODULENAME. Then it should appear.
If you still have problems please repost with all the answers you get from Red Hat posted.
For your video problem I would look again: cat /proc/pci and look for your video card and then edit XF86Config. Also: dmesg |more may help you - it contains the log file of system boot up. Thanks!
0
 
LVL 1

Author Comment

by:wemy
ID: 9895803
to Dandanio,
     thanks alot for your help, i will accept your answer soon, because your comment was too simple and useful for me, but i need just to complete the configuration of the network configuration to browse through the LAN, the surprise that i can connect to the Internet through the LAN but i still can not browse through any other machines (Win2k machines) in the network.
my machine is the only Linux Red hat machine on the network.
please advice..
thanks
0

Featured Post

Complete VMware vSphere® ESX(i) & Hyper-V Backup

Capture your entire system, including the host, with patented disk imaging integrated with VMware VADP / Microsoft VSS and RCT. RTOs is as low as 15 seconds with Acronis Active Restore™. You can enjoy unlimited P2V/V2V migrations from any source (even from a different hypervisor)

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Guacamole cut and paste issue 3 48
Oracle 12c patching 1 61
Access_log 17 100
Choosing CentOS 16 58
If you have a server on collocation with the super-fast CPU, that doesn't mean that you get it running at full power. Here is a preamble. When doing inventory of Linux servers, that I'm administering, I've found that some of them are running on l…
The purpose of this article is to fix the unknown display problem in Linux Mint operating system. After installing the OS if you see Display monitor is not recognized then we can install "MESA" utilities to fix this problem or we can install additio…
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:

896 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

14 Experts available now in Live!

Get 1:1 Help Now