Apache2/mod_ssl: I can't connect to an SSL enabled VHost

I use SuSE 9 and Apache 2.0.47 with pre-fork. I used the default SSL Vhost template "/etc/apache2/vhost.d/ssl_vhost.template" I created a self signed cert using the following:
1. openssl -genrsa -des3 -out server.key
2. openssl -req -key ../ssl.key/server.key -days 365 -out server.crt
3. entered the passphrase
4. Entered my cert details.

When I tryied to start apache2 (rcapache2 restart) it asked me for the passphrase and timed out to soon so I starteed it "manualy" (#: httpd2) and entered the passphrase and the server started. However any attempt to connect to the vhost loads the homepage (main server) and SSL connections are refused.
All help appreciated.
LVL 1
BLaCkDraGoNAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

pjedmondCommented:
I presume that somewhere in your httpd.conf you have the following lines or similar

Listen *:80
Listen *:443

If you are not listening on port 443, then you'll get the connection refused.

As a test, you can telnet to port 443, and it should connect if ssl is enabled - if not then you'll get a comment to the effect that you could not connect/connection failed.

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
pjedmondCommented:
Another idea...just to get the system up and running, is try creating a key without a pass phrase (FOR TEST PURPOSES ONLY), and see if that works for you.

Always start at the simplest level, and then add complexity:)
0
BLaCkDraGoNAuthor Commented:
Their is the line:
Listen 80
Listen 443
NameVirtualHost *

in /etc/apache2/listen.conf (SuSE9 has "modularised" the configuration)
Normaly when I connect to a vhost I get a "403 Error" because I have disallowed indexes so I am going to assume that either the server is having a problem with the ssl configuration or my certificates are invalid does the server normaly request passphrases at startup I read somewhere about "SSLPassphrase Internal" set the system up not to "nag" for a passphrase without using unencrypted certs. (This is still part of the origional question).
0
BLaCkDraGoNAuthor Commented:
I have decided to stop this Question as I discovered that I already have another similar one Open. I will only award 100pts IN THIS QUESTION but 300 in the next one to the best answer.
~BD~
0
BLaCkDraGoNAuthor Commented:
OOPs forgot I cant decrease points! Oh well that makes a potential 550 points up-for-grabs!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Apache Web Server

From novice to tech pro — start learning today.