Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 209
  • Last Modified:

Why does'nt it goes with the sound.

Hello,
I want to know why does the sound in my flash movie does not match with the movements in flash when i see it online, after publishing online. While editing the flash movie and previewing it, it was working perfect and everything was going with the sound. But when i published it online, the sound speed is fine i guess but the graphics and everything come late, that is it does not match with the sound. This is after publishing online.

Any idea why? :S

Thanks,
Phud3
0
Phud3
Asked:
Phud3
  • 3
  • 2
1 Solution
 
negatyveCommented:
Yes, you should set the sound as a stream, so you can syncrhonize it with graphic. Select the frame with the sound, choose "Stream" from Properties panel (flash mx) or Sound panel (flash 5), then click F5 on the sound layer to make it as long as the main timeline.
0
 
Phud3Author Commented:
Ah, thanks negatyve, this worked :)
I don't know what's the concept, but it worked. Can you tell me how did this work for my knowledge :P :)
0
 
negatyveCommented:
It works because with streaming sound the player forces sound-graphic synchronization, following the sound and eventually skipping graphic frames..
0
 
Phud3Author Commented:
Aha,
dude, I got a problem again. Before the process you asked me to do and my sound will match my movie, it worked. And that I had applied on the sound timeline. I mean I had added sound on a timeline and there your given process worked. One of the other person asked me to remove the sound from the timeline and add a playsound function action because my sound used to loop 2 times when i had added the sound in the timeline. So, keeping the other guy's way, I have now removed my sound from the timeline, made linkage of the soundfile in the library, then added an playsound action on the frame from where I need the sound to start. Now when i did this and published the movie, it gave me the same problem. The sound is not matching the graphics, movements. The sound goes fast and the movie is slow :S. Now how do i fix this? :P
Sorry for bugging you.

Thankyou,
Phud3
0
 
negatyveCommented:
(why B grade?)

You have to leave only one sound on the timeline, and no sound action, as the *ONLY* way to sync sound and graphics is as I told you, sound in a frame with the sync option set as "stream": http://www.macromedia.com/support/flash/ts/documents/audio_synch_options.htm
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now