Replacing SAM file causes a big problem

by mistake  ! I replace SAM file with SAM empty file (size is zero KB) then the result is :

1. I cannot logon GUI and recieve a message says that the lsass.exe has problem

2. I tried to use Advanced stratop Options and didn't help me but face the same result in case 1 .

3. I cannot use Recovery Console but instead It request password and when I type the password it says that incorrect ,  (the SAM is empty)

4. I have to keep my data and program settings in other words I need to my pervious settings

5.I made ASR floppy before the mistake occured but I lost it can I creat it from another machine ?

6.I have backed up all my machine  with 12 GB Important data

please help me
LVL 8
nader alkahtaniConsultantAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

KenneniahCommented:
If your hard drive is partitioned with FAT you can boot to a DOS disk to try and copy back a good copy of the SAM file. If NTFS, you'd either need a program like NTFS Dos to to this, or do a repair install of Windows XP.

How to Perform an In-Place Upgrade (Reinstallation) of Windows XP
http://support.microsoft.com/default.aspx?scid=kb;en-us;315341&Product=winxp
0
KenneniahCommented:
"Security Accounts Manager Initialization Failed" Error Message When You Start Windows XP
http://support.microsoft.com/default.aspx?scid=kb;en-us;316751&Product=winxp

0
nader alkahtaniConsultantAuthor Commented:
thanks for your comment , but it partitioned with NTFS
0
Protecting & Securing Your Critical Data

Considering 93 percent of companies file for bankruptcy within 12 months of a disaster that blocked access to their data for 10 days or more, planning for the worst is just smart business. Learn how Acronis Backup integrates security at every stage

KenneniahCommented:
Unfortunately then, without the ASR (and no you can't use one from another machine since each computer has specific security identifiers), and without a program like NTFSDos Professional, or ERD Commander from http://www.winternals.com/, you'll most likely have to do the repair install of Windows XP.
0
MihailoCommented:
You have a copy of SAM in WINDOWS\REPAIR
0
KenneniahCommented:
Yes there is a copy of SAM in Windows\Repair, however without the ability to boot to the Recovery Console, or a DOS boot disk with NTFS support, there's no way to copy it over.
One other possibility though would be if you could put the hard drive into a working Windows XP system and copy the file from C:\Windows\Repair to C:\Windows\System32\Config that way.
0
MihailoCommented:
> I cannot use Recovery Console but instead It request password and when I type the password it says that incorrect

Try with Windows 2000 Rec. cons., it won't ask you for password on XP installation (I'm not shure this will work, maybe RC checks for SAM but not ask for password - because of a bug)
0
GuyPaddockCommented:
You may try a blank password; the RC will always ask for a password if its the XP version, even if the Administrator account has no password set. Try pressing enter at the password prompt and see if that doesn't just let you in.

One work of caution when using NTFSDos: If you copy the SAM file over using NTFSDos, the SAM will NOT work properly. NTFSDos doesn't set security permissions on the NTFS volume. XP will NOT boot at all with a SAM file if it does not have the proper security credentials, even if the file is formatted properly. The RC WILL properly set them if you use it to do the copying. Just a behavior I've noticed. The ERD commander, because it is actually Windows (I think that's the product that boots off of a CD and actually runs Windows 2000, no?), will properly copy over the SAM.
0
CrazyOneCommented:
Hi NADIR

Try a parallel installation to get the SAM from repair folder mentioned above

although this is about Win2000 the idea is the same.

HOW TO: Perform a Parallel Installation of Windows 2000
http://support.microsoft.com/search/preview.aspx?scid=kb;en-us;266465

Then you can remove the parallel installation by deleting it when you have the original one up and running
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
nader alkahtaniConsultantAuthor Commented:
I missed Product Key for XP pro ....how can I try a parallel installation ?
0
CrazyOneCommented:
Did you register XP with Microsoft? If so contact them they might be able to help.
0
nader alkahtaniConsultantAuthor Commented:
I didn't register it .

Thank you all

recently I have found product key

0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows XP

From novice to tech pro — start learning today.