Solved

Compaq Evo n600c laptop, Mandrake 9.1: Processor constantly at 100%. Should I switch?

Posted on 2003-11-10
9
625 Views
Last Modified: 2013-12-15
As stated above, I have a Compaq Evo n600c with a PIII, 512 MB RAM, and have been trying to get Mandrake 9.1 to run.  I am a Linux newbie, and know very little about troubleshooting this OS, but do hope to learn more once this issue has been resolved.

I use KDE, and when I open the processor monitor, it shows to be operating at 100% constantly.  I assume this is the reason simple tasks take a long time to complete, such as opening Konsole takes approx. 2 minutes, Control Center about 3-4 minutes.  As you can imagine, this is frustrating to the point of not wanting to use Mandrake Linux until this problem is resolved (which is why I currently dual-boot XP Pro).

Is there a way to fix this, or would switching to Suse, Gentoo, or RedHat fix this problem?

Thanks all,

Ben
ben at eastex dot net
0
Comment
Question by:bmctee
  • 5
  • 4
9 Comments
 
LVL 12

Accepted Solution

by:
paullamhkg earned 130 total points
ID: 9729097
http://www.linux-on-laptops.com/compaq.html have a check to see this can help or not.
0
 

Author Comment

by:bmctee
ID: 9737516
I tried this web site, and it had a page with good pointers on my type of laptop, if I were an experienced Linux user.  However, I'm just getting started, so I don't know how to do some of the things it's asking.  

For example, if I try to make changes to lilo.config, I do so under root (since I'm not allowed on my account), save the file, then reboot.  There was a tag to have ACPI turned off under the main linux boot, I reversed it, saved, rebooted, and nothing changed.  Does this mean that I have to recompile the kernel after making any changes like this??  I run into this type of problem every time I try and do something with Linux.
0
 
LVL 12

Expert Comment

by:paullamhkg
ID: 9737668
Can you more specify what you need to do.
0
VMware Disaster Recovery and Data Protection

In this expert guide, you’ll learn about the components of a Modern Data Center. You will use cases for the value-added capabilities of Veeam®, including combining backup and replication for VMware disaster recovery and using replication for data center migration.

 

Author Comment

by:bmctee
ID: 9742372
Well I'm trying to get Linux (of any distro) up and running on my laptop.  I first tried Mandrake because this and SuSE were the two recommendations I had for beginners (from TechTV's web site).  The installation of Mandrake 9.1 went with no problems at all.  When I boot up, and everything has completed loading, I can open the system monitor tool, and it shows that my processor is running at 96-100% all the time.  After a short while, my fan will turn on because of the heat, and stay on until I shut down.  Because of this (processor at 100%), everything I try to do takes extremely long to complete.

My question is this: if I were to switch to a different distro (like SuSE), would this maybe fix the problem, or does the problem lie in the kernel (which I would think is the same between distros)?

If it is in the kernel, I need to know how to correct the problem and recompile successfully.  If switching to SuSE would fix it, then I'll probably buy it so I will have support on installation (which would address further questions that I have).

In sum, I am a Linux newbie that does not know why my processor does this, and that it is hard to get anything done (actually learn and use Linux) when the system is bogged down like it is.
0
 
LVL 12

Expert Comment

by:paullamhkg
ID: 9744791
Do you mean after you install with the GUI up and running the process go for 100%?

have you try to turn of unuse service, like printing service (cup), web service (apache) bla bla bla, and turn them on when need, to see the process come better.
0
 

Author Comment

by:bmctee
ID: 9745402
Yes, I have Mandrake 9.1 installed and after the GUI is up and going (I wait until everything has finished loading completely), I check the system monitor (that shows hdd, ethernet, and cpu stats), and it shows the CPU to be running anywhere from 96-100% the whole time.

I have tried turning off services, but only the ones I did not need.  I'll go in and turn off everything, then turn them back on one at a time to see if it helps.

I think one problem that I might have (this is just a guess), is on my lilo.conf, ACPI is turned off on the linux boot options.  I changed it to on, then did /sbin/lilo to implement it.  It said it added all the ones that were already there, and the * was beside windows because I wanted it to be default.  However, when booting, it appeared as nothing had changed and the default boot option was still linux, so I would assume that ACPI wasn't changed either.  Could ACPI have an affect on my processor problem?  If so, then any suggestions on getting LILO configured?
0
 

Author Comment

by:bmctee
ID: 9761572
I'm still looking to find a possible solution should anyone have one in their mind.

If you do not know the answer to this, but you can tell me some things about LILO, that would be helpful too.  Since I can't get Mandrake to work right, I made a live CD of SuSE (I can run Linux from the CD) to see if everything with it is compatible with my laptop.  However, I'm not able to boot from CD anymore because LILO takes over as my only boot option now.  I have used Knoppix before, so I know booting from CD works.  Can you tell me how to make a CD run before LILO, or command LILO to force the CD to boot?

Thanks everyone who has helped so far.  I've increased the points with all the remaining points I have.
0
 
LVL 12

Expert Comment

by:paullamhkg
ID: 9768325
I think it's not the lilo to control, have you try to set your notebook to boot from CD ROM then Harddisk, the 1st boot sequence is from your BIOS after you boot up your notebook/PC.
0
 

Author Comment

by:bmctee
ID: 9772370
In BIOS setup, I do not have a choice to boot from CD, I have an option to boot from my multibay (can be CD or floppy), hard drive, network, or docking station nic, as well as what order they can be in.  I chose to have the multibay first, hdd second, and so on.  This made my floppy drive light come on during boot, but did not boot from the CD, and I do not have a floppy drive.  

When I get home, I'll try booting the CD on another machine just to make certain that it is a bootable disc, and then I'll post back.

Thanks.
0

Featured Post

Master Your Team's Linux and Cloud Stack

Come see why top tech companies like Mailchimp and Media Temple use Linux Academy to build their employee training programs.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Anything Suspicious in this Report Email on Linux Server 4 47
centos linux 65 129
AWS Central Authentication 1 65
How to mount nfs share on this CentOS server? 6 29
Daily system administration tasks often require administrators to connect remote systems. But allowing these remote systems to accept passwords makes these systems vulnerable to the risk of brute-force password guessing attacks. Furthermore there ar…
Network Interface Card (NIC) bonding, also known as link aggregation, NIC teaming and trunking, is an important concept to understand and implement in any environment where high availability is of concern. Using this feature, a server administrator …
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…

810 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question