Share calendar

I have exchange 2000 with outlook xp and outlook 2000 clients.  Some of my users need to see other people's calendars without seeing and opening the entire mailbox.  Also, can this be set up as a folder and not just an outlook shortcut?

Thanks
MortgageGuyAsked:
Who is Participating?
 
Makr_Watson27Commented:
Sorry MortgageGuy didnt quite understand your question.
If you are asking what default permissions should be applied via Active Directory to this mailbox then its a tricky one to answer.  If you're not sure what your organizations standard rights should be then you should compare a few other mailboxes.
On an example server I looked at the following were set:

Administrator, Domain Admins, Enterprise Admins
 - Delete mailbox storage:Allow inherited
 - Read permissions:Allow inherited
 - Change permissions: Allow inherited
 - Take ownership: Allow inherited
 - Full mailbox access: Deny inherited
 - Associate external account: Not defined

SERVER$, Exchange Domain Servers
 - Delete mailbox storage:Allow inherited
 - Read permissions:Allow inherited
 - Change permissions: Allow inherited
 - Take ownership: Allow inherited
 - Full mailbox access: Allow inherited
 - Associate external account: Not defined

Everyone
 - Delete mailbox storage:Not defined
 - Read permissions:Allow inherited
 - Change permissions: Not defined
 - Take ownership: Not defined
 - Full mailbox access: Not defined
 - Associate external account: Not defined

SELF
 - Delete mailbox storage:Not defined
 - Read permissions:Allow Explicit
 - Change permissions: Not defined
 - Take ownership: Not defined
 - Full mailbox access: Allow Explicit
 - Associate external account: Not defined

0
 
Makr_Watson27Commented:
I dont believe you can acheive both.  The best result would be to give Folder Visible permissions to the Mailbox and then the appropriate rights to the calendar.  This could then be added as an addtional mailbox under the exchange service properties.  Effectively giving rights only to see the calendar.
Other than that you have the Open Other Users folder option, but this wouldnt make it appear as a folder in the folder list.
0
 
slandiseCommented:
The easiest way (I think) is to set it up in a public folder.  You can also set permissions there if not everyone should have access to a particular calendar.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
VahikCommented:
0
 
Makr_Watson27Commented:
The solution all depends on you comment about setup as a folder and not just an outlook shortcut.

Internally we have a team of ten people who share a public folder for their time,  as per slandise suggestion.  We use a custom field which we can use to filter the views on the calendar, that way you can see multiple peoples or just singular depending on your view.  But I dont believe this is what you are looking for.

XP also has additional functions for side-by-side calendar views.

All depends on your requirements
0
 
MortgageGuyAuthor Commented:
There is no one here that uses the outlook shortcuts, everyone uses the folders list.  I still can't believe that there isn't a way to visibly grant permissions to the calendar folder and deny everything else.  This is our ceo's calendar and we obviously don't want anyone else to see his e-mails only his calendar to make appointments surrounding his schedule.  Any other thoughts?
0
 
Makr_Watson27Commented:
As I mentioned earlier, you dont need permissions to anything else.

Load Outlook
Right Click Mailbox, select Properties
Add people/groups but only choose Folder Visible for the permission

Give appropriate permissions to the Calendar

Then when a user attaches to the Mailbox they will only see the Mailbox and the Calendar.

0
 
MortgageGuyAuthor Commented:
Are you saying that when someone attaches to the mailbox which is brought up as an additional mailbox they will see the mailbox and only the calendar folder?  Or are you saying that it can't be done as you mentioned earlier?  Assuming it can be done.  I can't seem to make the permissions work, so specifically tell who needs what and where including the default user and anonymous user.

Thanks
0
 
Makr_Watson27Commented:
You should be able to acheive what you want, sorry if I havent been clear.  Right here goes...

On the Sharing PC
 - Load Outlook
 - Display the Folder List by choosing View - Folder List

 - Right click the 'Outlook Today - [Mailbox - Username]' and choose properties
 - Select the Permissions tab
 - Highlight Default
 - Choose None from the list of Roles
 - Check the box labelled 'Folder Visible'
 - Click OK
 - Highlight Anonymous
 - Choose None from the list of Roles
 - Clear the box labelled 'Folder Visible'
 - Click OK

 - Right click the Calendar and choose properties
 - Select the Permissions tab
 - Highlight Default
 - Choose Reviewer from the list of Roles, (This gives everyone read rights)
 - Check the box labelled 'Folder Visible'
 - Click OK
 - Highlight Anonymous
 - Choose None from the list of Roles
 - Clear the box labelled 'Folder Visible'
 - Click OK

On another PC
 - Load Outlook
 - Choose Tools - Services
 - Highlight Microsoft Exchange Server and click Properties
 - Click the Advanced Tab
 - Click Add
 - Type in the name of the user you have shared in the steps above
 - Click OK

In the folder list you should now see the 'Mailbox - Username', clicking it will proove you have no rights.  Expand it and you should see Calendar underneath, clicking that you will see the users calendar.


Hope this is okay.

Regards

Mark
0
 
MortgageGuyAuthor Commented:
I really appreciate the very detailed steps, but for whatever reason it isn't working.  Are there other permissions involved that would override these because our users are able to see the entire mailbox?
0
 
Makr_Watson27Commented:
Can you detail the permissions listed on the 'Outlook Today - [Mailbox - Username]', the 'InBox' and the 'Calendar'

0
 
MortgageGuyAuthor Commented:
The permissions for the users are set up as the default settings, which are none for both the default and anonymous and no check marks are selected.
0
 
Makr_Watson27Commented:
Are you logged in as an account that has full mailbox priviledges to the mailbox in question?
 - Start Active Directory Users and Computers.
 - On the View menu, ensure that the Advanced Features check box is selected.
 - Double-click the user whose mailbox you want to check permissions for.
 - On the Exchange Advanced tab, click Mailbox Rights.

Which accounts have Full Mailbox Access selected?
I believe you the following will by default, but has anyone else?
 - You should have the server (SERVERNAME$)
 - Exchange Domain Servers
 - Self
0
 
MortgageGuyAuthor Commented:
I think we're making some ground here.  I have just about every single group with administrative rights belonging to this user and everyone else as my default.  I just created a temp user and by default it only adds the self with full mailbox rights and the read permissions.  I'm sure this is how it needs to be fixed, but before I risk screwing something else up in exchange what all do I need to have access for?
0
 
MortgageGuyAuthor Commented:
I've increased the points since this question has turned into something else.  I'm going to mirror my environment to be like the example you have shown previously.  Question, when I want all of my users to be able to access a certain folder on my server do I grant them access by sharing the folder and then giving them permissions or do i just give them rights by the security tab and the sharing and  permissions tabs are never used?

Thank you so much you have a been a HUGE help.
0
 
Makr_Watson27Commented:
I think I have lost you here.
You're mentioning Files and Folders, you're not sharing the mailboxes using the M drive are you?
Microsoft highly recommend that the M drive is not touched with regards to permissions.
0
 
Makr_Watson27Commented:
If you try and modify the permissions on a mailbox and get the following error:
The Modified permissions could not be saved. The client operation failed
Then the next article may be of use

XADM: You Cannot Set Permissions on Folders in a Mailbox
http://support.microsoft.com/default.aspx?scid=kb;en-us;323611&Product=exch2k

0
 
MortgageGuyAuthor Commented:
Sorry I've put this on another question.  You've nailed it right on the money for my exchange permissions, but I increased my points to see if you could help me out on my main server regarding security.
0
 
Makr_Watson27Commented:
Phew, thought I was going mad!

As far as file and folder permissions are concerned the Secutiry tab is the one to ensure is correct.

Sharing should be used to effectively create a network shortcut, i.e. instead of going to \\server\drive\folder\subfolder\folderneeded etc.  you can go straight to \\server\folderneeded

I've never changed the permissions on the share and just used the Security tab to get the permissions I need.

Does this help?
0
 
MortgageGuyAuthor Commented:
Thank you again.  You've answered all of my questions.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.