Oracle service hangs on "Starting". Help!

hey all,
i have Oracle Enterprise 8.1.6 installed on a WinXP machine and i created a local DB service with the Database Configuration Assistant, but the service won't start. when i go to Start>ControlPanel>.....>Services it just says "Starting" and nothing happens. No error message, no nothing, just says "Starting" and that's it. any ideas?

thanks much!
Lou1Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

kalosiCommented:
Did you check the database alert log ?
0
baonguyen1Commented:
As far as I know, Oracle certifies Oracle Databases on Windows XP  
version 9.0.1 or higher. It means you will have problems with 8.1.6 on Windows XP.

0
Lou1Author Commented:
one thing i tried was the following: in the file sqlnet.ora, i changed the following line: SQLNET.AUTHENTICATION_SERVICES= (NONE), it used to be NTS in the parenthesis. when i first powered my machine this morning and attempted to start the Oracle service manually it worked, but then i was messing around with the Oracle Net8 Assistant so i had to restart the service and now it won't start. it gives me the following error message:

"Could not start the OracleService[service name here] on Local Computer

Error 1053: The service did not respond to the start or control request in a timely fashion."

and then the it just says "Starting" and it won't do anything. it seems to be a WinXP/Oracle 8.1.6 incompitability issue, but it's got to be a way around it.

any ideas?

thanks much!
0
Cloud Class® Course: Microsoft Exchange Server

The MCTS: Microsoft Exchange Server 2010 certification validates your skills in supporting the maintenance and administration of the Exchange servers in an enterprise environment. Learn everything you need to know with this course.

kalosiCommented:
As I wrote earlier did you check the alert log of the database ??? this could help us much.
0
Lou1Author Commented:
oh ok, here it is what i found in a file called alert_db.log:

 "Mon Nov 10 15:45:39 2003
ODG-05019: Error: failed to bind socket"
0
tommbCommented:
I had the excact same problem on my client with WinXP/Oracle 8.1.6 and this procedure solved my problem.
Disable the Oracleservice in services
Reboot
Open a DOS-prompt and delete the Oracleservice:
ORADIM -DELETE -SID <SID>
Create a new service:
ORADIM -NEW -SID <SID> -MAXUSERS 50 -STARTMODE MANUAL -PFILE init<SID>.ora
Reboot
The new Oracleservice then starts even if startmode is set to manual (don't know why)
Open a DOS-prompt and start oracle
SVRMGRL
connect internal
password oracle
startup
0
Lou1Author Commented:
actually i was able to start it up by just going to command prompt and typing:
 
 oradim -startup -sid <SID> -usrpwd manager

thanks though.
0
bnacCommented:
I can't speak for 8.1.6, but I have installed 8.1.7.4.5 on a couple dozen XP machines successfully, and never seen what you are reporting.  I usually comment out the sqlnet.authentication_services.

Have you tried creating a second instance to see if it is afflicted the same way?
How about setting the service to manual and starting it from the command-line with
"net start oracleservice<SID>".  I know it shouldn't matter, but it may be worth a try.
0
RindbaekSenior ConsultantCommented:
Oracle doesn't support version 8 .x on Windows XP (doesn't mean that it wont work though).
If you use proffesionaly you should use 9.x.



0
bnacCommented:
Hey Lou, did you ever get your issue resolved?  If so, can you give us the result and close out the call.  If you have given up, you can request a refund.
0
libel_voxCommented:
I had a very similar problem to this today (Win XP Pro with service pack 1, Oracle 8.1.5). tombb's solution (deleting the service and then creating it again from a Dos prompt) worked like a charm. And its true - even though the service is displayed in the Windows service display as 'manual' it automatically starts on a reboot.

Don't know why such bizarreness happens with Oracle 8i and Win XP, but, at least in this case, there seems to be a solution.
0
PashaModCommented:
PAQed, with points refunded (70)

PashaMod
Community Support Moderator
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Java App Servers

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.