Computers near me Really slow on 1 of two Win2k machines. Why?

I have a Dell Inspiron Laptop 866Mhz with 384MB Ram running Win2k SP3 home network LAN'ed because of fixed IP ADSL ISP Router that acts as firewall DHCP DNS etc on 192.168.254.254 so I have set this machine up with an IP of 192.168.254.7.

My other machine (Custom) 3.06GHz P4 Hyperthreading with 2GB RAM also running Win2k sp3 set to 192.168.254.6 takes about 3-5 minutes to find my Workgroup ("INTERNAL")  despite that I have regedited & deleted the Remote computer / Scheduled Tasks key.

Since my laptop finds everything in under a couple of seconds is there a service running on one that shouldn't be?

Any help would be appreciated
minrichAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Casca1Commented:
Have you checked the netbios settings? I would assume you have compared the Network properties against
the other machine?
There are several things that could cause this. I would start by making the desktop TCP/IP properties match those on the laptop.
minrichAuthor Commented:
Casca1
I have checked that all my netbios settings are exactly the same.  I have also checked that the desktop is running the same services as the laptop.  The only thing that is different is in the Event Viewers,  I have taken .jpg's of the offending events.  \\INSPIRON is my laptop and \\ASUSA is my desktop.
However I can't paste them in here.

the gist of the Warning on iNSPIRON is "The browser was unable to retrieve a list of servers from the browser master \\ASUSA on the network \Device\NetBT_Tcpip_{4D5A4309-BC03-4E7A-B740-9B20D0D515A}.  The data is in the error code
Data . Bytes
0000:  40  00  00  00                                @ . . .

a very similar message appears onn the other machine each time I click on computers-near-me.

i do however get a different message from my laptop after that message:

the browser service has failed to retrieve the backup list too many times on transport \Device\NetBT_Tcpip_{4D.......515A}  The backup browser is stopping
Data . Bytes
0000:  40  00  00  00                                @ . . .

Any ideas?

Thanks
Casca1Commented:
Browse lists are WINS. Add entries into your LMHOST files. It should fix your problem.
Or try removing the TCP/IP on the desktop, and then rebuilding the stack. That may or may not fix it, as this is a netbios issue.
10 Tips to Protect Your Business from Ransomware

Did you know that ransomware is the most widespread, destructive malware in the world today? It accounts for 39% of all security breaches, with ransomware gangsters projected to make $11.5B in profits from online extortion by 2019.

minrichAuthor Commented:
Thanks Casca1

you have lost me on the subject of netBios and LMHOSTS, I did read through a few of the threads that you have answered in the past and i even tried 'browstat.exe' which i found on my machine.  however when it (browstat dumpnet) told me that i had  three Nbf and one NetBT_Tcpip transports i decided to give up.  I have been trying to clean up my machines prior to trying to run RedHat 9.0 on VMware 4.0.3 since i have been unsucessful in setting up my Samba server and sharing file systems across platforms.

Apolgies for the lack of capitals but my left-hand Shift key need 7lbs of pressure and i sometime think faster than i type.

anyway thanks for you help.  Is casca from Spanish/hispanic roots?

Post a response and I will give you the points and an "A" for effort - even though you lost me.

Richard
Casca1Commented:
Well, I will answer in reverse, and attempt to give an example of what should fix.
First, Casca is Latin, from Cascus; there is a whole story behind that name.
Caps aren't an issue, I just tend to use them... 8-)
Don't feel bad about the Linux/Samba thing. I had trouble with it, as well... 8-)
The following is an example from the LMHOSTS file

102.54.94.97     rhino         #PRE #DOM:networking  #net group's DC

so for your given example, you would need to add these entries:

192.168.254.6   ASUSA         #PRE
192.168.254.7   INSPIRION    #PRE

Note that the spaces in the text file are actually tab spaced.
The LMHOSTS file should be in your %systemroot%\system32\drivers\etc, and have no extension on the name, so you would need to edit the file, then choose to save, and that should fix your problem.

On the other hand, just simply remove the TCP/IP by taking the checkmark off, exit out of all the screens (To remove the bindings) and then go back in, re-add the TCP/IP, add your information, and that should actually resolve the issue, but occasionally it won't.
Good Luck!
Casca1Commented:
Oh, and thanks for the score and points, but wait. Lets try to resolve your issue before you award anything. You might change your mind... 8-)
minrichAuthor Commented:
Casca1
At your suggestion i have run browstat status on both machines and the output is interesting.  unfortunately, as I don't know how to add the output from a DOS Prompt (command line) to txt to include i used snag-it to get .jpg's which I will email directly to you.  Hope that is okay - i realize that it isn't exactly kosher - per the EE rules but there you go.

Basically for anyone following this thread my slow workstation shows 6 stati "Browsing is NOT active on domain" and 'Master name cannot be determined from GetAdapterStatus' on transports \device\Nbf_NdisWanOut{.... (3 times) and \device\Nbf_NdisWanIn{... (3 times) then it starts finding mamster browsers on a number of transports (whatever they are).

On my fast laptop only 4 transports appear - two of which show INSPIRON as master browser and two of which show ASUSA as master browser but with errors "Could not connect to registry, error = 53"

perhaps with all your certifications you can translate the output into words of one syllable for me. and perhaps let me know how I can clean it up

Thanks
minrichAuthor Commented:
Casca1
You will have to email me on minrich[AT]minrich[DOT]com 'cos i don't know yours.
Thanks
minrichAuthor Commented:
have you ever googled 'casca'?  I found that on about page four casca was the first person to stab Julius Caesar - is that good or bad?
Casca1Commented:
He is also credited with being the soldier that speared Jesus in the side.
Have you tried removing the TCP/IP and re-adding?
minrichAuthor Commented:
Sure gets around then - I'll have to check on my dates (historical) to find out how old he would have to be in both places in the same lifetime!
Will try suggestion and revert
minrichAuthor Commented:
No joy - I changed the checkbox on TCP/IP in my Local Area Connection Properties for my NIC - then rebooted - I re-ran Browstat status - no change in the somewhat lenghthy result - then I re-enabled my TCP/IP service and loaded the fixed (internal) IP, DefGateway, DNS etc. for my router

Any other suggestions?  Incidentally without the TCP/IP running I got two alerts/requests from Norton Personal Firewall asking for internet access???
minrichAuthor Commented:
email you.

I have already set lMHOSTS on both machines as you suggested.

incidentally, I did notice that one of the internet accesses was looking for UNIX Printers - this mmay have come from setting up Printing on my Redhat9 guest operating system
Casca1Commented:
Hmmmm...
That's odd. Look at mapped driuves you have. Go to the cmd prompt, and type netstat. That should show you a listing of mapped drives. If you had attempted a map op to the RHServer, and not deleted it, that could also cause this kind of issue.
Lemme Know.
Casca1Commented:
We found the problem via email. Minrich attached some graphics of the output of the commands, and in ipconfig /all, I saw VMWare running.
I had him shut it down, and the browsing is properly working again.
Now, if he will simply accept this as the answer and score, we can close this. 8-)

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Casca1Commented:
Thanks for the points and score, Minrich. Glad I could help.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 2000

From novice to tech pro — start learning today.