Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

SSL fails in iframes

Posted on 2003-11-10
3
Medium Priority
?
319 Views
Last Modified: 2010-04-09
i have a site secured with SSL. EVerything works fine and i also see the lock icon on the bottom status bar. i am using ie6. now in my secure asp page i inserted a blank iframe. after i did this i get a alert box that says "this page contains both secure and non-secure items. do you want to display both?" when i click 'yes', the page displays and i am able to continue. the site still works properly, but the lock icon on the bottom disappers.

what is happening and how do i cure this. my customer will not accept a page without the lock icon on the bottom even though the site is secure and working properly.

is this a specific issue with iframes ?
0
Comment
Question by:RTKVSNL
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
3 Comments
 

Author Comment

by:RTKVSNL
ID: 9720236
i have posted the code that caused this problem to begin

<IFRAME SRC="" id="fraHeader"  Name="fraHeader" scrolling="no" marginwidth="0" marginheight="0" AllowTransparency="false" frameborder="no"  noresize style="Z-INDEX: 3; LEFT: 0px; WIDTH: 780px; POSITION: absolute; TOP: 0px; HEIGHT: 68px;border-style:none;border-color:red"></IFRAME>
0
 

Author Comment

by:RTKVSNL
ID: 9720451
i have noted one more thing. in the SRC tag above, if i enter some page address then i dont get the security alert, butin my application, i am setting the SRC later through javascript. that is why i have left the SRC blank. could this be a problem?

i also deleted the javascript code, so i was just left with a blank iframe. even this caused the security alert to pop up.

i guess i am in quite a soup !
0
 
LVL 31

Accepted Solution

by:
seanpowell earned 500 total points
ID: 9721017
Hi RTKVSNL,

The problem is caused by your iframe not have a SRC - as you've noted - when the page loads. You need to set the source to reference some dummy page or relative URL in your site, and then replace the URL with your script after load - or however you've set that up.

Thanks,
GM
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article discusses four methods for overlaying images in a container on a web page
Originally, this post was published on Monitis Blog, you can check it here . In business circles, we sometimes hear that today is the “age of the customer.” And so it is. Thanks to the enormous advances over the past few years in consumer techno…
In this tutorial viewers will learn how to style elements, such a divs, with a "drop shadow" effect using the CSS box-shadow property Start with a normal styled element, such as a div.: In the element's style, type the box shadow property: "box-shad…
Learn how to create flexible layouts using relative units in CSS.  New relative units added in CSS3 include vw(viewports width), vh(viewports height), vmin(minimum of viewports height and width), and vmax (maximum of viewports height and width).

715 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question