Installing Perl

Hi, I've got mandrake 9.2 pro suite and I would like to remove the perl rpm installed during installation and then compile perl-5.6.1.

I'm having probelms removing perl, here is the output from rpm -qa | grep perl

perl-base-5.8.1-0.RC4.3mdk
perl-MDK-Common-1.1.6-3mdk
perl-HTML-Tagset-3.03-7mdk
perl-URI-1.25-1mdk
perl-Digest-SHA1-2.04-1mdk
perl-Digest-HMAC-1.01-11mdk
perl-libwww-perl-5.69-2mdk
perl-Authen-SASL-2.04-2mdk
perl-DBI-1.38-1mdk
perl-XML-SAX-0.12-3mdk
perl-ldap-0.29-1mdk
perl-Authen-PAM-0.14-3mdk
perl-TimeDate-1.16-3mdk
perl-Mysql-1.22_19-8mdk
perl-Date-Calc-5.3-3mdk
perl-devel-5.8.1-0.RC4.3mdk
perl-5.8.1-0.RC4.3mdk
perl-URPM-0.94-6mdk
perl-Locale-gettext-1.01-9mdk
perl-CGI-3.00-1mdk
perl-HTML-Parser-3.31-1mdk
perl-XML-NamespaceSupport-1.08-3mdk
perl-Convert-ASN1-0.16-4mdk
perl-XML-Parser-2.34-1mdk
perl-Net_SSLeay-1.25-1mdk
perl-Data-ShowTable-3.3-9mdk
perl-File-Tail-0.98-4mdk
perl-Term-Readline-Gnu-1.14-4mdk

Whenever I try to remove one of these packages, here is the response (rpm -e <package_name>

perl(Exporter) is needed by (installed) perl-Digest-HMAC-1.01-11mdk
        perl(Exporter) is needed by (installed) perl-libwww-perl-5.69-2mdk
        perl(Exporter) is needed by (installed) perl-Convert-ASN1-0.16-4mdk
        perl(Exporter) is needed by (installed) perl-DBI-1.38-1mdk
        perl(Exporter) is needed by (installed) perl-XML-SAX-0.12-3mdk
        perl(Exporter) is needed by (installed) perl-ldap-0.29-1mdk
        perl(Exporter) is needed by (installed) perl-Authen-PAM-0.14-3mdk
        perl(Exporter) is needed by (installed) perl-Net_SSLeay-1.25-1mdk
        perl(Exporter) is needed by (installed) samba-server-2.2.8a-13mdk
        perl(Exporter) is needed by (installed) perl-TimeDate-1.16-3mdk
        perl(Exporter) is needed by (installed) perl-Data-ShowTable-3.3-9mdk
        perl(Exporter) is needed by (installed) perl-Mysql-1.22_19-8mdk
        perl(Exporter) is needed by (installed) perl-File-Tail-0.98-4mdk
        perl(Exporter) is needed by (installed) perl-Date-Calc-5.3-3mdk
        perl(Exporter) is needed by (installed) perl-Term-Readline-Gnu-1.14-4mdk
        perl(Exporter) is needed by (installed) perl-devel-5.8.1-0.RC4.3mdk
        perl(Exporter) is needed by (installed) MySQL-client-4.0.15-1mdk
        perl(File::Basename) is needed by (installed) perl-5.8.1-0.RC4.3mdk
        perl(File::Basename) is needed by (installed) perl-XML-SAX-0.12-3mdk
        perl(File::Basename) is needed by (installed) perl-devel-5.8.1-0.RC4.3mdk
        perl(File::Basename) is needed by (installed) rpm-build-4.2-18mdk
        perl(File::Basename) is needed by (installed) MySQL-common-4.0.15-1mdk
        perl(File::Find) is needed by (installed) perl-5.8.1-0.RC4.3mdk
        perl(File::Find) is needed by (installed) rpmtools-4.5-13mdk
        perl(File::Find) is needed by (installed) spec-helper-0.9.2-1mdk
        perl(File::Path) is needed by (installed) perl-5.8.1-0.RC4.3mdk
        perl(File::Path) is needed by (installed) rpmtools-4.5-13mdk
        perl(File::Path) is needed by (installed) perl-devel-5.8.1-0.RC4.3mdk
        perl(File::Path) is needed by (installed) MySQL-common-4.0.15-1mdk
        perl(File::Spec) is needed by (installed) perl-5.8.1-0.RC4.3mdk
        perl(File::Spec) is needed by (installed) wml-2.0.9-6mdk
        perl(File::Spec) is needed by (installed) perl-CGI-3.00-1mdk
        perl(File::Spec) is needed by (installed) perl-XML-SAX-0.12-3mdk
        perl(File::Spec) is needed by (installed) perl-devel-5.8.1-0.RC4.3mdk
        perl(File::Spec::Unix) is needed by (installed) perl-5.8.1-0.RC4.3mdk
        perl(FileHandle) is needed by (installed) perl-5.8.1-0.RC4.3mdk
        perl(FileHandle) is needed by (installed) wml-2.0.9-6mdk
        perl(FileHandle) is needed by (installed) perl-File-Tail-0.98-4mdk
        perl(FileHandle) is needed by (installed) perl-devel-5.8.1-0.RC4.3mdk
        perl(FileHandle) is needed by (installed) swatch-3.0.4-3mdk
        perl(POSIX) is needed by (installed) perl-5.8.1-0.RC4.3mdk
        perl(POSIX) is needed by (installed) urpmi-4.4-37mdk
        perl(POSIX) is needed by (installed) drakxtools-newt-9.2-16mdk
        perl(POSIX) is needed by (installed) perl-Authen-PAM-0.14-3mdk
        perl(POSIX) is needed by (installed) swatch-3.0.4-3mdk
        perl(POSIX) is needed by (installed) MySQL-client-4.0.15-1mdk
        perl(POSIX) is needed by (installed) MySQL-common-4.0.15-1mdk
        perl(SelectSaver) is needed by (installed) perl-5.8.1-0.RC4.3mdk
        perl(SelectSaver) is needed by (installed) wml-2.0.9-6mdk
        perl(SelectSaver) is needed by (installed) perl-ldap-0.29-1mdk
        perl(Socket) is needed by (installed) perl-5.8.1-0.RC4.3mdk
        perl(Socket) is needed by (installed) wml-2.0.9-6mdk
        perl(Socket) is needed by (installed) drakxtools-newt-9.2-16mdk
        perl(Socket) is needed by (installed) perl-Convert-ASN1-0.16-4mdk
        perl(Socket) is needed by (installed) perl-Net_SSLeay-1.25-1mdk
        perl(Storable) is needed by (installed) perl-5.8.1-0.RC4.3mdk
        perl(Storable) is needed by (installed) harddrake-9.2-16mdk
        perl(Symbol) is needed by (installed) perl-5.8.1-0.RC4.3mdk
        perl(Symbol) is needed by (installed) wml-2.0.9-6mdk
        perl(Symbol) is needed by (installed) perl-DBI-1.38-1mdk
        perl(Symbol) is needed by (installed) perl-XML-SAX-0.12-3mdk
        perl(Time::Local) is needed by (installed) perl-5.8.1-0.RC4.3mdk
        perl(Time::Local) is needed by (installed) perl-libwww-perl-5.69-2mdk
        perl(Time::Local) is needed by (installed) perl-TimeDate-1.16-3mdk
        perl(XSLoader) is needed by (installed) perl-5.8.1-0.RC4.3mdk
        perl(XSLoader) is needed by (installed) perl-devel-5.8.1-0.RC4.3mdk
        perl(base) is needed by (installed) perl-5.8.1-0.RC4.3mdk
        perl(bytes) is needed by (installed) perl-5.8.1-0.RC4.3mdk
        perl(constant) is needed by (installed) perl-5.8.1-0.RC4.3mdk
        perl(constant) is needed by (installed) vim-common-6.2-11mdk
        perl(constant) is needed by (installed) perl-CGI-3.00-1mdk
        perl(constant) is needed by (installed) perl-XML-NamespaceSupport-1.08-3mdk
        perl(constant) is needed by (installed) perl-DBI-1.38-1mdk
        perl(constant) is needed by (installed) perl-XML-SAX-0.12-3mdk
        perl(constant) is needed by (installed) perl-devel-5.8.1-0.RC4.3mdk
        perl(integer) is needed by (installed) perl-5.8.1-0.RC4.3mdk
        perl(integer) is needed by (installed) perl-libwww-perl-5.69-2mdk
        perl(lib) is needed by (installed) perl-5.8.1-0.RC4.3mdk
        perl(lib) is needed by (installed) bootloader-utils-1.6-3mdk
        perl(lib) is needed by (installed) mandrake_doc-common-9.2-0.9mdk
        perl(lib) is needed by (installed) drakxtools-newt-9.2-16mdk
        perl(lib) is needed by (installed) harddrake-9.2-16mdk
        perl(overload) is needed by (installed) perl-5.8.1-0.RC4.3mdk
        perl(overload) is needed by (installed) perl-CGI-3.00-1mdk
        perl(overload) is needed by (installed) perl-URI-1.25-1mdk
        perl(overload) is needed by (installed) perl-XML-Parser-2.34-1mdk
        perl(overload) is needed by (installed) perl-XML-SAX-0.12-3mdk
        perl(re) is needed by (installed) perl-5.8.1-0.RC4.3mdk
        perl(strict) is needed by (installed) perl-5.8.1-0.RC4.3mdk
        perl(strict) is needed by (installed) bootloader-utils-1.6-3mdk
        perl(strict) is needed by (installed) wml-2.0.9-6mdk
        perl(strict) is needed by (installed) vim-common-6.2-11mdk
        perl(strict) is needed by (installed) lilo-22.5.7.2-6mdk
        perl(strict) is needed by (installed) perl-URPM-0.94-6mdk
        perl(strict) is needed by (installed) rpmtools-4.5-13mdk
        perl(strict) is needed by (installed) urpmi-4.4-37mdk
        perl(strict) is needed by (installed) mandrake_doc-common-9.2-0.9mdk
        perl(strict) is needed by (installed) perl-HTML-Tagset-3.03-7mdk
        perl(strict) is needed by (installed) perl-CGI-3.00-1mdk
        perl(strict) is needed by (installed) perl-URI-1.25-1mdk
        perl(strict) is needed by (installed) perl-HTML-Parser-3.31-1mdk
        perl(strict) is needed by (installed) perl-Digest-SHA1-2.04-1mdk
        perl(strict) is needed by (installed) perl-Digest-HMAC-1.01-11mdk
        perl(strict) is needed by (installed) perl-XML-NamespaceSupport-1.08-3mdk
        perl(strict) is needed by (installed) perl-libwww-perl-5.69-2mdk
        perl(strict) is needed by (installed) perl-Authen-SASL-2.04-2mdk
        perl(strict) is needed by (installed) perl-Convert-ASN1-0.16-4mdk
        perl(strict) is needed by (installed) perl-DBI-1.38-1mdk
        perl(strict) is needed by (installed) perl-XML-Parser-2.34-1mdk

        perl(strict) is needed by (installed) perl-XML-SAX-0.12-3mdk
        perl(strict) is needed by (installed) perl-ldap-0.29-1mdk
        perl(strict) is needed by (installed) perl-Authen-PAM-0.14-3mdk
        perl(strict) is needed by (installed) perl-Net_SSLeay-1.25-1mdk
        perl(strict) is needed by (installed) samba-server-2.2.8a-13mdk
        perl(strict) is needed by (installed) postgresql-server-7.3.4-2mdk
        perl(strict) is needed by (installed) perl-TimeDate-1.16-3mdk
        perl(strict) is needed by (installed) perl-Mysql-1.22_19-8mdk
        perl(strict) is needed by (installed) perl-File-Tail-0.98-4mdk
        perl(strict) is needed by (installed) perl-Date-Calc-5.3-3mdk
        perl(strict) is needed by (installed) perl-Term-Readline-Gnu-1.14-4mdk
        perl(strict) is needed by (installed) perl-devel-5.8.1-0.RC4.3mdk
        perl(strict) is needed by (installed) rpm-build-4.2-18mdk
        perl(strict) is needed by (installed) swatch-3.0.4-3mdk
        perl(strict) is needed by (installed) dhcp-common-3.0-1.rc12.2mdk
        perl(strict) is needed by (installed) MySQL-client-4.0.15-1mdk
        perl(strict) is needed by (installed) MySQL-common-4.0.15-1mdk
        perl(strict) is needed by (installed) xinetd-2.3.11-4mdk
        perl(utf8) is needed by (installed) perl-5.8.1-0.RC4.3mdk
        perl(utf8) is needed by (installed) perl-XML-SAX-0.12-3mdk
        perl(utf8) is needed by (installed) perl-TimeDate-1.16-3mdk
        perl(vars) is needed by (installed) perl-5.8.1-0.RC4.3mdk
        perl(vars) is needed by (installed) perl-MDK-Common-1.1.6-3mdk
        perl(vars) is needed by (installed) wml-2.0.9-6mdk
        perl(vars) is needed by (installed) vim-common-6.2-11mdk
        perl(vars) is needed by (installed) rpmtools-4.5-13mdk
        perl(vars) is needed by (installed) urpmi-4.4-37mdk
        perl(vars) is needed by (installed) perl-HTML-Tagset-3.03-7mdk
        perl(vars) is needed by (installed) perl-CGI-3.00-1mdk
        perl(vars) is needed by (installed) perl-URI-1.25-1mdk
        perl(vars) is needed by (installed) perl-HTML-Parser-3.31-1mdk
        perl(vars) is needed by (installed) perl-Digest-SHA1-2.04-1mdk
        perl(vars) is needed by (installed) perl-Digest-HMAC-1.01-11mdk
        perl(vars) is needed by (installed) perl-XML-NamespaceSupport-1.08-3mdk
        perl(vars) is needed by (installed) perl-libwww-perl-5.69-2mdk
        perl(vars) is needed by (installed) perl-Authen-SASL-2.04-2mdk
        perl(vars) is needed by (installed) perl-Convert-ASN1-0.16-4mdk
        perl(vars) is needed by (installed) perl-DBI-1.38-1mdk
        perl(vars) is needed by (installed) perl-XML-Parser-2.34-1mdk
        perl(vars) is needed by (installed) perl-XML-SAX-0.12-3mdk
        perl(vars) is needed by (installed) perl-ldap-0.29-1mdk
        perl(vars) is needed by (installed) perl-Authen-PAM-0.14-3mdk
        perl(vars) is needed by (installed) perl-Net_SSLeay-1.25-1mdk
        perl(vars) is needed by (installed) samba-server-2.2.8a-13mdk
        perl(vars) is needed by (installed) perl-TimeDate-1.16-3mdk
        perl(vars) is needed by (installed) perl-Mysql-1.22_19-8mdk
        perl(vars) is needed by (installed) perl-File-Tail-0.98-4mdk
        perl(vars) is needed by (installed) perl-Date-Calc-5.3-3mdk
        perl(vars) is needed by (installed) perl-Term-Readline-Gnu-1.14-4mdk
        perl(vars) is needed by (installed) perl-devel-5.8.1-0.RC4.3mdk
        perl(vars) is needed by (installed) swatch-3.0.4-3mdk
        perl(vars) is needed by (installed) MySQL-common-4.0.15-1mdk
        perl(warnings) is needed by (installed) perl-5.8.1-0.RC4.3mdk
        perl(warnings) is needed by (installed) perl-devel-5.8.1-0.RC4.3mdk
        perl-base = 2:5.8.1-0.RC4.3mdk is needed by (installed) perl-5.8.1-0.RC4.3mdk
        perl-base is needed by (installed) perl-5.8.1-0.RC4.3mdk
        perl-base >= 2:5.8.1 is needed by (installed) perl-MDK-Common-1.1.6-3mdk
        perl-base is needed by (installed) rpm-4.2-18mdk
        perl-base is needed by (installed) initscripts-7.06-32mdk
        perl-base is needed by (installed) bootloader-utils-1.6-3mdk
        perl-base is needed by (installed) msec-0.40-1mdk
        perl-base is needed by (installed) wml-2.0.9-6mdk
        perl-base is needed by (installed) makedev-4.1-1mdk
        perl-base is needed by (installed) syslinux-1.76-10mdk
        perl-base is needed by (installed) vim-common-6.2-11mdk
        perl-base is needed by (installed) lilo-22.5.7.2-6mdk
        perl-base is needed by (installed) basesystem-9.2-1mdk
        perl-base is needed by (installed) wget-1.8.2-12mdk
        perl-base is needed by (installed) menu-2.1.5-123mdk
        perl-base >= 2:5.8.1 is needed by (installed) perl-URPM-0.94-6mdk
        perl-base is needed by (installed) gnupg-1.2.3-3mdk
        perl-base is needed by (installed) ldetect-lst-0.1.8-10mdk
        perl-base >= 2:5.8.1 is needed by (installed) perl-Locale-gettext-1.01-9mdk
        perl-base >= 2:5.8.1 is needed by (installed) rpmtools-4.5-13mdk
        perl-base is needed by (installed) rpmtools-4.5-13mdk
        perl-base is needed by (installed) bootsplash-2.0.6-1mdk
        perl-base >= 2:5.8.1 is needed by (installed) urpmi-4.4-37mdk
        perl-base is needed by (installed) urpmi-4.4-37mdk
        perl-base is needed by (installed) mandrake_desk-9.2-8mdk
        perl-base is needed by (installed) howto-utils-0.2.13-2mdk
        perl-base is needed by (installed) mandrake_doc-common-9.2-0.9mdk
        perl-base >= 1:5.8.0-20mdk is needed by (installed) drakxtools-newt-9.2-16mdk
        perl-base is needed by (installed) drakxtools-newt-9.2-16mdk
        perl-base >= 2:5.8.1 is needed by (installed) perl-HTML-Tagset-3.03-7mdk
        perl-base >= 2:5.8.1 is needed by (installed) perl-CGI-3.00-1mdk
        perl-base >= 2:5.8.1 is needed by (installed) perl-URI-1.25-1mdk
        perl-base >= 2:5.8.1 is needed by (installed) perl-HTML-Parser-3.31-1mdk
        perl-base >= 2:5.8.1 is needed by (installed) perl-Digest-SHA1-2.04-1mdk
        perl-base >= 2:5.8.1 is needed by (installed) perl-Digest-HMAC-1.01-11mdk
        perl-base >= 2:5.8.1 is needed by (installed) perl-XML-NamespaceSupport-1.08-3mdk
        perl-base >= 2:5.8.0 is needed by (installed) perl-libwww-perl-5.69-2mdk
        perl-base is needed by (installed) perl-libwww-perl-5.69-2mdk
        perl-base >= 2:5.8.1 is needed by (installed) perl-Authen-SASL-2.04-2mdk
        perl-base >= 2:5.8.1 is needed by (installed) perl-Convert-ASN1-0.16-4mdk
        perl-base >= 2:5.8.1 is needed by (installed) perl-DBI-1.38-1mdk
        perl-base is needed by (installed) perl-DBI-1.38-1mdk
        perl-base >= 2:5.8.1 is needed by (installed) perl-XML-Parser-2.34-1mdk
        perl-base >= 2:5.8.1 is needed by (installed) perl-XML-SAX-0.12-3mdk
        perl-base is needed by (installed) cups-common-1.1.19-10mdk
        perl-base >= 2:5.8.1 is needed by (installed) perl-ldap-0.29-1mdk
        perl-base >= 2:5.8.1 is needed by (installed) perl-Authen-PAM-0.14-3mdk
        perl-base >= 2:5.8.1 is needed by (installed) perl-Net_SSLeay-1.25-1mdk
        perl-base >= 2:5.8.1 is needed by (installed) samba-server-2.2.8a-13mdk
        perl-base is needed by (installed) samba-server-2.2.8a-13mdk
        perl-base is needed by (installed) harddrake-9.2-16mdk
        perl-base is needed by (installed) postgresql-server-7.3.4-2mdk
        perl-base is needed by (installed) autoconf-2.13-19mdk
        perl-base >= 2:5.8.1 is needed by (installed) perl-TimeDate-1.16-3mdk
        perl-base is needed by (installed) automake-1.4-23.p6.mdk
        perl-base >= 2:5.8.1 is needed by (installed) perl-Data-ShowTable-3.3-9mdk
        perl-base is needed by (installed) perl-Data-ShowTable-3.3-9mdk
        perl-base >= 2:5.8.1 is needed by (installed) perl-Mysql-1.22_19-8mdk
        perl-base is needed by (installed) perl-Mysql-1.22_19-8mdk
        perl-base is needed by (installed) spec-helper-0.9.2-1mdk
        perl-base >= 2:5.8.1 is needed by (installed) perl-File-Tail-0.98-4mdk
        perl-base >= 2:5.8.1 is needed by (installed) perl-Date-Calc-5.3-3mdk
        perl-base >= 2:5.8.1 is needed by (installed) perl-Term-Readline-Gnu-1.14-4mdk
        perl-base is needed by (installed) perl-Term-Readline-Gnu-1.14-4mdk
        perl-base is needed by (installed) perl-devel-5.8.1-0.RC4.3mdk
        perl-base is needed by (installed) procinfo-18-4mdk
        perl-base is needed by (installed) rpm-build-4.2-18mdk
        perl-base is needed by (installed) swatch-3.0.4-3mdk
        perl-base is needed by (installed) tmdns-0.1-12mdk
        perl-base is needed by (installed) MySQL-client-4.0.15-1mdk
        perl-base is needed by (installed) MySQL-common-4.0.15-1mdk
        perl-base is needed by (installed) xinetd-2.3.11-4mdk
        /usr/bin/perl is needed by (installed) lilo-22.5.7.2-6mdk
        /usr/bin/perl is needed by (installed) bootsplash-2.0.6-1mdk
        /usr/bin/perl is needed by (installed) autoconf-2.13-19mdk


I then just try to compile perl-5.6.1 but I'm lm also having problems with this. I run sh Configure -de which goes through fine, I then run make and I get the following error:

make: *** No rule to make target `<built-in>', needed by `miniperlmain.o'.  Stop.

What is the best way to remove the installed perl rpm and compile the new perl?

Thanks
choccarlmAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

sunnycoderCommented:
Hi choccarlm,

> What is the best way to remove the installed perl rpm and compile the new perl?
install using rpm with upgrade option


Cheers!
Sunny:o)
0
choccarlmAuthor Commented:
The rpm installed is 5.8.1 and the version I want to compile is 5.6.1.

The reason for this is because I cant seem to get perl working with apache at the moment, whenever I go to http://mysite.com/test.pl, I'm getting and Internal Server Error and I dont know why

I look at the logs and all it says is "premature end of script"
0
sunnycoderCommented:
Are you sure that the script and everything else is correct and it is perl 5.8.1 which is the culprit ? it is unlikely.

the problem with uninstalling perl s that there are loads of packages which depend on it and may stop functioning ...
you can always use the force option -f but I would not recommend that...

I cant see an easy way out...
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

choccarlmAuthor Commented:
I've installed apache 1.3.27, is there anything special I need to do to get it to run perl scripts through the browser?

Cheers
0
sunnycoderCommented:
I do not know about how to run the scripts in a browser, but perl does nott look like suspect to me atleast... try running the script on some other machine... if the problem persists, means that something else is amiss
0
choccarlmAuthor Commented:
have you got a perl script that I could run from the command line to see if perl is actually working?

If it works, I will try it through the browser too

Thanks
0
sunnycoderCommented:
try this :o)

#!/usr/bin/perl
print "hello world\n";
0
choccarlmAuthor Commented:
that worked from the command line, but not from the brower. Thanks for your help but I think this is one problem I wont be solving!
0
sunnycoderCommented:
It means that perl is working fine but you need to figure out how to run it from browser ...
try embedding it in a page ... from my little knowledge of HTML , there were some <script> tags... perhaps you need to use them here...
else you can
1. wait for some other expert here to help or post on perl programming TA
2. http://www.f2o.org/help/perl.php 

 I keep getting "Internal Server Error" when running my script!
Not to worry! This is usually caused by an error within your Perl script. There are many common errors that cause this. Here is a checklist to follow to ensure your script will run properly.

Be sure to upload your scripts with your FTP client in text mode. UNIX uses LF (linefeeds) to separate lines. If you are using DOS it is important the the CR LF to LF translation be done. If you are using the Mac it is important the the CR to LF translation be done. If you use a UNIX-style FTP client, type "ASCII" before you send it. If you are using WS_FTP, be sure to click the ASCII radio button (and don't forget to switch back to binary before you download any executables...).
Be sure to set your script to executable. You can use the UNIX "chmod" command to set the script as executable (e.g. chmod 755 script.cgi).
Check and make sure the first line in every script is:

#!/usr/bin/perl

This tells the web server where Perl is located.
Make sure that your script is sending out a Content-type header before it outputs any HTML. You should have a line in your script that looks like this:

print "Content-type: text/html\n\n";

This tells the browser that you are sending it HTML.
If you have a UNIX prompt handy, try running your scripts from the command line to see if it generates any errors.
0
sunnycoderCommented:
solution to your problem
http://www.pageresource.com/cgirec/ptut2.htm

I got something to learn :o)
0
choccarlmAuthor Commented:
ok, I did perl -d /path/to/perl/script.pl

and it returned the following (bearing in mind that this script is currently working on another box running perl-5.6.1)

============================================

Loading DB routines from perl5db.pl version 1.22
Editor support available.

Enter h or `h h' for help, or `man perldebug' for more help.

Bareword found where operator expected at script.pl line 286, near "$xheaders NE"
        (Missing operator before NE?)
String found where operator expected at script.pl line 286, near "NE ''"
        (Do you need to predeclare NE?)
syntax error at script.pl line 286, near "$xheaders NE "
syntax error at script.pl line 326, near "else"
syntax error at script.pl line 332, near "}"
Execution of script.pl aborted due to compilation errors.
Debugged program terminated.  Use q to quit or R to restart,
  use O inhibit_exit to avoid stopping after program termination,
  h q, h R or h O to get additional info.
 
 
 
  Line 286 - if ($xheaders NE '') {print sendmail "$xheaders\n";}
 
  Line 326 - else
 
  Line 332 - }

0
sunnycoderCommented:
Ok, try running this::

#!/usr/bin/perl

print "Content-type: text/html\n\n";
print "<HTML><HEAD>";
print "<TITLE>CGI Test</TITLE>";
print "</HEAD>";
print "<BODY><H2>I just wrote a web page using Perl!</H2>";
print "</BODY></HTML>";

also if .pl extension does not work, try using .cgi extension
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.