Enable Telnet service

Hi,

   I have installed Linux 9 in my m/c.  i cann't able to telnet from another m/c to this.
and if i stop the xinetd service, it says, stopping xinetd  Failed. what should i do?
but i can able to do FTP.

i have checked in /etc/xinetd.d/telnet file  it says disable is No

Deva...
Deva77Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

sunnycoderCommented:
make sure that there is an entry for telnet service in /etc/services

start telnet from  /usr/sbin/in.telnetd with whatever options you deem fit ...
man 8 telnetd for detailed information on telnet options

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jlevieCommented:
This sounds like it might be RedHat 9. The first thing to check is whether you have the telnet server package installed with 'rpm -q telnet-server'. If it is you next need to make sure that the service is enabled with 'checkconfig telnet on' and follow that with 'service xinetd restart'. At this point the telnet service should be enabled and you can check that by trying 'telnet localhost' and a telnet session to the server from some other machine. If telnet to the localhost works, but sessions from outside fail you need to look for a firewall being in the way.
yuzhCommented:
telnet is not secure, plain text password. consider use secure shell instead. (ssh or openssh, they
are including secure FTP - sftp as well)
Acronis True Image 2019 just released!

Create a reliable backup. Make sure you always have dependable copies of your data so you can restore your entire system or individual files.

shivsaCommented:
you can enable xinetd-managed services simply with:
 
  # chkconfig telnet on

doing this restarts xinetd automatically.
shivsaCommented:
also
you also need to make sure that telnet/port 23 isn't being restricted by any any firewalling or entries in /etc/hosts.allow and /etc/hosts.deny.
shivsaCommented:
Check with the following command.
#rpm -qa | grep telnet

if it is not installed, install the same from the CD

rpm -ivh telnet-server-??????.rpm

enable the telnet in /etc/xinet.d/telnet file. Give disable=no

Restart the xinetd daemon

/etc/init.d/xinetd restart
EarleAkeCommented:
What error do you get when you try to telnet?  Do you get  the login prompt and are unable to login or can you not connect at all?  If you get the login prompt but can't login, maybe you are trying as root.  By default, root can't telnet in.
sam_sunderCommented:
Hi Deva,

1 The first thing you have to do is to see weather  telnet server rpm is available or not.
2. Type ntsysv at the prompt . you can see all the services in the menu check telnet and restart the xinetd demon.
3. You also have to check for telnet service in /etc/services.
4. The best thing is to use ssh for security reasons.  

Its  good to use a tool like putty. you can find this at http://www.chiark.greenend.org.uk/~sgtatham/putty/ . This is really a great
tool. I use it. it supports telnet, ssh, rlogin.

regards

sam
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.