Solved

IIS SMTP Mail Gets Stuck In Queue

Posted on 2003-11-11
53
110,336 Views
Last Modified: 2012-01-27
I've setup IIS to send bulk mail using a program called campaign enterprise from ariel software. When I send the messages they all get stuck in the queue. how can I receive them through outlook. The operating system I use is Win 2000 Pro. I do not have a static IP address. Everytime I use IIS I change the IP addresses but the mail still gets stuck in the queue. I've moved them to the pickup folder but they end up going back to the queue. In the event log the error reads - message to the remote domain failed, the connection was dropped by the remote host. I'll be grateful for your advice.

Regards n11cep
0
Comment
Question by:n11cep
  • 26
  • 25
  • 2
53 Comments
 
LVL 7

Expert Comment

by:Makr_Watson27
Comment Utility
Are you sending to a Smart Host or using DNS to resolve and send?
Check this by load Internet Information Services Manager
Right click SMTP Server, choose properties
Choose the Delivery Tab
Click Advanced
Do you have a Smart host set?

If you do then the SMTP server cannot find the Smart Host to deliver the messages to.
If you dont then you probably have a DNS resolution problem or a firewall issue
0
 

Author Comment

by:n11cep
Comment Utility
There is nothing in my smart host. I do not know what DNS is. I have norton personal firewall. I've allowed access for port 25 and I've also disabled it to see if that made a difference but no luck. My defualt website and default ftp sites have the same ip addresses as my default smtp server. Could this be causing my problem. If it is, how do I find the correct ip addresses. Is it ok to use a dial up connection.

My knowledge of IIS is not that great I'm more on the beginner level.

Regards

Paul (n11cep)
0
 
LVL 7

Expert Comment

by:Makr_Watson27
Comment Utility
You have two options for delivery of mail:

Smart Host
This setting tells the server to send all mail to another SMTP server.  So if you have an email account with your ISP then they generally give you an SMTP Address for you to send mail to, you could use this address for the Smart Host, in which case all outbound mail gets sent to that server for delivery onwards.

Direct Delivery
With this option your SMTP server delivers mail directly to the SMTP Server resposible for the domain the mail message is getting sent to.  What it does is looks up who is the responsible mail server for the domain and sends the mail to that server.

Try the following articles:
HOW TO: Configure the SMTP Virtual Server for Message Delivery
http://support.microsoft.com/default.aspx?scid=kb;en-us;303734&Product=iis50

HOW TO: Test the Windows 2000 SMTP Service Outbound Mailflow Without Using DNS
http://support.microsoft.com/default.aspx?scid=kb;en-us;297988

0
 

Author Comment

by:n11cep
Comment Utility
I've set up a smart host connection but my mail still goes back to the queue folder when I drag and drop the messages into the pickup folder. I'm sure the mail server I'm using is correct because in outlook under tools, accounts and then servers, my outgoing smtp mail is what I've used for my smart host. Ive also created a new domain in IIS to forward all mail to that server. I do not know what I'm doing wrong.

Regards

Paul (n11cep)
0
 
LVL 7

Expert Comment

by:Makr_Watson27
Comment Utility
You mentioned that you get event log errors, can your detail them please.

Also could you try the following for me from the server:
Click Start - Run
Enter CMD and click OK
This will produce a DOS Prompt
Type in the following
NSLOOKUP -TYPE=MX hotmail.com
Press enter

Then post up the response for me, this will help with DNS resolution.

0
 
LVL 7

Expert Comment

by:Makr_Watson27
Comment Utility
Also try the following article:
XCON: Windows 2000 and Exchange 2000 SMTP Use TCP DNS Queries
http://support.microsoft.com/?kbid=263237
0
 

Author Comment

by:n11cep
Comment Utility
C:\>NSLOOKUP - TYPE=MX hotmail.com
Usage:
nslookup (-opt ...)                       interactive mode using default server
nslookup (-opt...) - server            interactive mode using 'server'
nslookup (-opt...) host                 just look up 'host' using default server
nslookup (-opt...) host  server      just look up 'host' using  'server'

this is what comes up in the command prompt.

Regards

Paul (n11cep)
0
 

Author Comment

by:n11cep
Comment Utility
The error message in the event viewer is:
Message delivery to the remote domain 'sn2b.com' failed. The error message is 'The connection was dropped by the remote host'.

Regards

Paul (n11cep)
0
 
LVL 7

Expert Comment

by:Makr_Watson27
Comment Utility
Sorry the nslookup should be done in lowercase

nslookup -type=mx sn2b.com

You should get a response back in the form of
Server:  ns2.jtibs.net
Address:  212.9.0.136

Non-authoritative answer:
sn2b.com        MX preference = 20, mail exchanger = ns.studio2online.net
sn2b.com        MX preference = 10, mail exchanger = ns2.studio2online.net

sn2b.com        nameserver = ns2.studio2online.net
sn2b.com        nameserver = ns.studio2online.net
ns2.studio2online.net   internet address = 212.19.80.74
ns.studio2online.net    internet address = 212.19.88.151


Did you follow the artilce
http://support.microsoft.com/?kbid=263237
If so what was the result
0
 

Author Comment

by:n11cep
Comment Utility
I followed the article and I got the same information you got in the command prompt. I typed in the set vc and set q=mx. I then stopped the IIS moved the messages to the pickup folder, restarted the IIS but the messages went back to the queue folder.

Regards

Paul (n11cep)
0
 
LVL 7

Expert Comment

by:Makr_Watson27
Comment Utility
It is good that you got the DNS resolution,  what we need to do next is see if we can get through to the domains in question
Can you try the following:
telnet ns2.studio2online.net 25

It should come back with the following:
220-NS2.STUDIOIIONLINE.COM ESMTP Studio 2 Online Ultimate Mail Server ; Wed, 12
Nov 2003 16:01:02 -0000
220-220-Studio2online Power Mail Server;
220-Sun, 22 Oct 2000 14:32:28
220-*********************************************************************
220-220-* Secure Mail Server
220-220-*
220-220-* All connections are logged!
220-220-* This server employs antivirus and antispam technology
220-220 -*
220-*********************************************************************
220

Does it?
0
 

Author Comment

by:n11cep
Comment Utility
Yes, I get the same as you but only if I disable norton personal firewall. Do you know what port I can open so I can have norton enabled.

Regards

Paul (n11cep)
0
 
LVL 7

Expert Comment

by:Makr_Watson27
Comment Utility
You need SMTP port 25 open
If you are only sending email then open it outbound
If you are sending and receiving email open it bothways.

Basically SMTP works on port 25, if you havnt got it open mail cannot be sent or recevied.
0
 

Author Comment

by:n11cep
Comment Utility
I have port 25 open. I can send and receive mail from outlook but if I try to send mail using smtp it gets stuck in the cue. I don't understand what you mean by both ways. Is there another port for receiving.

Regards

Paul (n11cep)
0
 

Author Comment

by:n11cep
Comment Utility
Port 25 is selected in IIS. I can send and receive mail from outlook ok without using IIS, but when I send mail using campaign enterprise from ariel software it ends up sitting in the queue file. I don't understand what you mean by both ways. Is there another port for receiving the mail and is it only on IIS where the port should be selected.

Regards

Paul (n11cep)
0
 

Author Comment

by:n11cep
Comment Utility
Would you mind sending your last comment again please. The comment section was blank.

Regards

Paul (n11cep)
0
 
LVL 7

Expert Comment

by:Makr_Watson27
Comment Utility
I would like to try and determine where your fault lies, but so far all I can glean is conflicting messages.  If you try the following from your IIS Server for me please:
Open a command prompt

Type in
telnet user21.busdsl.jtibs.net 25

You should see the following:
220 ctsnts01.rdp.ctscomputing.com Microsoft ESMTP MAIL Service, Version: 5.0.219
5.6713 ready at  Wed, 12 Nov 2003 18:10:22 +0000

Type in
helo servername
(Where servername is the full dsn name of your IIS Server, you can find this by right-clicking 'My Computer', select properties, click the Network Identification tab.  The full computer name is shown, this is the one you need.)

You should see the following
250 ctsnts01.rdp.ctscomputing.com Hello [192.168.42.2]

Type in
mail from:youremailaddress
(Where youremailaddress is your full email address)

You should see the following
250 2.1.0 youremailaddress....Sender OK

Type in
rcpt to:test@ctscomputing.com

You should see the following:
250 2.1.5 test@ctscomputing.com

Type in
data

You should see the following:
354 Start mail input; end with <CRLF>.<CRLF>

Type in
testing
.

(Its important that you type in testing then press return then type in . and press return)

You should see the following:
250 Requested mail action okay, completed

Type in
quit

You should see the following:
221 Service closing transmission channel


Connection to host lost.


I will then be able to see your email come in.

If you cannot complete this process then the IIS SMTP server cannot send mail.
0
 

Author Comment

by:n11cep
Comment Utility
Everything is ok up to the bit where it says 354 Please start mail input.
but I do not see ; end with <CRLF>.<CRLF>

Regards

Paul (n11cep)
0
 
LVL 7

Expert Comment

by:Makr_Watson27
Comment Utility
Did you actually complete it reagrdless because I didnt get a message.
0
 

Author Comment

by:n11cep
Comment Utility
I've now continued to the next step, because I did not see
; end with <CRLF>.<CRLF>
I typed in testing (then pressed the enter key)
. (then pressed the enter key)
then it said
250 Mail queued for delivery.

Regards

Paul (n11cep)
0
 

Author Comment

by:n11cep
Comment Utility
Your last mail was blank again. Would you mind resending it for me please.

Thanx

paul (n11cep)
0
 
LVL 7

Expert Comment

by:Makr_Watson27
Comment Utility
Odd, I didnt get the message, you shouldnt need to type quit but can you repeat the test but end with quit

As an aside waht I am trying to achieve here is the limiting of your problems.  Basically we need to proove several items:
1) You can do a nslookup for a domain from your server
2) You can manually send an email from your server
3) A client can send an email to your smtp server for delivery onwards

1) We have prooved the nslookup by doing
nslookup -type=mx ctscomputing.com
and getting an MX record back

2) I need to get the message from you to proove that you can manually send, however I think this point is okay.

3) Setup an outlook client with the SMTP address pointing to the IP Address that your IIS SMTP server is running on.  Create and send a message to test@ctscomputing.com

Please do not involve your Ariel Software as yet, until we have prooved IIS is okay we shouldnt be involving anything else.

Regards
Mark
0
 

Author Comment

by:n11cep
Comment Utility
I don't understand how to do step 3. Can you explain this in more detail. Sorry to be a pain.

Regards

Paul (n11cep)
0
 
LVL 7

Expert Comment

by:Makr_Watson27
Comment Utility
Paul,

In between postings I have setup a Win2k with SMTP and have replicated your problem.
I am attempting to resolve on this blank SMTP server and will post up a resolution as soon as I have one.

Thanks for your patience.

Mark

p.s. Still didnt get your manual mail
0
 

Author Comment

by:n11cep
Comment Utility
I'm very grateful for your time and efforts in helping me to resolve my problem.
Thank you

Regards

Paul (n11cep)
0
 
LVL 7

Expert Comment

by:Makr_Watson27
Comment Utility
Right lets try the following, this will default your SMTP Settings, although I feel a re-install of your IIS maybe needed.

Load IIS Manager
Bring up properties on your SMTP Server
Make sure your internal network IP Address is selected in the list
Click Advanced, ensure that the line has your internal network IP address and the port is 25
Click OK

Click Connection
Under incoming
Untick Limit Connections to
Enter 10 for the Time-out
Under outgoing
Tick Limit Connections to and set to 1000
Enter 10 for the Time-out
Tick Limit Connections per domain and set to 100
Enter 25 for the TCP Port
Click OK

Click Access Tab
Click Authentication
Check Anonymous, Basic and Windows security
Click OK

Click Connection
Ensure All Except list below is selected and that there is nothing in the list
Click OK

Click Relay
Ensure Only the list below is selected
Tick the box labelled Allow all computers which successfully authenticate...
Click OK

Click the Messages Tab
Limit Message Size to 2048
Limit session size to 10240
Limit number of messages per connection to 20
Limit number of receipients per message to 100
Clear the NDR Box
Set the Badmail root to C:\InetPub\mailroot\badmail
(If you've installed to another drive or location then choose the approriate)

Click the Delivery Tab
Under Outbound
Set First retry to 15
Set Second retry to 30
Set Third retry to 60
Set Subsequent retry to 240
Set Delay notification to 12 Hours
Set Expiration to 2 Days
Under Local
Set delay notification to 12 Hours
Set expiration to 2 Days

Click Outbound Security
Ensure Anonymous is selected
Clear the TLS encryption
Click OK

Click Advanced
Set Max hop count to 15
Enter your servers fully qualified domain name (The one under Network ID on My Computer)
Clear the Smart host box
Clear the Perform reverse DNS
Click OK

Click LDAP Routing
Clear the Enable LDAP Routing

Click the Security Tab
Ensure Administrators is in the list.

Click OK
Stop the SMTP Server by right clicking it and choosing Stop
Start the SMTP Server by right clicking it and choosing Start
Wait 10 minutes

Meanwhile setup Outlook or Outlook Express
Use the internal IP Address of your SMTP Server for the outgoing messages
Send a message to your hotmail account or anything else you can check.
Does it work?

If you're still getting the event log errors then we should try specifying a remote domain, but I will wait for you to try the above first.
0
Top 6 Sources for Identifying Threat Actor TTPs

Understanding your enemy is essential. These six sources will help you identify the most popular threat actor tactics, techniques, and procedures (TTPs).

 
LVL 7

Expert Comment

by:Makr_Watson27
Comment Utility
Paul,

Quick question, are you getting any other event log errors from your SMTP, especially when you restart it?

Mark
0
 

Author Comment

by:n11cep
Comment Utility
I messages that said
Virtual Server 1. All bad messages will be forwarded to the post master.
Virtual Server 1. Smart Host is disabled
Virtual Server 1. Postmaster will not receive a copy of NDR messages
0
 
LVL 7

Expert Comment

by:Makr_Watson27
Comment Utility
If the messages are still queuing up then I can olny suggest you try the following excerpt from MS Article 812292:

Remove IIS
Click Start, and then click Control Panel, and then double-click Add/Remove Programs.
Click Add/Remove Windows Components, and then click to clear the Internet Information Services (IIS) check box.

To complete the wizard, follow the prompts.
Verify that the Metabase.bin file has been removed from the system by locating the following file:
<drive>\winnt\system32\inetsrv

If the Metabase.bin file exists, delete it.
Reinstall IIS
Click Start, and then click Control Panel.
Double-click Add/Remove Programs, and then click Add/Remove Windows Components.
Click the Internet Information Services (IIS) check box to enable IIS.
Click Details, and then click both SMTP.

To complete the wizard, follow the prompts.
Re-apply the Microsoft Windows 2000 Service Pack 4 (SP4). If you are prompted to do so, restart the server.

Good luck
0
 

Author Comment

by:n11cep
Comment Utility
I will try this tomorrow and let you know of the outcome. I would like to thank you once again for all your efforts and time. You have been very helpful even though I have very little understanding of the program.

Have a pleasent day

P.S just out of a matter of interest, what is the accept tags for besides sides  comment

Regards

Paul (n11cep)
0
 
LVL 7

Expert Comment

by:Makr_Watson27
Comment Utility
When we solve your problem, you will accept one of the comments as the answer and hence finish the posting.
Check out the help:
http://www.experts-exchange.com/help.jsp

I've still yet to read it all, I only signed up last week.  Have a good day too.
Mark
0
 

Author Comment

by:n11cep
Comment Utility
Hello Mark,

Do I need any windows 2000 server packs to use IIS.

Regards

Paul (n11cep)
0
 
LVL 7

Expert Comment

by:Makr_Watson27
Comment Utility
I would recommend going to SP4
Also if you have a broadband connection get all your WindowsUpdates done.

Mark
0
 

Author Comment

by:n11cep
Comment Utility
I've uninstalled and reinstalled IIS. I've used the settings you advised me to use. under relay you said - Ensure Only the list below is selected
Tick the box labelled Allow all computers which successfully authenticate
Click OK
When I do this and run the ariel software, in the message report for the software it says the messages have not been sent. If I go into IIS - relay and type in my IP address and select Only the list below the messages in the ariel software can be sent, but they still end up in the queue. Do you have any other suggestions I could try please.

Regards

Paul (n11cep)
0
 
LVL 7

Expert Comment

by:Makr_Watson27
Comment Utility
Paul,

I am failry certain your problem doesnt lie with the Ariel software as IIS should be able to send regardless.  The reason you need to turn the relay on is a seperate issue, but it is okay to have the list limited to your IP Address.  Where can I get hold of this bit of software, I will tru it on a server here and inform you of the results.

Mark
0
 
LVL 7

Expert Comment

by:Makr_Watson27
Comment Utility
Paul,
Ignore previous posting, I have located and will test.
Mark
0
 
LVL 7

Expert Comment

by:Makr_Watson27
Comment Utility
Paul,
Which ISP are you with, I need to know if you get an SMTP server you can use as a smart host
Mark
0
 

Author Comment

by:n11cep
Comment Utility
I'm with AOL in the United Kingdom

Regards

Paul (n11cep)
0
 
LVL 7

Expert Comment

by:Makr_Watson27
Comment Utility
I won't worry about AOL for now but...
I have setup a server here and successfully pretended to be you.
So can you try the following settings:
Open IIS
Properties on SMTP
Click Delivery Tab
Enter somethingnew2buy.com for the masquerade domain
Enter mail.somethingnew2buy.com for the Fully-qualified domain name
Enter [212.19.80.74] for the Smart Host
Tick the box labelled Attempt Direct Delivery before sending to smart host
Click OK
Stop and Start IIS

Try your software but limit the amount to say 10 messages.

Mark
0
 

Author Comment

by:n11cep
Comment Utility
Hi Mark,

The messages are still going back to the queue, although I have followed the above instructions.

Regards

Paul
0
 
LVL 7

Expert Comment

by:Makr_Watson27
Comment Utility
Paul,

Can you turn on logging:
Open IIS
Properties on SMTP
Tick the Enable Logging checkbox
Leave Active Log Format as 'W3C Extended Log Format'
Click Properties
Choose Daily
Clear use Local Time
Make a note of the directory, I would recommend changing the location if you're leaving logging on, but for now leave it where it is.
Click the Extendend Properties Tab
Check all the boxes
Click OK
Click OK
Stop the SMTP Service
Clear your Queue
Start the STMP Service

Can you try one message using the test message facility in the Arial Software.

Then post up the SMTP Log Results, there should be a file in the folder you noted above with a filename of the current date, post up the last few lines.

Mark
0
 

Author Comment

by:n11cep
Comment Utility
Hello Mark,

I tried to send a test message in campaign enterprise 8 provided by arial software.com it says the page you are requesting can not be found. Ariel software do not open until 9.00am they are 7 hours behind the UK. The time in the UK now is 10.53am, so it will be 4.00pm before I can speak to someone about the error page.

Regards

Paul
0
 
LVL 7

Expert Comment

by:Makr_Watson27
Comment Utility
Paul,
The other test via arial is to create a new campaign and use an address list containg one address
Mark
0
 

Author Comment

by:n11cep
Comment Utility
Mark,

I've sent the message again but it still ends up in the queue file. The information below is from the log files smtp folder

Fields: date time c-ip cs-username s-sitename s-computername s-ip s-port cs-method cs-uri-stem cs-uri-query sc-status sc-win32-status sc-bytes cs-bytes time-taken cs-version cs-host cs(User-Agent) cs(Cookie) cs(Referer)
2003-11-14 11:43:30 81.145.94.80 CAMPAIGN SMTPSVC1 PAUL-A2L9N0CEL5 81.145.94.80 0 HELO - +CAMPAIGN 250 0 52 13 1078 SMTP - - - -
2003-11-14 11:43:31 81.145.94.80 CAMPAIGN SMTPSVC1 PAUL-A2L9N0CEL5 81.145.94.80 0 MAIL - +FROM:+<queries@somethingnewtobuy.com> 250 0 54 42 985 SMTP - - - -
2003-11-14 11:43:31 81.145.94.80 CAMPAIGN SMTPSVC1 PAUL-A2L9N0CEL5 81.145.94.80 0 RCPT - +TO:+<marketing@somethingnewtobuy.com> 250 0 44 42 0 SMTP - - - -
2003-11-14 11:43:38 81.145.94.80 CAMPAIGN SMTPSVC1 PAUL-A2L9N0CEL5 81.145.94.80 0 MAIL - +FROM:+<queries@somethingnewtobuy.com> 250 0 54 42 0 SMTP - - - -
2003-11-14 11:43:38 81.145.94.80 CAMPAIGN SMTPSVC1 PAUL-A2L9N0CEL5 81.145.94.80 0 RCPT - +TO:+<marketing@somethingnewtobuy.com> 250 0 44 42 0 SMTP - - - -
2003-11-14 11:43:38 81.145.94.80 CAMPAIGN SMTPSVC1 PAUL-A2L9N0CEL5 81.145.94.80 0 DATA - +<20031114114331.705547@somethingnewtobuy.com> 250 0 129 747 563 SMTP - - - -
2003-11-14 11:43:40 81.145.94.80 CAMPAIGN SMTPSVC1 PAUL-A2L9N0CEL5 81.145.94.80 0 QUIT - CAMPAIGN 240 12797 74 4 0 SMTP - - - -
2003-11-14 11:43:46 212.19.80.74 OutboundConnectionResponse SMTPSVC1 PAUL-A2L9N0CEL5 - 25 - - 220-NS2.STUDIOIIONLINE.COM+ESMTP+Studio+2+Online+Ultimate+Mail+Server+;+Fri,+14+Nov+2003+11:44:40+-0000 0 0 103 0 5093 SMTP - - - -
2003-11-14 11:43:46 212.19.80.74 OutboundConnectionCommand SMTPSVC1 PAUL-A2L9N0CEL5 - 25 EHLO - mail.somethingnew2buy.com 0 0 4 0 5093 SMTP - - - -
2003-11-14 11:43:46 212.19.80.74 OutboundConnectionResponse SMTPSVC1 PAUL-A2L9N0CEL5 - 25 - - 250-NS2.STUDIOIIONLINE.COM+Hello+mail.somethingnew2buy.com+[172.189.132.214],+pleased+to+meet+you. 0 0 98 0 5203 SMTP - - - -
2003-11-14 11:43:46 212.19.80.74 OutboundConnectionCommand SMTPSVC1 PAUL-A2L9N0CEL5 - 25 MAIL - FROM:<queries@somethingnewtobuy.com> 0 0 4 0 5203 SMTP - - - -
2003-11-14 11:43:57 212.19.80.74 OutboundConnectionResponse SMTPSVC1 PAUL-A2L9N0CEL5 - 25 - - 250+2.1.0+<queries@somethingnewtobuy.com>...+Sender+ok 0 0 54 0 16250 SMTP - - - -
2003-11-14 11:43:57 212.19.80.74 OutboundConnectionCommand SMTPSVC1 PAUL-A2L9N0CEL5 - 25 RCPT - TO:<marketing@somethingnewtobuy.com> 0 0 4 0 16250 SMTP - - - -
2003-11-14 11:43:57 212.19.80.74 OutboundConnectionResponse SMTPSVC1 PAUL-A2L9N0CEL5 - 25 - - 250+2.1.5+<marketing@somethingnew2buy.com>...+Recipient+ok 0 0 58 0 16500 SMTP - - - -
2003-11-14 11:43:57 212.19.80.74 OutboundConnectionCommand SMTPSVC1 PAUL-A2L9N0CEL5 - 25 BDAT - 1017+LAST 0 0 4 0 16500 SMTP - - - -
 
Regards

Paul (n11cep)
0
 

Author Comment

by:n11cep
Comment Utility
Mark,

just a quick note, these are the last few lines of the smtp trace log that I just ran.

SMTP log file opened on: 11/14/2003 12:12:40 PM
CONNECT REQUESTED: 81.145.94.80

CONNECT RESPONSE: 220 mail.somethingnew2buy.com Microsoft ESMTP MAIL Service, Version: 5.0.2195.6713 ready at  Fri, 14 Nov 2003 12:12:42 +0000

SEND HELO
SENDING: MAIL FROM: <queries@somethingnewtobuy.com>

RECEIVE: 250 2.1.0 queries@somethingnewtobuy.com....Sender OK

Regards
Paul (n11cep)
SENDING: From: sales@somethingnewtobuy.com
To: marketing@somethingnewtobuy.com

--Boundary.11111111.11111111--


.

RECEIVE: 250 Mail queued for delivery.

CLOSE RESPONSE: 221 Closing connection. Good bye.



SENDING: RCPT TO: <marketing@somethingnewtobuy.com>

RECEIVE: 250 2.1.5 marketing@somethingnewtobuy.com

SENDING: DATA

RECEIVE: 354 Please start mail input.
0
 

Author Comment

by:n11cep
Comment Utility
Mark,

The information below is from the trace log of campaign enterprse. I don't know if you may find this helpful or not.

11/14/2003 12:12:53 PM basProcessing/RequestVariables: Parameter 1 of the method used is invalid or not appropriate. - Variable Name: CampaignCategory
11/14/2003 12:12:59 PM basProcessing/RequestVariables: Parameter 1 of the method used is invalid or not appropriate. - Variable Name: COMMAND
11/14/2003 12:12:59 PM basProcessing/RequestVariables: Parameter 1 of the method used is invalid or not appropriate. - Variable Name: ALTCOMMAND
11/14/2003 12:13:00 PM basProcessing/RequestVariables: Parameter 1 of the method used is invalid or not appropriate. - Variable Name: COMMAND
11/14/2003 12:13:00 PM basProcessing/RequestVariables: Parameter 1 of the method used is invalid or not appropriate. - Variable Name: ALTCOMMAND

Regards

Paul (n11cep)
0
 
LVL 7

Expert Comment

by:Makr_Watson27
Comment Utility
Paul,

Are you using GFI Mail Essentials, if so read http://support.microsoft.com/default.aspx?scid=kb;en-us;812292&Product=iis50
Looking at the logs Campaign is sending to smtp server, but SMTP server is not completing the data transfer.  It initiates the conversation with your external mail server but never completes.
I will keep looking.
Mark
0
 

Author Comment

by:n11cep
Comment Utility
Mark,

How will I know if I'm using GFI Mail Essentials.

Regards

Paul
0
 
LVL 7

Expert Comment

by:Makr_Watson27
Comment Utility
If you dont know, you probably arent.
What to try next
Reducing the timeouts so we get a NDR quickly
 - Properties on SMTP
 - Delivery
 - Advanced
 - Keep smart host of [212.19.80.74]
 - Untick Attempt Direct Delivery
 - OK
 - 1st Retry 2 mins
 - 2nd Retry 2 mins
 - 3rd Retry 2 mins
 - Subsequent Retrys 2 mins
 - Delay Notification 2 mins
 - Expiration 10 mins
 - Stop and Restart
Try doing a plain text email from Arial Software to my hotmail address

0
 

Author Comment

by:n11cep
Comment Utility
I've sent the email

Regards

Paul (n11cep)
0
 
LVL 7

Accepted Solution

by:
Makr_Watson27 earned 125 total points
Comment Utility
This has transpired to be primarily a firewall issue with Norton Personal Firewall and the allowing of SMTP traffic.
If the firewall is switched off mail can and does go through.
However the trouble shooting steps have become hindered by my lack of knowledge of this firewall.
All documentation I find does not concur with what Paul is seeing on screen.
0
 
LVL 1

Expert Comment

by:marrowyung
Comment Utility
Can you all tell me why we need to input masquerade domain?
0
 
LVL 1

Expert Comment

by:marrowyung
Comment Utility
Also,

When I type mail from:myaddress

it say 501 unrecognized paramter:myadress.

Marrow.
0

Featured Post

IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

What is an ISAPI filter?   •      It's an assembly (.dll file) that can add or change the way IIS works.   •      They can be enabled globally for your web server or on a site-by-site basis.   When the IIS server receives a request, enabling the ISAPI fi…
When it comes to showing a 404 error page to your visitors, you do not want that generic page to show, and you especially do not want your hosting provider’s ad error page to show either. In this article, I will show you how to enable the custom 40…
This video discusses moving either the default database or any database to a new volume.
Access reports are powerful and flexible. Learn how to create a query and then a grouped report using the wizard. Modify the report design after the wizard is done to make it look better. There will be another video to explain how to put the final p…

772 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

9 Experts available now in Live!

Get 1:1 Help Now