Solved

Crystal Enterprise 9 Standard edition - licensce issue (dropping licenses after inactivity)

Posted on 2003-11-11
4
447 Views
Last Modified: 2007-12-19
I have Crystal Entyerprise 9 standard insatlled on a server with 5 concurrant licenses.  Reports are published via IIS to a virtuial directory browser folder and  called via a URL, this uses one guest account license from the Enterprise server.  When the internet browser is closed down the license remains open for 20 mins, there are settings on the pageservers etc to time out idle connections after 20 mins which i have changed to 1 minute but it is still happening.  Anyone know which setting needs to be changed.  It is very easy to run 5 instances of a report and use all the licenses up even thought the report browser has been closed.
0
Comment
Question by:faulja
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
4 Comments
 
LVL 101

Expert Comment

by:mlmcc
ID: 9727331
How are you closing the reports?  Are you freeing the connection?

I thought I had read that CR9 had solved the problem of holding connection open.  That may not be true for Enterprise.

After resetting the timeouts have you Shutdown CE and restarted it?  Restarted the server?

mlmcc
0
 

Author Comment

by:faulja
ID: 9727381
I have restared all the services and rebooted after the changes and there is no difference.  I found the knowledge base article refering to CE8 on the crytsal website which is an exact match of the problem.

All of the servers in CE9 have a timeout setting for logging of users after idle time, except the web server componet which is refered to in the CE8 problem.

The users have no option to log out, they open their report in a browser, refresh, view, export etc, when they are finished they close the browser.  They are never aware of any logon process as the guest account  logon prompt never appears (Unless we are out of licenses)
0
 
LVL 1

Accepted Solution

by:
claral earned 150 total points
ID: 9736074
Install SP1 for CE9, the hardcoded 20 min timeout can then be changed in the webserver component, add the following linme to the command line

-defaultsessiontimeout x where x is minutes
0
 

Author Comment

by:faulja
ID: 9736357
Excellent, that seems to have done the trick.  Still not very impressed with the standard software with this problem
0

Featured Post

On Demand Webinar: Networking for the Cloud Era

Ready to improve network connectivity? Watch this webinar to learn how SD-WANs and a one-click instant connect tool can boost provisions, deployment, and management of your cloud connection.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Crystal Reports: 5 Tests for Top Performance It is complete, your masterpiece report.  Not only does it meet your customer’s expectations, it blows them out the water, all they want is beautifully summarised and displayed in a myriad of ways. …
I hate sub reports and always consider them the last resort in any reporting solution.  The negative effect on performance and maintainability is just not worth the easy ride they give the report writer.  Nine times out of ten reporting requirements…
In this brief tutorial Pawel from AdRem Software explains how you can quickly find out which services are running on your network, or what are the IP addresses of servers responsible for each service. Software used is freeware NetCrunch Tools (https…
Monitoring a network: why having a policy is the best policy? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the enormous benefits of having a policy-based approach when monitoring medium and large networks. Software utilized in this v…

622 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question