NT Service

Hi all,

I have created my own Service but have a problem starting up a GUI app from my Service.
If I use ShellExecute (with different parameters at the end  -  0, 1, ws_shownormal etc.), it does start it up but as a process, it does not actually open up the App.

Can someone please help me out here ?

Thanks !!

Pieter
PieterJAsked:
Who is Participating?
 
snehanshuCommented:
I think you would have to check the "Allow Service to Interact with The Desktop" checkbox in the service properties.
Right click your service from
Control Panel -> Administrative tools -> Services -> <your Service>
in the [Log on] tab

HTH,
...Snehanshu
0
 
snehanshuCommented:
And regarding your question
>>Delete Question Q_20604662
Post it in the CS section
http://www.experts-exchange.com/Community_Support
:-)
...Snehanshu
0
 
snehanshuCommented:
Some related links:
How can I allow my service to interact with desktop?
http://www.dotnet247.com/247reference/msgs/33/166835.aspx

How to enable a service to interact  with desktop when the service is not running under the localSystem account?
http://www.experts-exchange.com/Operating_Systems/Q_20572206.html

:-)
0
 
snehanshuCommented:
Hey
  I just figured out that if you set the "interactive" property of your service to true then the "Allow Service to Interact with The Desktop" gets checked on install.
...Shu
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.