Solved

"man" problem

Posted on 2003-11-12
4
334 Views
Last Modified: 2013-12-15
I have a problem with "man"
when I want see manual of a command, it didn't show normally
inside the manual, there were strange character (like small rectangle)
i think this is about font problem
but I don't know what should I do

can anybody help me?
thanks
0
Comment
Question by:nk2003
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
4 Comments
 
LVL 24

Expert Comment

by:shivsa
ID: 9729406
u have to fix fonts.

this is for RH7.
-------

> Using a combination of vi/emacs and man XF86Config:

> 1) Discover which /etc/X11/XF86Config??? is actually being run
>  - (under RedHat 7.1 it's /etc/X11/XF86Config-4)
>  - capture the output of startx using startx >& output.log
> and look for where it reports which one it is using

> 2) Find the fonts section

> 3) Fix it

> You'll want to look for the "how to specify font paths" section in the
> man pages. Essentially it's:

> Section "Files"
>         FontPath "tcp/linux:7100"  
>       FontPath   "/usr/X11R6/lib/X11/fonts/local/"
>       FontPath   "/usr/X11R6/lib/X11/fonts/misc/"
> EndSection

> The first entry says speak to an XFS using tcp and port 7100.
> The latter two represent actual physical font paths. I think the Unix Font Server
> locally is "unix/:0" but check that in the man pages. Fonts generally
> live in similar directries to the above. You could do a "locate
> fonts.dir" because each font directory must contain that file if you
> can't find them.

> Of course, if you literally can't find them then that may be your
> problem. Reinstall them using rpm, tar xzvf, dpkg or whatever.
0
 
LVL 24

Expert Comment

by:shivsa
ID: 9729493
if u can resolve with above. then it might be your locale problem.

If you see three characters instead of one in your terminal, it's that your terminal is not UTF-8 aware and man
thinks it is. So, either use a UTF-8 aware terminal (XFree86, xterm) or don't tell man your terminal is UTF-8 (probably a locale issue).

LC_CTYPE=C man tty
to see if that solves the problem.

or
export LANG=C

Put it at the bottom of:
/etc/bashrc

and will be set when you login.
0
 

Author Comment

by:nk2003
ID: 9729846
thanks, it works
I type export LANG=C

can you tell me what it means?  expecialy "C" character
0
 
LVL 24

Accepted Solution

by:
shivsa earned 125 total points
ID: 9732890
this state that u had locale problem.

by export LANG=C, u setup your locale setting to use C locale.

At program startup, the current language and country setting is retrieved from the operating system. and this way u are telling OS to give u language setting to C locale which is commonly used in USA.
0

Featured Post

Ransomware: The New Cyber Threat & How to Stop It

This infographic explains ransomware, type of malware that blocks access to your files or your systems and holds them hostage until a ransom is paid. It also examines the different types of ransomware and explains what you can do to thwart this sinister online threat.  

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

rdate is a Linux command and the network time protocol for immediate date and time setup from another machine. The clocks are synchronized by entering rdate with the -s switch (command without switch just checks the time but does not set anything). …
Over the last ten+ years I have seen Linux configuration tools come and go. In the early days there was the tried-and-true, all-powerful linuxconf that many thought would remain the one and only Linux configuration tool until the end of times. Well,…
Excel styles will make formatting consistent and let you apply and change formatting faster. In this tutorial, you'll learn how to use Excel's built-in styles, how to modify styles, and how to create your own. You'll also learn how to use your custo…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

740 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question