Solved

Hard Drive Problems...  Shows up in Bios but just won't load an OS.

Posted on 2003-11-12
20
6,757 Views
Last Modified: 2012-08-13
I have a hard drive that registers when I boot and even when I try to load an OS but when I try to load the actual OS I get various problems depending on the OS.

First I tried with Slackware 9.1.  I was able to partition it with cfdisk and format it just before the install.  But during the install it just hangs on the first package...  forever.

Next was with Windows XP.  Again I see the size of the HD but during the formating it gives me an error.  Actually a BSOD with something about a partsys.mgr.

I tried some more OS's Linux and Windows based and got basically the same thing.  Even in a DOS boot (with a DOS boot disk) I can't even see the drive.

What in the world could the problem be?  Is there anything I can do to fix it...  If not I am desparetly curious to know the specific problem.
0
Comment
Question by:webtacsat
  • 6
  • 5
  • 2
  • +5
20 Comments
 
LVL 32

Expert Comment

by:Luc Franken
Comment Utility
webtacsat,
Can you remember the errorcode the blue screen gave you??

Boot from a win98/ME bootdisk, if you don't have one, get one from http://www.bootdisk.com
After you've done this run Fdisk and delete the existing partitions on your drive. Now try to install..

Still no luck??
Try zerofilling the drive using killdisk => http://www.killdisk.com

LucF
0
 
LVL 32

Expert Comment

by:jhance
Comment Utility
Your situation is unclear:

1) Has a DIFFERENT hard drive worked OK here?  If so, then it sure sounds like the drive itself is defective.  Try another one.

2) If NOT, then I suspect your problem is NOT the hard drive at all.  I think you have another hardware issue.  The most common one in my experience causing this is BAD RAM.  Try swapping out your RAM for some other modules or try your multiple modules individually until you find the bad one.

It could also be your CPU or motherboard (I'm assuming you've already checked out your cooling, power supply, etc.) but these are more difficult to check and the RAM being bad is much more common.
0
 
LVL 8

Expert Comment

by:Huseyin1
Comment Utility
i think you need to be patient, wait alittle, like with the 1st OS you rtryed, hardware is the culprit when OS installs freeze.
take somehting out.
0
 
LVL 8

Expert Comment

by:Huseyin1
Comment Utility
alos make sure the HDD is ok, do a scan disk, i think this can be done in dos mode, i think we need 3rd party software that will test the integrety of your HDD, anyone??????
0
 
LVL 18

Accepted Solution

by:
chicagoan earned 500 total points
Comment Utility
Download the manufacturer's testing utility and perform the destructive test or use WDCLEAR or KILLDISK to test and zero out the drives boot loader and partition table.

Download and run MEMTEST86 and let it run a couple of cycles.

0
 

Author Comment

by:webtacsat
Comment Utility
I guess I could have mentioned that before...  the hard drive was the only problem.  I have set up the computer with Slackware 9.1 on a different hard drive and the installation process flew.  Maybe I should also mention I tried each installation on each OS several times.  The outcome was always the same.  As for the specific error under Windows XP it was partmgr.sys...  I am 90% sure...  it was a while ago I tried that and I really don't feel like trying the installation again.  Plus I did a google search and found nothing on the error.  As for the other options I plan on trying them out tonight.
0
 
LVL 32

Expert Comment

by:Luc Franken
Comment Utility
Ok, keep us informed.
0
 
LVL 1

Expert Comment

by:asurada2003
Comment Utility
Why dont u get a new HDD and try.
Maybe u this HDD got internal error already.
0
 

Author Comment

by:webtacsat
Comment Utility
It's not about getting a new hard drive.  I have more than enough already.  I just want to understand exactly what is wrong with the hard drive.  I acquired it after fixing another computer by replacing this hard drive with a new one.

BTW, the likely hood of it being damaged by a drop is slim to none.

Anyway, I would just like to know what is causing this problem specifically.
0
 
LVL 18

Expert Comment

by:chicagoan
Comment Utility
SO the drive was a problem in another machine?
And your machine is OK with another drive..
Have you run the destructive fitness test from the drive manufacturer or killdisk or wdclear?
0
Threat Intelligence Starter Resources

Integrating threat intelligence can be challenging, and not all companies are ready. These resources can help you build awareness and prepare for defense.

 

Author Comment

by:webtacsat
Comment Utility
I think I am close to an answer.  I tried the manufaturer utility software but quickly found out that that was not the route to go.  Maxtor's utility told me there was an error, but it only gave me a service code so that I can return the HD.  Well, that won't work because the hard drive is old, how old I don't know...  but I acquired it from someone whose computer was severly outdated.  In case anyone wants to know what the error/service code is I'll just throw that in here.  It was C21S57...  don't think that means anything to a none maxtor techie.  Anyway I am using WDCLEAR right now and the process seems to be taking forever and could take forever longer.  So far I have an ECC error on Cylinder 2, Head 2, Sector 22 and the code is 17.  Now I don't know if that code 17 relates to the table on this website http://datarecoveryaid.com/hard_drive_errors.htm and then in that case would it be a 1717 error, which is surface read errors.
Can anyone tell me does the WDCLEAR process normally take a really long time?  I will close this question and give the points to chicagoan as soon as WDCLEAR is complete.  I just want to leave it open for a few more hours (could be days at this rate, LOL) so that I can post the final results and summarize everything.  Plus I am willing to hear some more advice if anyone has it.
0
 

Author Comment

by:webtacsat
Comment Utility
Okay I did the calculations.  There are over 13000 cylinders on this hard drive.  I have managed to get through testing 15 of them in one hour.  So it seems it would take about 37 days to finish the testing.  Guess I will just close this question and move on with my life.  Why is it takining so long?
0
 
LVL 18

Expert Comment

by:chicagoan
Comment Utility
What's the drive make and model?
What's the DMA setting for this controller?
Is it set for auto-detect and the only device on the controller?
Is SMART and VIRUS PROTECTION disabled in the BIOS (if present?)
Is it on a known good 80 wire cable?
0
 

Author Comment

by:webtacsat
Comment Utility
It is a Maxtor 90680U2.  As fir the DMA setting for this controller...  not sure how to check... in the bios?  Auto-detect is on but there is a CD-ROM drive on the same controller.  As for SMART and VIRUS PROTECTION disabled I am 99% sure but I would check if the computer wasn't tied up right now.  And finally, yes the cable is good.

Do you ask these things because they would affect the speed of WDCLEAR?

Do you think WDCLEAR can fix the ECC error?

I think I may have to stop this process...  I am currently at 33 cylinders complete...  which means at this current rate of about 20 every three hours it is going to take awhile.
0
 

Expert Comment

by:Biboshooter
Comment Utility
Hi, Perhaps you need to try some hardware swapping.

1) Try another hard drive. If the other hard drive works, then you have a faulty hard drive.
2) If still the same error occur with another drive, try changing of Memory. (use another similar memory.)
3) Another suggestion. You better put the CDROM (as Master) on another IDE controller. You will get better performance from your Hard drive.
4) If the initial Hard drive is confirm faulty. Use the Maxtor hard drive tester to scan and see if there is any problems.
5) Send the drive for RMA.

To understand why the drive fails, in technical detail for a user, it is quite hard on you then.
I am similar experience in dealig with a failed OS installation. It hangs half way. Even though I managed to complete the installation, I cannot start the OS after rebooting. I didnt suspect the Hard drive at all in the first place. Evetually I grew tired after swapping of hardware like display cards, memory, CDROM.. etc.. almost replace my motherboard.. Phew. I downloaded a Maxtor Hard drive tester and scan.. OMG. A faulty drive, which I sent for RMA.. returned me a New drive in 2 weeks. :-)
 
0
 
LVL 18

Expert Comment

by:chicagoan
Comment Utility
There's no point in letting that process continue, there's obviously something amiss.
The DMA mode will be shown in the bios, I'd reset the bios to factory defaults, and set the "reset configuration data" to YES.
If it's a maxtor, download their diags, take the CD off the chain and run it.
If that fails, you can do the RMA right on their website
0
 

Author Comment

by:webtacsat
Comment Utility
But I can't do an RMA if the drive is no longer under warranty, right?  Like I said I got this drive off of a guy out of a dead Compaq computer (the power supply went besides the hard drive but first the HD went then the pwrsupply).
0
 

Expert Comment

by:Biboshooter
Comment Utility
hi webacsat,

well if in this case, I can only suggest you to forget abt the whole thing. Dun brrod over a dying or dead hard drive. I have 8 hard drives sitting at home... guess what. they have nice roles. Paper weights. :-) The magnets are great tools to keep your paper fix onto the whiteboard. :-)

:-) cheers.
0
 
LVL 4

Expert Comment

by:shaharidzal
Comment Utility
Have you tried changing the IDE data cable?
0
 
LVL 18

Expert Comment

by:chicagoan
Comment Utility
Don't assume it's not under warranty, just plug the serial # in at their website.
0

Featured Post

Better Security Awareness With Threat Intelligence

See how one of the leading financial services organizations uses Recorded Future as part of a holistic threat intelligence program to promote security awareness and proactively and efficiently identify threats.

Join & Write a Comment

I have purchased two new systems and both are now Universal Extensible Firmware Interface (UEFI) based. UEFI is replacing BIOS for the desktop PC. It is a Linux based firmware with enough robustness it can communicate with a website without loading …
Moving your enterprise fax infrastructure from in-house fax machines and servers to the cloud makes sense — from both an efficiency and productivity standpoint. But does migrating to a cloud fax solution mean you will no longer be able to send or re…
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

772 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now