Dial up connection transfer delaying...

Hello i have a very strange thing happening in my comp. Everytime I connect to my ISP, the transfer is delayed for about 2 minutes. That mean when I'm connected to my ISP, I won't be able to do anything with the website, chat... for the first 2 minutes. Anyone know what caused this?
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

LucFEMEA Server EngineerCommented:
Check if other programs are using your internet connection. Maybe windows update, virusscaner etc. Also, check if the "log on to network" is unchecked at the connection settings as it's not needed for internet connections.

If you're using dialup, you have to balance your applications "instant update" settings against the likelyhood that if you set them to manual you would ever do them. I'd say to take the hit and be safe.

McAfee, Norton, Mircosoft, Realplayer, AOL and others can jump on your dialup connection to phone home everytime you connect. If this is a new build, if will settle down some once thinks are up to date.
ThangNhocNgayXuaAuthor Commented:
I think that it's not because of those app. there was just no data transfer between me and the ISP for the first two minutes. this is stupid... :((
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

Is this dialup or ISDN or DSL or what?  What is the routine you follow to connect?
bbaoIT ConsultantCommented:
"I think that it's not because of those app. there was just no data transfer between me and the ISP for the first two minutes", how do you know it? also please give more info about what ShineOn asked. thanks.
Who's your ISP?
Have you checked for ad/spyware?
In the initial period when things aren't working what is the output of IPCONFIG /A ?
If you have gotten an address, what are the results of a tracert to your ISP's DNS servers and a tracert to www.linux.org?
When you initally connect, try opening task manager and sorting the task list by CPU utilization to see what processes go active. (Running down each of those tasks is a good idea anyway)
ThangNhocNgayXuaAuthor Commented:
Hem. The topic said that i'm using Dial up :) i'm living in Vietnam and my ISP is FPT ( I also tried the other ISPs in case it's my ISP problem but it wasn't )

@chicagoan: Yes i have scanned my comp using Ad-aware 6 with the latest update. I'm using the following programs.

1.Norton Antivirus 2004 Pro
2.Zone Alarm Pro newest build.
3.Colorific for my monitor.
4.Popup Ad Blocker
5.Internet Turbo ( I installed this after the problem occured. )
5.SoundMax controller.
7.DU Meter.

There wasn't any signal show that my comp. trying to connect to the internet. When i went to the Event Viewer, i saw these errors:

1. Timeout (30000 milliseconds) waiting for a transaction response from the Dnscache service.
2. A provider, OffProv11, has been registered in the WMI namespace, Root\MSAPPS11, to use the LocalSystem account.  This account is privileged and the provider may cause a security violation if it does not correctly impersonate user requests. ( This is before the time the problem occured )

@ShineOn: The routine to connect? everything was normal after a dump on my system.

Anybody of you have an idea to deal with this issue? i'm really annoyed with the first two minutes when i'm connected to the net :((
LucFEMEA Server EngineerCommented:
Have you tried disabling the firewall for just this time to check if maybe the firewall is the problem here.
Error #1 is a problem. Spybot and other spy/ad removal programs can modify the host file. Check you host file, if you see a lot of entries pointing to localhost ( this is an attempt at null routing malicious web sites, but not a good one.
Rename the host file to hosts.old and copy hosts.sam to hosts to restore it.

A brute force method to get your networking back to default values would be to boot to safe mode, remove your modem and other network adaptors and all protocols and services, reboot and redetect everything.

#2 is informative and not an error, the Windows Management Instrumentation system to let you know that some, (potentially non-MS and/or potentially dangerous (to security or privacy)) code has registered to be run within WMI with LocalSystem priviledges. In this case it's Microsoft Office and if you're comfortable with that, it's OK.


Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ThangNhocNgayXuaAuthor Commented:
What the hell, a lot of ad and spy addr. there. ( I did use Ad-aware o.0 so why they are there ? ) Although i can't find the hosts.sam there but there was lmhosts.sam :P so i used it instead. And you know what? my connection back to normal. Thank you :)
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.