250GB Harddrive shows up as 128GB!

Hi

I bought a 250GB IBM Harddrive which is in a caddie connected via a firewire to my laptop. I had some problems with it (could not copy files due to i/o device error) and so I re-formatted it and instead of 250GB it shows up as 128GB. What is the problem - can someone help please?

Thanks

nikolailazarevAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

chicagoanCommented:
You don't say what operating system you're using.
Many of these drives come partitioned and formatted to their capacity with the FAT32 file system.
If you experienced errors accessing the factory partition and your repartitioning effort resulted in a 128GB limitation, I suspect that your machine's bios does not support 48-bit LBA.
See if your laptop manufacturer ha a bios upgrade to address that issue.
You'll them have to repartition and refort the drive.
That process will depend on your operating system and how you intend to use the drive.
Go for the bios update and post your results.
0
nikolailazarevAuthor Commented:
hi,
I'm using Sony Vaio Laptop, Pentium 4, with Win XP.
The file system here is obviously NTFS, and under this system I reformatted the drive.
Whem My buddy formatted it on him machine it showed as 238GB, but after I reformatted it it gives me 128GB only.

You say I should upgrade the BIOS, how do I do that? I only bought this laptop a 9 months ago wouldn't it have an updated BIOS anyway?

Thanks
0
chicagoanCommented:
One would think a 9 month old machine would have current bios.
Compare your bios to the latest available at http://ciscdb.sel.sony.com/cgi-bin/select-p-n.pl
Have you installed all the window updates?
You need XP service pack 1, at least.

>The file system here is obviously NTFS
Many people use FAT32 on their external drives for interoperability with other operating systems and to write drive images under DOS.

0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

LucFEMEA Server EngineerCommented:
How to Enable 48-bit Logical Block Addressing Support for ATAPI Disk Drives in Windows XP
http://support.microsoft.com/default.aspx?scid=kb;en-us;303013 

Also check for a bios update wich supports 48-bit adressing.

LucF
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
nikolailazarevAuthor Commented:
That's strange Chicagoan, I've looked at the URL you gave me to download the BIOS but they don't seem to have my model.

I'm using Sony Vaio PCG-GRX616SP - (laptop)  if you happen to know where I can find BIOS for this machine, please let me know. I would much appreciate that.
Like LucF says I think I also need BIOS which supports 48-bit addressing

Thanks

0
chicagoanCommented:
Try this link http://www.vaio-link.com/

Have you done the WIndows Updates?
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Storage

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.