recurring error message - Title:' Icc runtime: Gp Fault stack trace' - Message:' corrupted stack. Impossible to trace'

Hi,

I keep getting the error message box Title:' Icc runtime: Gp Fault  stack trace' - Message:' corrupted stack. Impossible to trace'
on the machine which hosts a broadband connection and uses ICS to deliver requests to othere machines on the network.

I have pretty much no idea what is going on except that it only occurs when the broadband connection is active. And i think that the error message pops up when web page requests are made.. but that's just a guess really.

Don't know whether it's important but The whole situation only seemed to start happening after a power cut recently.

Another problem that suddenly occured today after another power cut is that the A0 printer that is connected to the same machine as the above problem has stopped being accessible across the network yet is still functioning perfectly well on the host machine. I have tried reinstalling the printer drivers on both the host and the client but nothing.

Has anybody got a clue what i can do with either of these problems.

Please Let me know if you feel the points need to be increased and i will do so because it is rather urgent
StoopidisAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

lrmooreCommented:
Try re-setting the TCP/IP stack on the workstation
If workstation is XP:

How to Reset Internet Protocol (TCP/IP) in Windows XP
http://support.microsoft.com/default.aspx?scid=kb;en-us;Q299357
0
StoopidisAuthor Commented:
Thanks lrmoore,

sorry but I forgot to specify that it is a 'win 2000 server' machine hosting the broadband connection and printer. All the other machines are 'win 2000'

I've had a search for a similar article and couldn't turn anything up.

Will your suggestion still apply for win 2000.?
If so can you help me with a link or some advice?
and
Is it the TCP/IP on the 'win 2000 server' machine that i need to reset?

appologies for the previous lack of OS ver.

Thanks in advance - Stoopidis
0
Cloud Class® Course: Microsoft Office 2010

This course will introduce you to the interfaces and features of Microsoft Office 2010 Word, Excel, PowerPoint, Outlook, and Access. You will learn about the features that are shared between all products in the Office suite, as well as the new features that are product specific.

lrmooreCommented:
Yes, the XP directions apply to Win2k also.
Do this on the server...
0
StoopidisAuthor Commented:
Great.. i'll give it a go and get back to you .. cheers
0
lrmooreCommented:
Have you installed SP4 perchance?
If yes, can you rollback to SP3?
If not, suggest giving it a go..
0
bbaoIT ConsultantCommented:
it looks it is a game related problem, did you install any game before?
0
StoopidisAuthor Commented:
Ok..


No it's not game related . I've done a search for the problem and a similar type of query was raised on a couple of game forums but no solution. thanks though.

lrmoore...
I tried the win xp method but it doesnt work.. there is a netsh utility but 'netsh int ip reset logfile.txt' is and unrecognised command.

sp4 is installed. If I uninstall it using add remove programs what other automatic updates do i have to remove?

cheers Stoopidis



0
lrmooreCommented:
Did you have this problem before you installed SP4?

If you choose uninstall, it should ask you if you want to roll back to SP3 version...
0
StoopidisAuthor Commented:
No the problem has never happened before but it has only just occured and SP4 was installed ages ago
0
StoopidisAuthor Commented:
Ok... now i have rolled back to service pack 3 which caused the OS to fail everytime the boot sequence had just about ended even if i tried to boot into the last known successful configuration. couldn't boot into safe mode ... nothing. So I reinstalled OS over the top and hey presto!!!!..........Still getting the same problem........It's a mystery.....any more ideas......

Stoopidis
0
lrmooreCommented:
ew...
How about a fresh clean install, then apply all service packs?
0
bbaoIT ConsultantCommented:
i think the key is icc. icc should stands on Internet Control Center, here is its homepage:

http://www.usefulware.com/cmdialup.asp

I got confusion too, since you said you are "still getting the same problem" after you "reinstalled OS over the top".

"over the top"? not a fresh clean install? just re-install over the previous one? so all your applications keeped including icc.
0
GnartCommented:
Stoopiditis,

If "SP4 installed a long time ago" and other hot-fixes/patches have been installed, roll-back may do more harm than good.  Forget about ICS and Broadband combo, they have problems because of the softmodem code incompatability which is what you are running into.  

Get yourself a broadband router.  Remove the DSL software from your W2K and their softmodem drivers.  Connect the DSL modem to the router and set the router as your default Internet gateway for the hosts....

The broadband router should provide DHCP, NAT, Routing, DMZ and the more expensive one $80 or more will provide VPN capabilities.

cheers
0
StoopidisAuthor Commented:
Gnartart..........

Thanks for the pearls of wisdom. If only it answered my question.......All i want to do is stop the stoopid message popping up.. .. . . it only started doing it about a week ago after nearly two years of no problems with the setup what so ever. so why change it if it's not broken.(much)

if i'm gonna give 500 points for a question then i expect an expert answer rather than an expensive workaround... or a suggestion (like rolling back the service pack - thanks lrmoore)
that turns out causing more harm than good.....thanks for pointing that out in your post by the way... It's always great to be told something you've already found out the hard way.

Do you have any, more direct, ideas of what the problem is or how to solve it.

If i am understanding your post right and it is a problem with the sofmodem code incompatibility (whatever that is).... and it was working before..... then am i to asume that it's driver has somehow become corrupted....in which case if  i uninstall the modem and all it's drivers then reinstall it .....

good health


0
bbaoIT ConsultantCommented:
just learned about "icc" and "icc runtime", AFIAK, icc is NOT a standard built-in component of windows, it is "Internet Control Center", a 3rd party software that allows for PUSH technology, dialup access, messaging, and other access and Internet application management.

the focus should be on icc, not sp4 or ics, i think.

Stoopidis, are you sure you did install ICC before?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
GnartCommented:
The messsage is from your DSL/modem software - if you install the software it will install the Internet Control Center - the helpme center - the IP statistic monitor (to knock you off if you sit idle), etc....

I ran into ICC, my problem is slightly different - it reboots my system each time I boot up to give its softmodem software time to connect so it would seem that I am connected all the time.  I took it off my problems disappeared.

I discovered about other software because my firewall reported the software attempted to call home - including ICC.  BTW, Did you block ICC?  removing the block may solve your problem.

Again, it's my two cents here - you would do much better by putting in a DSL/modem instead of the DSL/modem software and ICS.  It would solve all of your problems.

cheers
0
bbaoIT ConsultantCommented:
Stoopidis, any update news?
0
ilikemycarCommented:
Stoopidis,
Did you get anywhere with this?
I have an NT4 server which is our primary web server, which has also suddenly developed this fault out of the blue.
Cheers
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.