• C

Urgent please.. C-GNU MAKE

Hi all,

would appreciate help pls

I have SUN OS 5.8 HERE..

I am actually trying to install GNU MAKE 3.79 version.
I don't know much about it..

but i downloaded .gz file.. from gnu.org website..

i gunzipped it..
i untarred it..

i did this

 CFLAGS="-pipe -O" LDFLAGS="-s" ./configure --prefix=/usr/gnu

to install it..

it displays as below:

#  CFLAGS="-pipe -O" LDFLAGS="-s" ./configure --prefix=/usr/gnu
loading cache ./config.cache
checking for a BSD compatible install... ./install-sh -c
checking whether build environment is sane... yes
checking whether make sets ${MAKE}... ./configure: make: not found
checking for working aclocal... missing
checking for working autoconf... missing
checking for working automake... missing
checking for working autoheader... missing
checking for working makeinfo... missing
checking host system type... sparc-sun-solaris2.8
checking whether make sets ${MAKE}... (cached) no
checking for gcc... no
checking for cc... no
configure: error: no acceptable cc found in $PATH

in my path

# env | grep PATH

I don't think i have c complier here on this server.. unless c compiler comes with SUN OS 5.8. I don't know.. how to check?

we are not using c on this server.. we use JAVA
do i need c compiler for installing GNU MAKE???

if yes where to get it from? how to install it?

else how to install GNU MAKE?

Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Kent OlsenDBACommented:

This install utility needs a C compiler to build GNU-Make and it appears that your system doesn't have C installed.

You should be able to go to gcc.gnu.org and download a gcc .tar file.  The file will contain a C compile in object form that will run on your Sun system.

If you can't find it there, try www.sunfreeware.com

Good Luck!

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Tommy BraasCommented:
If I were you I would ask your sysop (administrator) to install what you need. You probably have a bunch of dev tools installed on the server already, or on another server, but since they are not in your path, you can't find them.

Good luck,

shivaniAuthor Commented:
there is no sys admin here. So all installation I have to do as part of learnings.

I will try to download the gcc as you suggested.

I read at one place,
if I put /usr/ccs/bin in path, it might work.
I have /usr/ccs/bin on my server. can it help anything?
what is ccs? its not c compiler right?

The 7 Worst Nightmares of a Sysadmin

Fear not! To defend your business’ IT systems we’re going to shine a light on the seven most sinister terrors that haunt sysadmins. That way you can be sure there’s nothing in your stack waiting to go bump in the night.

shivaniAuthor Commented:
can u also pls suggest, how to modify path on my unix prompt..

when I login as root, i get prompt as

which shell is it?

How to set the path,
right now..
# echo $PATH

I want to try to include /usr/ccs/bin

in your .bash_profile or .profile or equivalent file

add a line

log out and then login

>I don't think i have c complier here on this server.. unless c compiler comes with SUN OS 5.8. I don't know.. how to check?
My guess would be that you have it ... its just not in your path... though it generally has its executable/soft link in /usr/bin...

try this

locate gcc
which gcc

what do these two commands return ... if they do not return anything, then you do not have gcc installed and will have to download and install it from gcc.gnu.org

>do i need c compiler for installing GNU MAKE???
as Kent said, yes you do

>how to install it?

In the PATH settings which I posted in the previous post, make sure that there is an export statement present for exporting the PATH variable
you will get the sources from the site ... there will be a README or INSTALL file in the untared sources... read that for installation instructions
shivaniAuthor Commented:
# locate gcc
locate: not found
# which gcc
no gcc in /usr/sbin /usr/bin

i could not get gcc from gcc.gnu.org..

but i got it from sunfreeware.com

i got this file gcc_small-3.3.2-sol8-sparc-local.gz

Hope this will work..?? any ideas?

I tried putting usr/ccs/bin in path.. doesn't work.. get same error..

shivaniAuthor Commented:
Well, I gunzipped it..

it has one file in it..

no installation instructions or anything..

any ideas what to do with it?
Kent OlsenDBACommented:

Since the compiler should be the compiler object code and all of the include libraries, this may be a self installing object module.

Try executing it from root.

shivaniAuthor Commented:
I tried this as root..

chmod +x gcc_small-3.3.2-sol8-sparc-local

got some weird msg's.. as below..

./gcc_small-3.3.2-sol8-sparc-local: 1: not found
./gcc_small-3.3.2-sol8-sparc-local: 1: not found
./gcc_small-3.3.2-sol8-sparc-local: 1: not found
./gcc_small-3.3.2-sol8-sparc-local: 1: not found
./gcc_small-3.3.2-sol8-sparc-local: 1: not found
./gcc_small-3.3.2-sol8-sparc-local: 1: not found
./gcc_small-3.3.2-sol8-sparc-local: 1: not found
./gcc_small-3.3.2-sol8-sparc-local: 07070100000000000000000000000000000000000000010000000000000000000000000000000000000000000000000000000b00000000TRAILER!!!07070100156952000081a40000000a0000000a000000013fa0c1e8000000b4000000880000000a00000000000000000000000800000004pkginfoPKG=SMCgcc: not found
./gcc_small-3.3.2-sol8-sparc-local: Software: not found
./gcc_small-3.3.2-sol8-sparc-local: Christensen: not found
./gcc_small-3.3.2-sol8-sparc-local: 07070100156951000081a40000000a0000000a000000013fa0c1f100007951000000880000000a00000000000000000000000700000004pkgmap:: not found


/gcc_small-3.3.2-sol8-sparc-local: 1: not found
./gcc_small-3.3.2-sol8-sparc-local: 1: not found
./gcc_small-3.3.2-sol8-sparc-local: 1: not found
./gcc_small-3.3.2-sol8-sparc-local: 1: not found
./gcc_small-3.3.2-sol8-sparc-local: 1: not found
./gcc_small-3.3.2-sol8-sparc-local: 1: not found
./gcc_small-3.3.2-sol8-sparc-local: syntax error at line 798: `(' unexpected

(Please note that this is not a complete message..) it was not possible to scroll the whole msg..

any ideas?
shivaniAuthor Commented:
Just FYI,

# ls -al
total 145876
drwxr-xr-x   2 root     other        512 Nov 13 10:10 .
drwxr-xr-x   8 root     other        512 Nov 12 22:28 ..
-rwxr-xr-x   1 root     other    74633216 Nov 12 22:51 gcc_small-3.3.2-sol8-sparc-local

to tell you size of file
Kent OlsenDBACommented:

Hi shivani,

http://www.sunfreeware.com/gcc.html  has this disclaimer:

To use the gcc package from sunfreeware.com you MUST install all of the SUNW developer packages that come on Sun's Solaris CDs.

shivaniAuthor Commented:

i don't have CD right now..

can i download gcc from somehwre else.. ?? or any other package from sunfreeware.com which might work..

anyway, i am trying gcc.gnu.com .. other website u gave me..

it will take long to FTP the stuff.. (sinze it is not zipped or anything)

so i have to be patient i think..

shivaniAuthor Commented:
it will take 7 hours to download GCC from GNU.. because it is not in zipped format..

sucks.. but no choice i think right?
Kent OlsenDBACommented:

Wow.  7 hours?

I'm not aware of object code for Sun being available from gcc.gnu.org.  What are your downloading and where did you find it?

shivaniAuthor Commented:
CLICK US (Virginia): mirrors.rcn.net (also available via http)
shivaniAuthor Commented:
Oops, i was downloading whole crap..

can i just go there


and download

shivaniAuthor Commented:
any help here plz

sounds like sources for red hat linux ... look for solaris sources

do you have pkg-get installed ... if yes, then simply give

pkg-get install gcc

and it will handle the rest (download and install )

else, get the binaries from:::
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.