XP Scheduler not firing

I have recently changed my PC and am trying to do the following - in my previous PC, whether i am logged or in standby mode the scheduler used to get fired - but now it works only if I am logged in to the PC - What am i missing?
LVL 4
komandurAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

komandurAuthor Commented:
i am running windows media player as a sort of "wake up" call - it used to work beautifully...with the list of songs i have my kids get ready for school when certain number of songs finishes....how can i get it to work without having logged in...it was working so i know it is possible.

win xp professional
0
sunray_2003Commented:
Dear komandur,

My understanding is that Accounts in which scheduler runs should have a password.
Go to control panel --> User accounts and click on the account ( which you use ) and enable password for it

Check to see if this would solve the issue

Thanks,
Sunray
0
sunray_2003Commented:
When you said previous PC, what that windows xp

S
0
Challenges in Government Cyber Security

Has cyber security been a challenge in your government organization? Are you looking to improve your government's network security? Learn more about how to improve your government organization's security by viewing our on-demand webinar!

komandurAuthor Commented:
yeah the previous one was also win xp prof - and the account thro' which i run already has a password. It used to wakeup the PC and run it also. Now it expects me to be logged in to run this....
0
Luc FrankenEMEA Server EngineerCommented:
Look at the properties of the task you've scheduled, make sure you use the runas function and put the right password there.

LucF
0
komandurAuthor Commented:
yeah it is. If I open the scheduler and choose to run that task, it does it correctly. It runs fine so long as I am logged in- the moment i logout or sleep the PC, it fails to fire...No clue in the event viewer for why it failed also...what am i missing?
0
Luc FrankenEMEA Server EngineerCommented:
rightclick on the task, choose properties, check "run as" and put "Domainname\username" (if you use this computer locally without a domain, just put the username there" then click set password and put the right password there twice

LucF
0
komandurAuthor Commented:
no luck...even if i put only the username, it is automatically changing it to domainname\username - still not working if i logoff...any more ideas? is there somewhere a log that will tell me why it failed?

isn't it supposed to fire even if the user is logged off? or does my window media player is not able to run as "service"?
0
Luc FrankenEMEA Server EngineerCommented:
>isn't it supposed to fire even if the user is logged off?
Only if that user has administrative rights as far as I know. Someone correct me if I'm wrong.
0
komandurAuthor Commented:
yeah the user does have administrative rights
0
KenneniahCommented:
On the settings tab under properties for the scheduled task is the checkbox for Wake the computer to run this task checked?
0
komandurAuthor Commented:
It is checked - Isn't that to wake it up if it is in suspend mode - It doesn't work even if i am logged off...sort of windows media player is refusing to run as service...
0
marc_nivensCommented:
schedule the task with AT and use the /interactive switch.  The task will then run as local system and logoff/screen saver will not affect it.
0
komandurAuthor Commented:
This is the command it runs at specified time in the morning

"C:\Documents and Settings\All Users\Documents\My Music\My Playlists\Wakeup Songs.wpl"

Please tell me where to add this switch..

thanks
kannan
0
marc_nivensCommented:
should be something like this, assuming you're running it at 7:00:

at \\computername 7:00 /interactive "C:\Documents and Settings\All Users\Documents\My Music\My Playlists\Wakeup Songs.wpl"
0
komandurAuthor Commented:
it did not work. though it added in the schedule and promptly deleted it. Remember everything works fine so long as i am logged in..
0
komandurAuthor Commented:
it doesn't work even if another user is logged in..that means it somehow expects the creator to be logged in...how can i make this run as a "service" - i never had trouble doing this in my previous pc - i don't understand why it is failing now..
0
komandurAuthor Commented:
I have resolved it finally by installing the SP 1a. There is also an article on this by microsoft. See:

http://support.microsoft.com/default.aspx?scid=kb;en-us;812400

thanks for all the assistance.

Now how do i go about deleting this question?

0
KenneniahCommented:
To have the question deleted and be refunded points follow the instructions at:
http://www.experts-exchange.com/help.jsp#hi70
0
grostonCommented:
To the system administrators:

Please give komandur the points for this question. This issue has been plaguing me and his answer was the absolute right one.

Thanks!
0
moduloCommented:
PAQed, with points refunded (50)

modulo
Community Support Moderator
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
OS Security

From novice to tech pro — start learning today.