Solved

Cannot view folders using IE6 in OWA

Posted on 2003-11-12
13
1,491 Views
Last Modified: 2012-06-21
I have seen postings to similar types of errors posted here before, but none that describe the exact problem that I am having. The Microsoft fix when receiving the error did not help:
http://support.microsoft.com/default.aspx?scid=kb;en-us;315515. I will try some of the other recommended solutions, but I still wanted to post my question to see if anyone had a sure answer.

Anyway, here is the problem I am having, along with all of the users on my network who connect via Outlook Web Access.
When viewing email in OWA via Internet Explorer 6 SP1, I can log in fine and see the email in my Inbox, but the folders do not display in the left-hand pane. When I click the folders button, I just get "Loading...", but nothing appears. At the bottom of the screen is a java script error that reads:

Line: 1272
Char: 2
Error: Invalid procedure call or argument
Code: 0
URL: http://server1/exchweb/CONTROLS/ctrl_Tree20.htc
(Microsoft says that the fix for this error is the link that I posted at the top of this message, but that did not resolve the problem)

Continously hitting the refresh button will sometimes bring up the folders, but not everytime. One strange thing is though, is that this problem doesn't happen if I connect to OWA when connected through Netscape. The folders can be displayed fine. Also, this problem used to only occur when dialed up over a phone line. When connected directly to the LAN, everything was fine. But now both dialup and the LAN users are having this problem. I've searched on the web and a couple of sites mention that I might see these kinds of conditions after loading Exchange SP3. I loaded SP3 in September, and this is about the time that one of our users said he started experiencing the problem. Its been like this since apparently, though I wasn't aware of it until about a month ago. Please help if anyone has any sugguestions. I'm assuming that this is a problem residing within the configuration of OWA (file permissions, settings, etc), but not sure. Being that Netscape works, I cant be sure where the problem lies. This question is worth 500 points, since I need to get a solution soon. Thanks.

To better help solve the problem, here is the configuration that I have:

W2K Advanced Server w/ Exchange 2000 SP3, and latest hofixes.
Clients use W2K w/ Internet Explorer 6.0 SP1
0
Comment
Question by:spawar
  • 4
  • 3
  • 3
  • +2
13 Comments
 
LVL 10

Expert Comment

by:pcbrat
ID: 9745017
I know this sounds brutal, but try rolling back your Service and see if that helps. If it does resolve it then you should complain to MS. This sounds like a Hotfix problem. And although they will deny it I know for a fact that they are notorious for breaking something else after supposedly fixing one thing. See link :)

http://support.microsoft.com/default.aspx?scid=kb;en-us;330220&Product=exch2k

dawne :)
0
 

Author Comment

by:spawar
ID: 9769150
Thanks for the help. I followed your link, in which Microsoft says to installed the March 2003 Rollup Patch for Exchange. I already had this patch installed, and I think this is the one that caused the problem. So instead of unisntalling it, I installed yet another cumulative rollup patch for Exchange from September. The server now had all of the latest hotfixes, but still no go on the OWA problem. I tried reapplying the Iislockdown tool, and even removing its settings totally. Again, nothing. Anything else you can sugguest? Thanks.
0
 
LVL 10

Expert Comment

by:pcbrat
ID: 9772054
Iislockdown tool???

NOOOOOOOOOOOOOOO

Remove that...never put IIS Lockdown on any server running OWA...It breaks it!!

Ok you need to reinstall Exchange and IIS....try IIS first.......

IIS Lockdown messes with the permissions on the "M" drive....

here is a quick link to all things IIS and breaking :) LOL

http://support.microsoft.com/default.aspx?scid=kb;en-us;309677&Product=exch2k

Try reinstalling IIS and see if that fixes it....if not you may have to reinstall Exchange and then re hot fix it...WITHOUT IIS Lockdown!

I'll send you some more links.....see if you can tweak it before you do anything...check the link!

dawne


0
 

Author Comment

by:spawar
ID: 9776678
IIS was installed at one point, though I don't remember why we installed it. I removed it the other day, along with the URL Scan tool. It is gone now. So you are saying that even though it is gone, the permissions that it changed won't be returned? I'd hate to have to reinstall Exchange to fix this one small OWA problem. Everything else works, and Netscape works when IE wont work with OWA. Do you have any links for the best way to remove IIS on the Exchange server, with minimal impact to the rest of Exchange? Please let me know. Thanks again.
0
 
LVL 10

Expert Comment

by:pcbrat
ID: 9780802
You need IIS in the Exchange server for OWA to work....you dont need the IIS Lockdown tool!

Reinstall IIS and then see if that helps....if it doesnt then you will need to reinstall Exchange....you wont need to recreate mailboxes.....just have everybody out of them while you do it...then reservice pack.

IIS Lockdown tool changes the perms on the M drive.....that is where OWA sits.... DONT MESS WITH The M Drive!

Try what I said and see if it helps....
0
 
LVL 1

Expert Comment

by:stuartharrison
ID: 9972530
Hi I am having the exact same problem!

I have two Windows 2000 Servers SP4, One is the Exchange Server 2000 SP3, Sept Post SP3 Patch installed. This problem just appeared for me last week, no apparent reason why?

I have installed the MS Hot fix http://support.microsoft.com/default.aspx?scid=kb;en-us;330220&Product=exch2k

Which did not resolve the issue. I have tried reinstalling the W2K SP4 service pack and the Exchange service packs. I have uninstalled the IIS Lockdown tool and Urlscan but the problem remained. I then reinstalled the Lockdown tool and Urlscan, as I installed these on the original set-up and didn't have any problems with them until now?
So what am I left with? Uninstall / Reinstall IIS? Or reinstall Exchange server?

There is the issue in http://support.microsoft.com/?id=kb;en-us;323672 about Exchange Routing Engine Service Does Not Start Automatically or Manually After You Remove IIS and Then Reinstall It. Which concerns me, the next step in that article is to reinstall exchange.

I am new to Exchange 2000 as I have been using Lotus Notes for the last 3 years! I am not feeling confident about reinstalling Exchange! I would like to know the outcome of the original authors posting "spawar" ???

I am getting several errors when login into OWA using IE 6.0 SP1 (it works in a Netscape browser).

"An Internal Server Error occurred" pops up twice, then loading is displayed and the emails never load.

I am also seeing various script errors in IE:-

Error1:-

Line: 14
Char: 1
Error: Automation server can't create object
Code: 0
URL: http://domainname/exchange/administrator/inbox/?Cmd=contents

Error2:-

Line: 1191
Char: 4
Error: Automation server can't create object
Code: 0
URL: http://domainname/exchweb/controls/ctrl_tree20.htc

Error3:-

Line: 1704
Char: 3
Error: Automation server can't create object
Code: 0
URL: http://domainname/exchweb/controls/ctrl_view20.htc

I have even replaced the files mentioned in the script errors in a vain attempt to fix this issue.
I am also using Veritas Backup Exec V9.0, if you need to know about my backup system?

Please help I am desperate!

Many Thanks.





0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 

Author Comment

by:spawar
ID: 9989640
Hi,

 Its been a while since I was able to resolve my problem, but havent had time to post my findings on EE. After all the unecessary work I did.....(uninstalled service packs, iislockdown, and various patches), I found that those weren't the problem at all. It was a file that I was missing in my Exchweb/controls directory called "ctrl_Tree20.js". After researching my error message a million times, I decided to look at the scripting error that I was getting. Atfer careful searching line by line, I found that the script was calling for a java file of "ctrl_Tree20.js". I did a search on my entire exchange system, and found nothing. I have no idea why it was no longer there, but it was gone. To make things worse, I couldn't locate it anywhere on the Internet, and I didn't have a backup of the file. So I decided as a test, to download Exchange Service Pack 3, and search it for that file. I didn't reapply service pack 3, I just downloaded it and extracted the file. Sure enough, that missing java file was in there. I copied it to my Exchweb/contols directory, and.......waallaa! It worked! My folders came back and I no longer had any scripting errors. I double checked by using OWA in Netscape and Opera, as well as IE. I haven't had any problems with it since. So in your case, since you have multiple errors regarding http://domainname/exchweb/controls/ctrl_view20.htc, I would guess that you might also be missing a file or so. I would carefully examine your event logs, and open up the htc file in Notepad and look for any files that it might be calling. Make sure that you have those files installed, and if not, search for them in the Exchange SP3 download. I don't know if your problem is exactly the same as mine since I didnt get those same errors you had. But regardless, sounds like it is still somehow related to the ctrl_view20.htc file not being able to function. Try and repost with your results.
 
 Thanks.
 SPAWAR

0
 
LVL 1

Expert Comment

by:stuartharrison
ID: 9990348

Thanks for your comments Spawar.  I have looked for the file you had missing and it is present on my server. I have run up another Exchange server on VMWare Virtual Machine, in that instance of Exchange 2000 the owa is working ok! There is 113 files in the exchweb/controls directory on both the live and virtual servers. I have even copied the files from the virtual machine over the top of the controls directory on the live server, in the hope any corruption in the controls directory would be fixed.
This has not resolved the issue, I am still getting "Internal Server Error Occurred" and the script errors. Seems like I have a different problem! This is so frustrating as I am sure I have not configured it wrong, as it was working fine for 3 months. This must be a bug or some form or corruption?
Guess I will have to reinstall Exchange and maybe IIS ? not too happy about that prospect as I haven't done that before! Any tips from anyone on how to safely do this?
Does anyone else know what might be causing these problems with OWA??

Well thanks for your help! Happy Xmas!

Thanks
0
 
LVL 1

Expert Comment

by:stuartharrison
ID: 9990437
I have also posted my own question here

http://beta.experts-exchange.com/Applications/Email/Q_20830582.html

worth 500 points!

Thanks
0
 
LVL 1

Expert Comment

by:stuartharrison
ID: 10094772
I have contact Microsoft Tech Support, it cost a pretty penny! however they have resolved this issue.

This problem is something to do with MSXML. Seems like some kind of corruption.
If you look in WINNT\SYSTEM32 Folder there are several MSXML.DLL files.
On my system I have the following:-

maxml.dll
msxml4r.dll
msxml3.dll
msxml3a.dll
msxml3r.dll
msxml4.dll

I was instructed to:-

Run the following command from the command prompt:
 
tlist -m msxml.dll
make sure that the module isn't loaded under and tasks.
 
then run regsvr32 msxml.dll

I had to do this for each of the dll's listed above.

Some registered successfully however others came up with an error warning.
This didn't seem to matter however as my OWA is now working!

I have asked Microsoft to comfirm in more detail why this happened on my system?? I have also asked them about their position on weather you should use the IIS lockdown and Url Scan tools on Exchange servers running OWA? as different people have different opinions on this!

So if I hear any more information I will post it here!

Hope this helps, if anyone else has a similar nightmare, shame no one knew the answer on Experts Exchange!

Thanks.
0
 

Expert Comment

by:saxonchan
ID: 10976176
I have find a related message post on another forum saying that it's a bug of IIS6.0 and already confirmed by Microsoft. (the compression error of IIS6 cache).
Here is the hotfix for it http://support.microsoft.com/?id=831464

Acutally, I didn't install yet.
The problem dissappeard after I follow the workaround on that kbid.
to empty the IIS6.0 Temp file located on
 "%windir%\IIS Temporary Compressed Files".

I even didn't do the last steps ( run  IISReset in cmd)
0
 

Accepted Solution

by:
modulo earned 0 total points
ID: 12802938
PAQed with points refunded (500)

modulo
Community Support Moderator
0

Featured Post

Highfive Gives IT Their Time Back

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

Pegasus Mail (http://www.pmail.com/) is a donation ware that is a collaboration of David Harris along with his team members. It is a desktop mail client that offers the option of configuring more than one mail account with single set up. It supports…
User Beware!  This is a rather permanent solution to removing your email from an exchange server.  The only way to truly go back is to have your exchange administrator restore your mailbox from backups.  This is usually the option of last resort.  A…
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…
This video shows how to remove a single email address from the Outlook 2010 Auto Suggestion memory. NOTE: For Outlook 2016 and 2013 perform the exact same steps. Open a new email: Click the New email button in Outlook. Start typing the address: …

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now