Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Remote desktop connection (LAN / Internet)

Posted on 2003-11-13
5
Medium Priority
?
1,231 Views
Last Modified: 2010-04-11
Greetings.
 
Server OS : Win 2k Server

When i use Romote Terminal Services (RTS) from Win 2k Pro within LAN, there will be authentication to enter the password. So, the user need to enter username and password.

But if i dial up from Internet  and connect using RTS to the same Win 2k Server, it will auto-logon using a valid default username (tlsinternetuser) and password. It will not ask to enter password.

How to force the user to enter username and password if they connect from Internet? Otherswise, it will be a disaster if everyone can login without any authentication..

Thanks in advance.
0
Comment
Question by:pandav
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
5 Comments
 
LVL 9

Expert Comment

by:TooKoolKris
ID: 9739167
To Make Changes to the Automatic Logon Information

Click Start, point to Programs, point to Terminal Services Client, and then click Client Connection Manager.
Click the connection you want to change.
On the File menu, click Properties.
On the General tab, under Log on automatically with this information, type a new user name, password, or domain name.

Read here about other configurations:
http://support.microsoft.com/default.aspx?scid=kb;en-us;306573&Product=win2000
http://support.microsoft.com/default.aspx?scid=kb;en-us;300847&Product=win2000
0
 
LVL 18

Accepted Solution

by:
chicagoan earned 500 total points
ID: 9740249
I think you want to modify the way the terminal SERVER behaves.

By default, a Windows 2000 Server Terminal Services connection always prompts for a password, even if you've configured one in the connection logon information of the client. To contol this behavior:

Start the Microsoft Management Console (MMC) Terminal Services Configuration snap-in
(Start, Programs, Administrative Tools, Terminal Services Configuration).
Right-click the configuration for which you want to modify the default password setting
Select Properties from the context menu.
Select the Logon Settings tab.
Note the "Always prompt for password" check box. Check this box to always prompt for a password.
Click Apply, then click OK.
Close the dialog box. Future connections should be forces to make a password entry, which will defeat automatic logon.

I would also check the username and make sure there IS a password!
0

Featured Post

Three Reasons Why Backup is Strategic

Backup is strategic to your business because your data is strategic to your business. Without backup, your business will fail. This white paper explains why it is vital for you to design and immediately execute a backup strategy to protect 100 percent of your data.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Check out the latest tech news, community articles, and expert highlights in August's newsletter.
What we learned in Webroot's webinar on multi-vector protection.
The Email Laundry PDF encryption service allows companies to send confidential encrypted  emails to anybody. The PDF document can also contain attachments that are embedded in the encrypted PDF. The password is randomly generated by The Email Laundr…
Sometimes it takes a new vantage point, apart from our everyday security practices, to truly see our Active Directory (AD) vulnerabilities. We get used to implementing the same techniques and checking the same areas for a breach. This pattern can re…

715 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question