File Sharing No Go

Mac OS9.1 on both Powerbook 3400c/240 & G4. Until earlier today, file sharing worked perfectly. But I got it into my head to initialise the Powerbook and switch to extended format (from standard format), then reinstalled 9.1. Seemed okay, till I discovered file sharing is not happening.

Using PB as host, Connect as Guest is grayed out. Checked File Sharing & Users & Groups, and guest is allowed access to computer and programs. Trashed the preference files for File Sharing & Users and Groups, restarted, and tried again. Still no go.  Zapped the PRAM. Still no go. Tried using G4 as host. Same story.  Tried to create new user, with password. Cannot access. Users & Groups shows Guest access to computer and programs, but it's not working!

The host computer shows up when AppleShare is selected in the Chooser. AppleTalk is active, ethernet, but I cannot get file sharing to work.

Need to connect via ethernet. (PB modem is dead, so remote access is not possible.)

HELP? -- D. Chan
D_ChanAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ckurt99Commented:
This doesn't really answer your question, since I am having trouble imagining why Guest is not showing up, but... each of your computers has an identity unique to itself, have you tried connecting as that actual (remote) identity, using the password from the remote computer?  This requires you to set up accounts on the local computer that mimics the remote computer's name, as you seem to be familiar with doing.  It has the downside that once you sign in as "remote owner" you get total access to the remote machine, which perhaps is more access than you want granted, but it should work.

Along the more general lines, have you actually started File Sharing?  You have to go into Control Panels and find the File Sharing control panel, open it up, fill in the fields for owner and password, and then start file sharing by clicking on the button.  But you probably already knew this... if not, see http://docs.info.apple.com/article.html?artnum=106657 .


Kurt
D_ChanAuthor Commented:
Thanks. In the meantime, resolved problem. It turned out to be a simple fix. Selected hard drive on the host computer, typed Command-I for Information, pulled down Sharing, and found that no access had been granted to others, so adjusted the settings, and started up file sharing . . . works just fine without any hitch whatsoever. -- D. Chan
moduloCommented:
PAQed with points refunded (500)

modulo
Community Support Moderator

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Apple Networking

From novice to tech pro — start learning today.