• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 524
  • Last Modified:

Cannot print to networked printer via PC with active internet connection

I have a Windows XP computer that has one network card for the local (192.168.0.*) network and connects to the internet.  It is the gateway for the other computers on the network to get to the internet.  I have a Linksys Printserver with a HP printer on it.  I can ping the printserver with no problem.  When I go to print to it, it always gives me a connection error.  SCA91261_P1 is the name given to the printserver.  This is not adjustable.

I have a networked computer @ 192.168.0.1
This computer connects to the interet via 10.5.226.71
I have a networked printer @ 192.168.0.10
There are 2 other computers on the network that can print.

***  host  ***
127.0.0.1       localhost
192.168.0.10 SCA91261_P1

*** routing table ***
Active Routes:
Network Destination        Netmask          Gateway       Interface  Metric
          0.0.0.0          0.0.0.0      66.82.12.17     10.5.226.71       1
       10.5.226.0    255.255.255.0      10.5.226.71     10.5.226.71       30
      10.5.226.71  255.255.255.255        127.0.0.1       127.0.0.1       30
   10.255.255.255  255.255.255.255      10.5.226.71     10.5.226.71       30
        127.0.0.0        255.0.0.0        127.0.0.1       127.0.0.1       1
      192.168.0.0    255.255.255.0      192.168.0.1     192.168.0.1       20
      192.168.0.1  255.255.255.255        127.0.0.1       127.0.0.1       20
    192.168.0.255  255.255.255.255      192.168.0.1     192.168.0.1       20
        224.0.0.0        240.0.0.0      10.5.226.71     10.5.226.71       30
        224.0.0.0        240.0.0.0      192.168.0.1     192.168.0.1       20
  255.255.255.255  255.255.255.255      10.5.226.71     10.5.226.71       1
  255.255.255.255  255.255.255.255      192.168.0.1     192.168.0.1       1
Default Gateway:       66.82.12.17

Any help in getting the computer to print to the print while the other network is also active would be greatly appreciated!
0
DizTorDed
Asked:
DizTorDed
  • 3
  • 3
1 Solution
 
hdhondtCommented:
With XP your IP protocol would default to "raw" (aka Appsocket). It is possible that the printserver does not support this. You can change the protocol to "lpr" which is more likely to be supported as it is an older protocol.

To do this, go to Printer Properties, click on the Ports tab, and then on the Configure Port button. Click on the LPR radio button. You will also need to enter a name for the Queue Name. This is device dependent, but, if this is your problem, the other PCs should already have the correct name.
0
 
DizTorDedAuthor Commented:
I am using a Linksys PPSX1 as the print server.  When I click on the port properties, there is no option to select RAW or LPR.  I tried to create a a Standard TCP/IP port.  This did not work.  However, I did notice that the traffic, when using the TCP/IP port, was on the intranet as apposed to the PRINTSERVER port which goes to the internet.
0
 
hdhondtCommented:
As the Printserver has address 192.168.0.10 (SCA91261_P1) any traffic to it should only go to the intranet. Addresses starting with 192.168 are not routed to the internet. What do you mean when you say "the PRINTSERVER port goes to the internet"?

What settings do the other PCs use to connect to the printserver? Check under the "Ports" tab to see if that gives any clues.
0
Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
DizTorDedAuthor Commented:
When I state that "it goes to the internet" I mean that it only tries the network connection that is for the internet and does not try the network connection for the intranet.  I get this info via the  network monitors on the task bar.  The one for the intranet never blinks while the internet connection blinks.

Under Ports, I have selected SCA91261_P1   PRINTSERVER Port  HP Photosmart 1115.
0
 
hdhondtCommented:
Your description of the port means that the port name is SCA91261_P1 - that was the name given to it by whoever created the port. It's "description" is "Printserver port" and the "HP Photosmart 1115"entry is just a comment to tell the user which printer it really is.

To create one a Standard TCP/IP port:

1. Go to Printer Properties and click on the Ports tab
2. Click on the Add Port button
3. Select Standard TCP/IP Port and click on New Port
4. Enter 192.168.0.10 as the printer's IP address. You can change the name of the port to whatever you like, or leave it to the default. You should be able to printk like this.
5. If not, to enable LPR, click on the LPR button, and enter "L1" for the "Queue name" (if the printer is on the first parallel port of the printserver; change "1" if you use a different LPT)

This should work. For more info on Linksys, see
http://www.linksys.com/support/support.asp?spid=18#tcpip

Did you check what kind of port the other PCs use?
0
 
DizTorDedAuthor Commented:
I was able to finally get it to print!  Here is what I did....

1. Created a Standard TCP/IP port
2. Enter 192.168.0.10 as the printer's IP address.
3. After creating it, I configured the port for LPR.
4. Entered "L0" for the "Queue name"

I found one small blurb in the documents that stated that L0 was port one, L1 was port two and L2 was port three.
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now